Astroghost-Francois

Se fabriquer une camera AllSky pour moins de 100 Euros c'est possible ;-)

Recommended Posts

Le PoE ne consiste pas à alimenter la caméra sur le port Ethernet, mais permet de faire passer l'alimentation par ce port. Ça permet seulement de ne pas avoir une prise d'alimentation sur l'appareil, mais ça ne dispense pas de devoir relier à une alimentation les lignes Ethernet empruntées sur le port pour la circonstance.

 

Explications ici, par exemple.

 

Pas tout à fait vrai.

Si on dispose d'un routeur ou switch POE (avec des ports POE) on peut brancher directement la caméra (compatible POE) via le câble Ethernet sur le port POE du routeur/switch.

Il n'y aura dans ce cas là pas besoin d'alimentation supplémentaire.

 

Dans le cas de l'utilisation d'un routeur/switch non POE il faut utiliser un injecteur POE.

Share this post


Link to post
Share on other sites

C'est ce que je compte faire pour ma caméra, d'injecter le courant dans un adaptateur POE.

Mais du coup il n'y a pas de risques d'injecter aussi le courant dans l'autre sens vers le switch RJ45?

(J'imagine que ça doit être calculé pour que ça ne fasse pas de conneries mais bon...)

Share this post


Link to post
Share on other sites
C'est ce que je compte faire pour ma caméra, d'injecter le courant dans un adaptateur POE.

Mais du coup il n'y a pas de risques d'injecter aussi le courant dans l'autre sens vers le switch RJ45?

(J'imagine que ça doit être calculé pour que ça ne fasse pas de conneries mais bon...)

 

Non aucun risque.

L'injecteur a 2 ports Ethernet, un qui va de l'injecteur au switch un autre en direction de la caméra avec le courant injecté.

Sinon les simples splitter passifs comme la photo plus haut sont basés sur le même principe à la seule différence qu'ils utilisent l'alimentation de la caméra pour faire passer le courant (en général du 12v) contrairement aux 48v du standard POE.

Mais à l'autre bout il faut le même type de branchement pour extraire le courant du câble Ethernet pour alimenter la caméra par un câble séparé alors qu'avec un switch POE ou Injecteur POE on branche tout simplement le câble Ethernet sur la caméra qui récupérera les 48v pour son alimentation.

Sur une longue distance il vaut mieux utiliser un vrai injecteur POE (ou switch POE) car avec 48v la tension sera plus stable avec moins de perte que le faible courant procuré par l'alimentation de la caméra.

La ligne de courant est totalement séparée de la ligne data.

Elle utilise une paire de câbles inutilisés dans le câble Ethernet pour faire passer le courant.

 

Je n'ai jamais eu de problèmes avec les injecteurs POE que j'ai installé chez les clients ;)

 

253780.jpg

Edited by Phill68

Share this post


Link to post
Share on other sites

Pensez donc à commander en même temps et chez le même vendeur que la caméra un vrai injecteur POE.

Pour les 15€ que ça coûte cela vous donnera une meilleure solution que ces "splitter" bon marché.

 

http://fr.aliexpress.com/store/product/poe-injector-48V-16w-full-out-100Mbps-power-over-ethernet-single-POE-support-lighting-protection-802/410015_1707645355.html

Edited by Phill68

Share this post


Link to post
Share on other sites

Moi ça serait pour l'utiliser sur cette caméra ip qu'on voit sur la gauche au dessus de la porte:

 

37748c3695c002d7e86106db917e9b15b75a0fa2.jpg

 

Donc le cable réseau fait seulement 3 mètres jusqu'au switch, mais le cable d'alimentation est trop court!

Obligé de mettre une rallonge à la con au milieu du mur comme on peut le voir sur cette photo à gauche:

 

f5d7cf3e8712914230e59de10a529ab25b1da5c0.jpg

et puis deux cables c'est pas très beau...

 

Alors j'aimerais injecter le courant avec l'alim de la caméra au niveau du switch sous la table, et après au lieu d'utiliser l'extracteur qui est vendu avec l'injecteur, je pensais ouvrir la caméra et souder les deux fils de la prise RJ45 sur la prise d'alim de la caméra :)

Share this post


Link to post
Share on other sites

Mais les 48 Volts de l'injecteur vont pas griller la caméra? ( il me semble que la mienne c'est du 5V...)

Share this post


Link to post
Share on other sites
Ce n'est pas la peine de faire une bifurcation côté caméra.

 

17276-1458683313.jpg

 

Ton dessin est faux

Si tu utilises un splitter pour injecter du 12v tu ne peux pas alimenter la caméra par le port RJ45 de la caméra.

Il faut côté caméra extraire ces 12v et alimenter la caméra avec la prise d'alimentation.

C'est bien pour cette raison qu'il y a une paire de splitter.

 

L'alimentation POE (avec une caméra compatible POE) sur la prise RJ45 de la caméra se fait en 48v et non 12v.

Il faut pour cela un switch POE ou un injecteur POE.

 

Voilà le bon branchement

 

passive-poe-injector-splitter-network-diagram.jpg

Edited by Phill68

Share this post


Link to post
Share on other sites
Mais les 48 Volts de l'injecteur vont pas griller la caméra? ( il me semble que la mienne c'est du 5V...)

 

L'alimentation POE d'une caméra n'est que possible si la caméra est compatible POE.

Dans ce cas la caméra est alimenté en 48v par la prise RJ45 (ou directement par son bloc d'alimentation).

 

Si une caméra n'est pas compatible POE il faut utiliser son bloc d'alimentation ou passer par un splitter de part et d'autre comme dans l'exemple ci-dessus.

 

Et ne paniquez pas avec les 48v :D

Si vous branchez un câble POE (avec du 48v) sur une caméra non POE il ne se passera rien puisque les 2 pins RJ45 prévus pour le POE ne sont pas utilisés.

 

Les 5v de ta caméra se font sur la prise d'alimentation et non sur la prise Ethernet RJ45 comme c'est le cas des 48v pour le POE.

Edited by Phill68

Share this post


Link to post
Share on other sites
Alors j'aimerais injecter le courant avec l'alim de la caméra au niveau du switch sous la table, et après au lieu d'utiliser l'extracteur qui est vendu avec l'injecteur, je pensais ouvrir la caméra et souder les deux fils de la prise RJ45 sur la prise d'alim de la caméra :)

 

Surtout pas !

L'alimentation POE 48v sur la prise RJ45 est donnée par un injecteur ou un switch POE.

 

Ton bloc d'alimentation ne fait pas 48v et est prévu à être branché sur la prise d'alimentation de la caméra et non sur la RJ45.

 

Ensuite pour pouvoir alimenter ta caméra en POE par la prise RJ45 il faut aussi que ta caméra soit compatible POE.

Si elle n'est pas badgée POE cela ne fonctionnera pas.

 

La différence entre une caméra POE par rapport à une non POE c'est qu'elle dispose d'un circuit qui converti les 48v de la prise RJ45 en une tension nominale pour le fonctionnement (5v ou 12v).

Share this post


Link to post
Share on other sites
L'alimentation POE d'une caméra n'est que possible si la caméra est compatible POE.
"Mon" dessin vaut pour une caméra compatible avec le PoE, puisqu'il était question ici d'une caméra de ce type.

Share this post


Link to post
Share on other sites
L'alimentation POE (avec une caméra compatible POE) sur la prise RJ45 de la caméra se fait en 48v et non 12v.
Oui m'sieur, d'ailleurs, j'en ai une (BlackFly, toi y en a connaître ?).

Share this post


Link to post
Share on other sites

Pour faire plaisir au monsieur, compléments :

 

  • L'alimentation doit être de 48 V (pas 12 V) ;
  • La caméra doit être compatible PoE.

 

17276-1458683313.jpg

 

Ça y est, j'ai bon ?

Share this post


Link to post
Share on other sites
"Mon" dessin vaut pour une caméra compatible avec le PoE, puisqu'il était question ici d'une caméra de ce type.

Sauf que tu n'as pas compris ce qu'est le standard POE ni mes explications précédentes

 

Alors je vais développer ce qu'est le POE

 

La norme POE a été faite en 2003 pour alimenter des périphériques via le câble Ethernet en utilisant une paire de fils non utilisés dans le câble.

 

Pour cela il est nécessaire d'avoir d'un côté un switch ou routeur ou injecteur POE qui injectent du 48v dans le câble Ethernet et de l'autre côté un périphérique compatible POE qui est alimentée par les 48v à sa prise RJ45.

 

Une caméra POE peut être alimentée de 3 manières.

1. Par son bloc d'alimentation (12v en général) sur sa prise d'alimentation

2. Par POE avec un switch/routeur ou injecteur POE qui va envoyer du 48v dans le câble Ethernet et alimenter la caméra avec du 48v par sa prise RJ45

3. En déportant le bloc d'alimentation et en utilisant un injecteur/splitter passif afin d'utiliser le câble Ethernet pour véhiculer le courant puis alimenter la caméra sur sa prise d'alimentation

 

Dans le cas n°3 (qui est le cas de ton dessin) il est nécessaire après avoir injecté le 12v dans le câble de récupérer ces 12v via le splitter côté caméra.

Et de ce splitter les 12v seront acheminés vers la caméra par un câble qui sera branché sur la prise d'alimentation de la caméra (et en aucun cas sur sa prise RJ45 !).

Comme c'est indiqué sur ce dessin:

passive-poe-injector-splitter-network-diagram.jpg

 

Voici les ports d'un switch POE avec ses 4 sorties POE (en jaune), les autres 4 ports ne sont pas POE (donc pas d'injection de 48v dans le câble)

images?q=tbn:ANd9GcTpIHzD-Wyqpvde5WOUCkW13fvzHxb7xvWr0stKDARGeXeSCUjJ

 

Pour en savoir plus sur la norme POE:

http:// https://fr.wikipedia.org/wiki/Alimentation_%C3%A9lectrique_par_c%C3%A2ble_Ethernet

Share this post


Link to post
Share on other sites
Pour faire plaisir au monsieur, compléments :

 

  • L'alimentation doit être de 48 V (pas 12 V) ;
  • La caméra doit être compatible PoE.

 

17276-1458683313.jpg

 

Ça y est, j'ai bon ?

 

Ton raisonnement oui ton dessin non car il montre que tu veux alimenter la caméra par la prise RJ45 ce qui ne marchera pas.

Il aurait fallu représenter le splitter côté caméra qui récupère le 12v comme cela ;)

 

passive-poe-injector-splitter-network-diagram.jpg

 

Pour faire plaisir au monsieur,.....

 

Et au passage ce n'est pas pour me faire plaisir, mais j'ai 30 années de métier derrière moi dans l'installation de réseaux informatiques alors mes explications sont plus pour vous rendre service ;)

Share this post


Link to post
Share on other sites

Premiers essais peu concluants ..

J'ai branché la cam sur ma box orange.

Avec Ispy j'ai une image , mais elle ne fait pas 360° , plutôt 180 °!! un demi dôme ...

edit : en fait la caméra n'était pas horizontale: je l'ai ouverte (tiens il y a du desiccant , il faut le laisser ?), et mis l'objectif horizontal, c'est mieux , mais pas 360°

Comment la configurer ? Je lance device manage , je trouve la cam, Web Brrowse, IE se lance avec plein d'alerte (Windows ne connait pas l'éditeur et le bloque .. bref !) j'ai enfin une page avec des onglets à renseigner ... mais j'y mets quoi ? l'adresse IP ? il n'y a pas de commentaires en face les cases ...

De plus j'ai une alerte HTML/Framer avec AVG .

edit : En supprimant le contrôle ActivX j'ai la bonne page IE.

Mais impossible de me connecter à la cam, j'ai Media subconnect error. De plus IE plante souvent ...

Edited by michelsonia

Share this post


Link to post
Share on other sites

Après une restauration système avant l'installation du plug in IE et de device manager , j'ai réussi (avec de nombreuses alertes !!) à avoir la page de connection à la caméra. mais ce n'est pas stable, des fois c'est OK des fois non (impossible d'afficher la page ...).

Mais , il y a un mais, je n'arrive pas à sauvegarder ma config caméra (media subconnect error et device failed .. Pffff;

p><p><img src=[/img]

 

<a href=config_imagesia-com_16one_large.JPG' alt

Edited by michelsonia

Share this post


Link to post
Share on other sites

Visiblement il y a un problème réseau.

 

Pour bien configurer une caméra IP il faudrait aussi bien paramétrer son routeur (box) et le pare-feu.

Moi je laisse une plage IP pour attribuer manuellement des IP fixes et une plage IP pour des IP délivrés par le routeur en DHCP.

 

Je branche la caméra par un câble Ethernet court directement sur une entrée du routeur (ou box qui est aussi un routeur).

Souvent elle est préreglée en DHCP, la box va donc lui attribuer une adresse IP.

On peut trouver ensuite cette adresse facilement.

Moi j'utilise un petit utilitaire qui s'appelle Angry IP-Scanner.

Grâce à cet utilitaire j'ai affiché tous les IP du réseau et aussi des adresses MAC des périphériques qui sont reliés à ces adresses IP sur une plage IP que j'aurais fixé avant de lancer le scanne.

L'adresse MAC de la caméra étant affiché sur l'étiquette apposée sur la caméra il est facile donc de récupérer l'adresse IP qui vient de lui être attribuée par le routeur.

 

Ensuite depuis le navigateur je tape cette adresse IP:nº du port (voir dans la notice) dans la fenêtre d'adresse et normalement j'accède au menu de configuration de la caméra.

 

Il faut aussi pour toutes ces procédures avoir les droits administrateur pour éviter des problèmes de droits.

 

Dans la configuration de la caméra je vais fixer l'adresse IP avec une adresse encore disponible de ma plage d'adresse IP fixes.

Lors du redémarrage de la caméra ce sera cette adresse qu'il faudra utiliser.

Il ne faut pas oublier de rentrer aussi l'adresse IP du routeur (Gateway), ainsi que le nº de port.

Activer la fonction UpnP s'il elle est disponible (aussi bien côté caméra que routeur).

Je fixe aussi la vitesses du débit réseau sur 100Base-T (100 Mbit/s) au lieu de automatique (ou pire 10 Mbit/s si mal configuré).

Bien sûr si la caméra est compatible avec le réseau Gigabit je choisirais cette option, mais peu probable avec les caméras chinoises à ce bas prix.

Je désactive aussi la fonctions d'économie d'énergie s'il y en a une.

 

Côté routeur je regarde aussi que les réglages sont bons et que les ports sont ouvert et redirigées pour la caméra.

 

Le problème de connexion peut aussi venir d'une mauvaise alimentation.

Surtout si on utilise la solution du bloc d'alimentation déporté par injection/extraction du 12v.

Si l'alimentation est faiblarde sur une longue distance il peut y avoir des pertes.

Il faut préférer si déjà la caméra est POE utiliser un injecteur POE (ou un Switch POE) et alimenter la caméra avec du 48v.

 

S'il y a des problèmes de connexion, on peut aussi (avec la commande cmd dans la fenêtre "Démarrer") envoyer une série de ping vers la caméra pour vérifier si des paquets ne se perdent pas

 

Exemple: ping 192.168.1.25 -t enverra des paquets de manière discontinue à cette adresse IP jusqu'à interruption par un CTRL-C.

Si la liaison est bonne il n'y aura pas de paquets perdus.

S'il y a des paquets perdus il faut revoir ses branchements ou la configuration réseau.

 

J'ai aussi déjà eu des problèmes d'accès au menu de configuration d'une caméra IP avec Internet Explorer.

Je préfère utiliser Google Chrome ou Firefox qui posent moins de problèmes.

 

Une fois les tests à proximité effectués avec succès je branche ma caméra sur la ligne Ethernet prévue à cet effet.

Si cela ne marche pas pareil on sait que le problème vient de la liaison Ethernet (ou de l'alimentation).

 

Bien configurer aussi son pare-feu.

Il faut fixer l'adresse IP de la caméra et des programmes qui l'utilisent comme "autorisés" et que les ports de la caméra ne soient pas bloqués par le pare-feu.

 

Autres points importants:

Télécharger sur le site du fournisseur ou du fabricant le dernier firmware pour la caméra. Bien des problèmes sont résolu par un firmware plus récent alors que dans l'emballage le firmware de la caméra est dépassé depuis longtemps.

 

Vérifier aussi dans les journaux s'il n'y a pas des erreurs:

Ordinateur (clic droit) --> gérer --> observateur d'événements --> journaux Windows --> application et système (activer le filtre pour n'afficher que: erreur, critique, avertissement).

 

Souvent le manuel est en anglais (et chinois :be:) alors pour quelqu'un qui n'a pas l'habitude de configurer une caméra IP c'est la galère pour s'en sortir.

Je vous suggère de télécharger un manuel en français d'une autre marque (Axis, D-Link etc.).

Le principe reste le même et cela peut aider à comprendre le principe de fonctionnement.

 

Voilà c'est tout ce qui me vient à l'esprit pour l'instant comme pistes. ;)

Edited by Phill68

Share this post


Link to post
Share on other sites

Suite a plusieurs demandes petit rappel pour la configuration d' Ispy

 

Configuration du serveur FTP pour le transfert des images et Timelpase

 

Enregistrement des images et Configuration/Transfert FTP

 

ALLSKY-CAMERA-IP-IMX222-1080P-FTP-BERNIER-FRANCOIS.JPG

 

Création du timelapse :

 

ALLSKY-CAMERA-IP-IMX222-1080P-ISPY-2-BERNIER-FRANCOIS.JPG

 

 

Je mettrais en détail demain un petit tuto pour pouvoir visualiser et configurer sa caméra Allsky directement a partir d'un téléphone Android

 

ALLSKY-CAMERA-IP-IMX222-1080P-Android-screen-BERNIER-FRANCOIS.png

 

François

Share this post


Link to post
Share on other sites

Merci Phill68.

Ma caméra est branchée sur la box avec un câble de 1 m , l'alim est à côté (c'est celle de ma QSI ..)

Les test ping sont OK , pas de paquets perdus (envoie par groupe de 4).

Je me suis loggé sur la box en tant qu'admin , je ne vois pas la camera (pourtant j'ai une image avec IspY... Le problème vient-il de là ?

Quant à mettre à jour les pilotes .. sur l'étiquette il y marqué Starlight IP camera, mais je n'ai rien trouvé sur internet .

Edited by michelsonia

Share this post


Link to post
Share on other sites

I'l n'y a aucun pilote a installer pour utiliiser ou acceder une camera IP.

Éventuellement mettre à jour le Firmware.

 

François

Share this post


Link to post
Share on other sites

L'interface Web plante souvent, et il faut relancer IE.

J'ai utilisé le plug in du cd: General_IE_V1.0.086_20130522.exe .

Firmware ? C'est interne à la camera, non ?

Share this post


Link to post
Share on other sites
I'l n'y a aucun pilote a installer pour utiliiser ou acceder une camera IP.

Éventuellement mettre à jour le Firmware.

 

François

 

Oui autant pour moi, je voulais parler du firmware bien sûr.

Je corrige.

 

Et oui le firmware est le logiciel interne qui permet à la caméra de fonctionner (comme le BIOS sur un PC).

Il n'y a rien de marqué dans le manuel concernant une adresse web où on peut télécharger les mises à jour ?

Sinon un message au vendeur peut être la solution.

 

Pour se connecter l'adresse IP seule peut ne pas suffire il faut aussi l'adresse du port de la caméra pour accéder à la configuration de la caméra.

Exemple: 192.168.1.25:80

Edited by Phill68

Share this post


Link to post
Share on other sites

En jouant sur le contrôle activ X de IE (options sécurités ) j'ai réussi à tout installer correctement et j'ai maintenant accès aux contrôles de la caméra .. et à les enregistrer !!(Je me suis inspiré de ceux d'Astrogost :) ).

La caméra a l'air sensible (j'ai couvert la camera avec une couverture ..), à voir dehors la nuit.

Encore Merci pour vos aides et conseils !!

Share this post


Link to post
Share on other sites
Voici mon 1er Timelaps https://vimeo.com/160515736

 

Bien sympa ton timelapse. Pas d'image qui saute. La vidéo est parfaitement stable durant toute la durée du time lapse. Il y a juste un moment où tu as dû essayer la détection de mouvement.

 

Tu es à 1 images toutes les 10 secondes ? Car on a du mal à voir le timing se dérouler.

 

Elle marche bien cette petite caméra. Je crois que je vais m'en commander un exemplaire sans tarder, avant que tous les astrams du monde ne vident les stocks :be:

 

Merci également à François pour ses précieuses explications.

Share this post


Link to post
Share on other sites

Je confirme que cette petite caméra à tout d'une grande !

 

Installée hier soir à l'observatoire, les trouées nuageuses permettent de très clairement voir les étoiles !

 

Regardez le résultat ici :

 

http://www.astronomic.fr/post/2009/03/23/59-la-meteo-en-direct

 

Sur le deuxième timelapse (celui des dernières 24h), on repère facilement la polaire "fixe" et les autres étoiles qui "tournent" autour...

Edited by cedricthomas
Ajout.

Share this post


Link to post
Share on other sites
Je confirme que cette petite caméra à tout d'une grande !

 

Installée hier soir à l'observatoire, les trouées nuageuses permettent de très clairement voir les étoiles !

 

Regardez le résultat ici :

 

http://www.astronomic.fr/post/2009/03/23/59-la-meteo-en-direct

 

Sur le deuxième timelapse (celui des dernières 24h), on repère facilement la polaire "fixe" et les autres étoiles qui "tournent" autour...

 

C'est vrai qu'elle marche bien cette caméra.

 

Il y a juste un point qui m'étonne un peu. J'ai l'impression qu'on voit plus d'étoiles durant la phase où le soleil est en train de se coucher que pendant la nuit noire.

 

Peut-être un réglage à effectuer dans iSpy ?

Share this post


Link to post
Share on other sites

Bonsoir Cedric

 

quels sont tes réglages de sensibilité de la caméra pour voir les étoiles?

 

merci

Share this post


Link to post
Share on other sites
Bonsoir Cedric

 

quels sont tes réglages de sensibilité de la caméra pour voir les étoiles?

 

merci

 

Oui moi aussi je suis curieux de connaitre vos reglagles!!

Car je la trouve assez bruitée malgré le reglage antibruit a 5!

 

Astroghost, comment tu fais pour android?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.