Jump to content

Camera CCD fabriqué maison "CAM86"


pagpatrice
 Share

Recommended Posts

Il y a 2 heures, pagpatrice a dit :

STDev

Je vais partir du principe que tu as fais ça sans eclairage direct sur la cam et surtout sans eclairage à LED à proximité, je pense comme tu l'auras deviné à un probleme avec l'alim (en général), il faut en premier comme l'a suggéré @Pierre_Ch baisser la tension de l'alim principale, tu peux effectivement passer à 8 V, tout fonctionnnera même le refroidissement il sera juste plus long à réagir.

 

Je me suis aperçu qu'elle est trés sensible aux parasites générés par les alim d'ampoule à LED, jusqu'à une distance de 2 m, pour l'instant mes essais de blindage ne sont pas concluant bon en même temps généralement il n'y a pas d'éclairage lorsqu'on s'en sert.

Le type d'alim aussi, d'un modele à l'autre il peut y avoir une belle difference.

 

Tu as peut être un regulateur qui deconne, on y pense rarement et pourtant... pour exemple j'ai un petit recepteur FM avec lequel je n'entendais qu'un sifflement enorme s'il etait alimenté à plus de 9 V, j'ai remplacé son regulateur 5V interne, depuis un son clair sans parasite à n'importe qu'elle tension. 

 

 

Merci pour les pistes à explorer !

Pas d'éclairage Led à proximité...

Je vais commencer par baisser la tension d'alimentation pour voir .

Didier. 

Link to comment
Share on other sites

Il y a 12 heures, pagpatrice a dit :

STDev

Je vais partir du principe que tu as fait ça sans eclairage direct sur la cam et surtout sans eclairage à LED à proximité, je pense comme tu l'auras deviné à un probleme avec l'alim (en général), il faut en premier comme l'a suggéré @Pierre_Ch baisser la tension de l'alim principale, tu peux effectivement passer à 8 V, tout fonctionnnera même le refroidissement il sera juste plus long à réagir.

 

Je me suis aperçu qu'elle est trés sensible aux parasites générés par les alim d'ampoule à LED, jusqu'à une distance de 2 m, pour l'instant mes essais de blindage ne sont pas concluant bon en même temps généralement il n'y a pas d'éclairage lorsqu'on s'en sert.

Le type d'alim aussi, d'un modele à l'autre il peut y avoir une belle difference.

 

Tu as peut être un regulateur qui deconne, on y pense rarement et pourtant... pour exemple j'ai un petit recepteur FM avec lequel je n'entendais qu'un sifflement enorme s'il etait alimenté à plus de 9 V, j'ai remplacé son regulateur 5V interne, depuis un son clair sans parasite à n'importe qu'elle tension. 

 

Édit, je viens de réaliser que j'ai écrit une connerie, là le STDev est sur la totalité du capteur donc pixel mort compris, fait la mesure sur une sélection sans pixel mort STP.

Bon alors là, je n'y comprends plus rien !

Je viens de faire une mesure avec l'outil APT Pixel Aid sur une zone limitée comme tu le suggères et j'obtiens une StdDev de 12.4 sur l'offset à -12 °.

J'obtiens sensiblement la même valeur si je coche l'option Whole Image toujours à -12°.

1831398620_MesurezoneT-12.thumb.jpg.0edcbd5592cb91d326898e05d1932d73.jpg

 

Si je fait la même mesure en température ambiante, sur une zone limitée j'obtiens toujours un StdDev de 12.6 mais avec Whole Image la valeur passe à 26. 

Ce qui est curieux c'est que les valeurs de la fenêtre Ascom ne changent pas quel que soient les conditions et restent autour de 24.

D'autre part, j'ai fait un essai avec l'alimentation à 8V et c'est pire la StdDev de la fenêtre Ascom marque 26 !

Voilà ! Du coup je ne sais plus trop que croire ...

 

Link to comment
Share on other sites

salut :)

 

quelques news de la cam87

- version 1.1 lancée en commande, ça devrait régler les petits soucis de la première version. livraison dans 3 semaines

- ma v1 fonctionnelle (mais avec le capteur à l'envers) est partie chez @gehelem pour qu'il puisse nous faire un driver INDI

 

enjoy !

  • Merci / Quelle qualité! 1
Link to comment
Share on other sites

Il y a 4 heures, lordzurp a dit :

mais avec le capteur à l'envers) est partie chez @gehelem pour qu'il puisse nous faire un driver INDI

Le driver fonctionnera à l'envers aussi (s'il fonctionne)

Il projetera ses images sur le ciel.

Ce sera un driver IDNI.

  • Merci / Quelle qualité! 1
  • Haha 3
Link to comment
Share on other sites

Il y a 13 heures, gehelem a dit :

Le driver fonctionnera à l'envers aussi (s'il fonctionne)

Il projetera ses images sur le ciel.

Ce sera un driver IDNI.

Un vidéo projecteur , quoi :cheesy:

Link to comment
Share on other sites

@lordzurp On a hâte de se lancer dans l'aventure Cam87... Merci. 

@pagpatrice et @Pierre_Ch Je ne m'explique pas les écarts de mesures de StdDev suivant l'utilitaire pris pour ouvrir les images... Je vais partir du principe que ma cam fonctionne bien ( ce qui semble être le cas ) et me concentrer sur les paramètres d'acquisition et veiller à avoir un ADU suffisamment élevé sur les brutes. 

Je pense que les problèmes de bruit viennent essentiellement d'un signal d'acquisition trop faible et d'un mauvais échantillonnage. 

J'ai modifié un peu les réglages de gain et d'offset de la caméra. 

Je testerai ça pendant la prochaine nuit claire.

Link to comment
Share on other sites

Il semblerait qu'il soit plus facile de se fier au sigma dont la valeur semble plus universelle... 

Pour info, quelle valeur de sigma relevez-vous en général sur vos offsets ? C'est pour pouvoir me situer ! 

Merci,

Didier.

Link to comment
Share on other sites

Le 11/04/2021 à 16:46, dpapavoine a dit :

Il semblerait qu'il soit plus facile de se fier au sigma dont la valeur semble plus universelle... 

Pour info, quelle valeur de sigma relevez-vous en général sur vos offsets ? C'est pour pouvoir me situer ! 

Merci,

Didier.

Hello Didier,

 

J'utilise Prism et le driver ASCOM  pour faire les acquisitions et le traitement et sur un offset brut (raw non passé en couleur bien sur) j'obtiens un bruit RMS de 11,10 ADU avec une moyenne de 378.

 

Je ne sais pas si ça t'aide pour comparer avec tes mesures.

 

Pierre

Link to comment
Share on other sites

Il y a 2 heures, Pierre_Ch a dit :

Hello Didier,

 

J'utilise Prism et le driver ASCOM  pour faire les acquisitions et le traitement et sur un offset brut (raw non passé en couleur bien sur) j'obtiens un bruit RMS de 11,10 ADU avec une moyenne de 378.

 

Je ne sais pas si ça t'aide pour comparer avec tes mesures.

 

Pierre

Bonjour Pierre,

Merci pour les infos. Je réalise mes acquisitions avec APT et elles sont au format FIT . J'ai une moyenne ADU sur les offsets proche de la tienne à 361 mais je ne suis pas sûr que l'on puisse comparer les valeurs de bruit entre des formats différents...

J'ai tout de même décidé de tenter d'améliorer les choses. J'ai commandé une alimentation régulée 5v à très faible bruit pour remplacer le module convertisseur de tension DC/DC soudé sur la carte pour alimenter celle-ci. 

Je vous tiendrais au courant des résultats.

Didier.

Link to comment
Share on other sites

Hello All,

 

During the last days I could improve the sensor cooling of my CAM87-Box by replacing the one stage TEC1-12706 (40x40mm) with a two stage TEC2-19003.

With the Tec1-12706 the temp. went approx 15 ° down from ambient and with the new TEC2-19003 I'm getting a temp.-diff. of> 30 ° 😀.

Thanks to @ gehelemfor his report on  https://www.diycam.fr/index.php/fr/11-all/refroidissement/9-test-du-peltier-tes2-19003

 

Also the current from the 12V supply is only 2A instead of 3.5 -4A.

Starting temp: 22.2 ° C

after 5min: 2.2 ° C

stabilized after 20min to -8.5 ° C

 

Now I can't wait till the INDI driver is ready.

 

***********************

 

In recent days, I have been able to improve the cooling of the sensor of my CAM87-Box by replacing the one-stage TEC1-12706 (40x40mm) with a two-stage TEC2-19003.

With the Tec1-12706, the temperature has decreased by about 15 ° compared to the ambient and with the new TEC2-19003, I get a temperature difference of> 30 ° 😀.

Thanks to @ gehelem for his report on https://www.diycam.fr/index.php/fr/11-all/refroidissement/9-test-du-peltier-tes2-19003.

 

Also the current of the 12V power supply is only 2A instead of 3.5 -4A.

Starting temperature: 22.2 ° C

after 5min: 2.2 ° C

stabilized after 20min at -8.5 ° C

 

Now I can't wait for the INDI driver to be ready.

 

 

Klaus

 

 

Screenshot 2021-04-23 100537.jpg

Edited by Klausmh
French translation
  • Merci / Quelle qualité! 1
Link to comment
Share on other sites

Il y a 9 heures, Klausmh a dit :

I can't wait till the INDI driver is ready.

Please edit your message with a french translation... 🙂

 

Tu peux essayer si tu veux, le driver marche en partie chez moi : il faut juste le compiler...

je travaille actuellement sur le contrôle  du refroidissement, je galère un peu...

Link to comment
Share on other sites

Il y a 14 heures, gehelem a dit :

Please edit your message with a french translation ... 🙂

 

You can try if you want, the driver partly works for me: you just have to compile it ...

I am currently working on cooling control, I am struggling a bit ...

@gehelem:

 

Compiling the indi-CAM87 gives me the compiling  errors with my RPi4 running "Astroberry".

 Installing the latest "libftdi" version 1.5 gives the same error 😞.

 

After replacing "ftdi_tcoflush" and "ftdi_tciflush" with  "ftdi_usb_purge_tx_buffer" and "ftdi_usb_purge_rx_buffer" it complies and it works as you have shown in your post..  

Which libftdi do you use?

 

******************

 

La compilation de l'indi-CAM87 me donne les erreurs de compilation avec ma RPi4 exécutant "Astroberry".

L'installation de la dernière version 1.5 de "libftdi" donne la même erreur 😞.

 

Après avoir remplacé "ftdi_tcoflush" et "ftdi_tciflush" par "ftdi_usb_purge_tx_buffer" et "ftdi_usb_purge_rx_buffer" c'est conforme et cela fonctionne comme vous l'avez montré dans votre post....  

Quelle libftdi utilisez-vous ?

 

**********************

Error messages:

astroberry@astroberry:~/CAM87-Test/indi_cam87_ccd/build $ make
[ 40%] Built target cam87
[ 60%] Linking CXX executable indi_cam87_ccd
/usr/bin/ld: CMakeFiles/indi_cam87_ccd.dir/libcam87.c.o: in function `Spi_comm':
libcam87.c:(.text+0x5e8): undefined reference to `ftdi_tciflush'
/usr/bin/ld: libcam87.c:(.text+0x5f8): undefined reference to `ftdi_tcoflush'
/usr/bin/ld: CMakeFiles/indi_cam87_ccd.dir/libcam87.c.o: in function `reset':
libcam87.c:(.text+0x6d0): undefined reference to `ftdi_tciflush'
/usr/bin/ld: libcam87.c:(.text+0x6e0): undefined reference to `ftdi_tcoflush'
/usr/bin/ld: CMakeFiles/indi_cam87_ccd.dir/libcam87.c.o: in function `posExecute':
libcam87.c:(.text+0x884): undefined reference to `ftdi_tciflush'
/usr/bin/ld: libcam87.c:(.text+0x894): undefined reference to `ftdi_tcoflush'
/usr/bin/ld: libcam87.c:(.text+0x1434): undefined reference to `ftdi_tciflush'
/usr/bin/ld: libcam87.c:(.text+0x1444): undefined reference to `ftdi_tcoflush'
/usr/bin/ld: CMakeFiles/indi_cam87_ccd.dir/libcam87.c.o: in function `readframe':
libcam87.c:(.text+0x1a20): undefined reference to `ftdi_tciflush'
/usr/bin/ld: libcam87.c:(.text+0x1a30): undefined reference to `ftdi_tcoflush'
/usr/bin/ld: CMakeFiles/indi_cam87_ccd.dir/libcam87.c.o: in function `cameraConnect':
libcam87.c:(.text+0x1eb4): undefined reference to `ftdi_tciflush'
/usr/bin/ld: libcam87.c:(.text+0x1ee8): undefined reference to `ftdi_tcoflush'
/usr/bin/ld: libcam87.c:(.text+0x1f1c): undefined reference to `ftdi_tciflush'
/usr/bin/ld: libcam87.c:(.text+0x1f50): undefined reference to `ftdi_tcoflush'
/usr/bin/ld: libcam87.c:(.text+0x1fa8): undefined reference to `ftdi_tciflush'
/usr/bin/ld: libcam87.c:(.text+0x1fdc): undefined reference to `ftdi_tcoflush'
collect2: error: ld returned 1 exit status
make[2]: *** [CMakeFiles/indi_cam87_ccd.dir/build.make:104: indi_cam87_ccd] Fehler 1
make[1]: *** [CMakeFiles/Makefile2:105: CMakeFiles/indi_cam87_ccd.dir/all] Fehler 2
make: *** [Makefile:130: all] Fehler 2
 

 

Link to comment
Share on other sites

  • 2 weeks later...

Je progresse sur le nouveau boîtier en alu + impressions 3D, en exploitant l’expérience faite avec mon boitier 100% impression 3D ... c'était iperfacile de forer le couvercle une simple pointe scie-cloche chinoise :D 

 

Le projet est prêt, réalisation a suivre ...

Capture.PNG

20210507_143646.jpg

20210507_143658.jpg

  • J'aime 1
Link to comment
Share on other sites

Le 24/04/2021 à 11:03, Klausmh a dit :

a compilation de l'indi-CAM87 me donne les erreurs de compilation avec ma RPi4 exécutant "Astroberry".

L'installation de la dernière version 1.5 de "libftdi" donne la même erreur 😞.

 

Après avoir remplacé "ftdi_tcoflush" et "ftdi_tciflush" par "ftdi_usb_purge_tx_buffer" et "ftdi_usb_purge_rx_buffer" c'est conforme et cela fonctionne comme vous l'avez montré dans votre post....  

Quelle libftdi utilisez-vous ?

Désolé de ma réponse si tardive ...

 

il faut impérativement utiliser la librairie fournie par Intra2net :

Celle de Ftdichip fonctionne très très bien, mais elle a un énorme inconvénient qui la rend inutilisable pour nous

On est obligé de désactiver les communications classiques par le port série avec des puces ft232 (qu'on trouve dans les focuser diy ou dans les cables Eqmod par exemple)

La seule option est donc de se rabattre sur la librairie Intra2net qui fait la même chose, et elle s'appelle "libftdi" (au lieu de "D2XX")

Malheureusement elle est beaucoup moins stable, et on est obligé de la compiler pour pouvoir l'utiliser (je ne crois pas qu'il existe de package tout fait, à vérifier...)

 

Tes messages d'erreur semblent indiquer que ta librarie libftdi n'est pas installée correctement.

As-tu suivi les étapes suivantes ?

http://developer.intra2net.com/mailarchive/html/libftdi/2013/msg00014.html

Citation

Here is a short tutorial on how to build libftdi git under
Ubuntu 12.10, But it is similar on other Linux distros.

1) Install the build tools
sudo apt-get install build-essential
sudo apt-get install git-core
sudo apt-get install cmake
sudo apt-get install doxygen (for building documentations)

2) Install dependencies
sudo apt-get install libusb-1.0-devel
(if the system comes with older version like 1.0.8 or
earlier, it is recommended you build libusbx-1.0.14 or later).

sudo apt-get install libconfuse-dev (for ftdi-eeprom)
sudo apt-get install swig python-dev (for python bindings)
sudo apt-get install libboost-all-dev (for C++ binding and unit test)

3) Clone the git repository
mkdir libftdi
cd libftdi
git clone git://developer.intra2net.com/libftdi

If you are building the release tar ball, just extract the source
tar ball.

4) Build the git source and install
cd libftdi
mkdir build
cd build
cmake ..
nano CMakeCache.txt (if you want to change some build optiosn)
cmake ..
make
sudo make install

 

---------------

Sorry for my late reply ...

you must use the library provided by Intra2net:

The one from Ftdichip works great, but it has a huge drawback that makes it unusable for us.

We have to deactivate the classic communications by the serial port with ft232 chips (which we find in the focuser diy or in the Eqmod cables for example)

The only option is therefore to fall back on the Intra2net library which does the same thing, and it is called "libftdi" (instead of "D2XX")

Unfortunately it is much less stable, and we have to compile it to be able to use it (I don't think there is a ready-made package, to check ...)

 

Your error messages seem to indicate that your libftdi library is not installed correctly.

Did you take the following steps? http://developer.intra2net.com/mailarchive/html/libftdi/2013/msg00014.html

---------------

Link to comment
Share on other sites

Le 5/9/2021 à 10:55 AM, gehelem a dit :

Sorry for my late response ...

 

you must use the library provided by Intra2net :

The one from Ftdichip works great, but it has a huge drawback that makes it unusable for us.

We have to deactivate the classic communications by the serial port with ft232 chips (which we find in the focuser diy or in the Eqmod cables for example)

The only option is therefore to fall back on the Intra2net library which does the same thing, and it is called "libftdi" (instead of "D2XX")

Unfortunately it is much less stable, and we have to compile it to be able to use it (I don't think there is a ready-made package, to be checked ...)

 

Your error messages seem to indicate that your libftdi library is not installed correctly.

Did you take the following steps?

http://developer.intra2net.com/mailarchive/html/libftdi/2013/msg00014.html

 

---------------

Sorry for my late reply ...

you must use the library provided by Intra2net:

The one from Ftdichip works great, but it has a huge drawback that makes it unusable for us.

We have to deactivate the classic communications by the serial port with ft232 chips (which we find in the focuser diy or in the Eqmod cables for example)

The only option is therefore to fall back on the Intra2net library which does the same thing, and it is called "libftdi" (instead of "D2XX")

Unfortunately it is much less stable, and we have to compile it to be able to use it (I don't think there is a ready-made package, to check ...)

 

Your error messages seem to indicate that your libftdi library is not installed correctly.

Did you take the following steps? http://developer.intra2net.com/mailarchive/html/libftdi/2013/msg00014.html

---------------

@gehelemThanks for your help.  After I installed a fresh RaspianOS on my RPi4 I could compile your indi_cam87_ccd without any errors 🙂

However I' still in the process to setup my Pi as an "Astropi" step by step with all the apps.  This will take some time till I'm finished 😞.

 

Why I have to do this? - Because it seems to me that my former "Astroberry" installation (which is really nice) has some problems with the libftdi. Up to now I can't track this back.

 

 

***********************

 

@gehelem Merci pour votre aide.  Après avoir installé un RaspianOS frais sur mon RPi4, j'ai pu compiler votre indi_cam87_ccd sans aucune erreur 🙂 .

Cependant je suis toujours en train de configurer mon Pi comme un "Astropi" étape par étape avec toutes les applications.  Cela prendra un certain temps jusqu'à ce que j'aie terminé 😞.

 

Pourquoi dois-je faire cela ? - Parce qu'il me semble que mon ancienne installation "Astroberry" (qui est vraiment bien) a quelques problèmes avec la libftdi. Jusqu'à présent, je n'ai pas pu retrouver la trace de ce problème.

 

Klaus

 

 

 

Link to comment
Share on other sites

il y a 9 minutes, Zoroaster a dit :

Et voici le 2ème côté du nouveau machin ... doigt froid, Peltier et ventirad.

 

20210519_220835.jpg

20210519_220810.jpg

 

Très beau montage !!

 

Pierre

  • J'aime 1
Link to comment
Share on other sites

hey :)

je suis pas mort, j'ai un atelier qui c ommence à être cool (bon, par contre j'ai pas encore de cuisine ... ya des priorités)

la révision de la cam87 fonctionne bien, j'attends un peltier et je bosse sur le boitier, bientot dispo chez vous !

 

image.thumb.png.08ca58f840cff1074bd911fe78f0ad13.pngimage.thumb.png.660588b9d4684e668e0e6412710c59e4.png     

 

1273931.thumb.jpg.49bfd0c8ef9a2a7bfa6d0b46b4618db0.jpg

 

1273811.thumb.jpg.10de47f55a8b809895d3cf385425572e.jpg

 

1273799.jpg.d658e08762126ba22e7a093f58f32b4c.jpg

  • J'aime 1
  • Merci / Quelle qualité! 4
Link to comment
Share on other sites

  • 2 weeks later...

Hello All,

 

after a longer period of of silence I want to share my latest iteration of my CAM87. 

 

Changes:

  • UV-Filter to cover the sensor (like the idea from @Zoroaster). I used a good HOYA 49mm UV FIlter. With this filter I could cool the sensor up to -30k down from ambient temperature 🙂. ( Using a TEC2 -19003 30x30mm two stage peltier @ approx 2.7A - thanke @gehelem)
  • Instead using normal nut i switched to insert-nuts.
  • Some dimension changes to fit the peltier and the new fan.
  • Still using the "old" electronic from @lordzurp
  • Integrated tripod nuts
  • Used a  Noctua NF-A4x20 FLX Fan which has nearly no vibration.

 

 

Bonjour à tous,

 

Après une longue période de silence, je veux partager ma dernière itération de mon CAM87. 

 

Changements :

  • Filtre UV pour couvrir le capteur (comme l'idée de @Zoroaster). J'ai utilisé un bon HOYA 49mm UV FIlter. Avec ce filtre j'ai pu refroidir le capteur jusqu'à -30k par rapport à la température ambiante 🙂 . (En utilisant un Peltier TEC2 -19003 30x30mm à deux étages @ environ 2.7A - merci @gehelem).
  • Au lieu d'utiliser des écrous normaux, j'ai opté pour des écrous à insérer.
  • Quelques changements de dimensions pour adapter le peltier et le nouveau ventilateur.
  • J'utilise toujours la "vieille" électronique de @lordzurp.
  • Ecrous de trépieds intégrés
  • Utilisation d'un ventilateur Noctua NF-A4x20 FLX qui n'a pratiquement aucune vibration.


 

CAM87-Explosion.png

CAM87-V3-STL.rar CAM87-Box-KH-3.STEP

  • Merci / Quelle qualité! 2
Link to comment
Share on other sites

il y a 9 minutes, Klausmh a dit :

Bonjour à tous,

 

Après une longue période de silence, je veux partager ma dernière itération de mon CAM87

Nice / joli !

Que prévois-tu pour le doigt froid ?

What about cold finger ?

Link to comment
Share on other sites

Posted (edited)
2 hours ago gehelem said:

Nice / pretty!

What do you plan for the cold finger?

What about cold finger?

Ohhh - sorry I forgot some pictures.

they are from my previous version, but it's the same in the current version. the only difference is the new fan and the new 30x30 peltier.

 

Klaus

IMG_0233.JPG

IMG_0232.JPG

Edited by Klausmh
  • Merci / Quelle qualité! 2
Link to comment
Share on other sites

  • 3 weeks later...

juste pour pas laisser ce fil mourir ...

 

toujours en train de valider ma version box (le premier peltier a cramé ...), ça va arriver un jour

en attendant, j'ai repris la version ronde, et j'ai presque un truc qui tient dans un rond de 2" (c'est encore un premier brouillon, mais ça rentre et toutes les pistes sont routées)

l'objectif est d'avoir une cam qui peut se monter à la place du secondaire d'un newton, pour faire un astrographe

l'alim sera déportée sur le tube, via une nappe souple (alim + USB), et un cable plus gros pour la puissance du TEC + ventilo

unknown (1).png

  • J'aime 2
  • Merci / Quelle qualité! 2
Link to comment
Share on other sites

  • 3 weeks later...

Yop

 

des news d'ici

- j'ai une cuisine (au bout de 3 mois. chacun ses victoires ...)

- ma cam87 fonctionne en froid

     - peltier 2 étages 40mm 8A (TEC2-25408) sous-alimenté en 5V pour rester autour de 8W

     - delta de -25°C à burne, je vais tourner à -20°C pour avoir une bonne régulation. 5min pour passer de 25 à 5°C

     - j'ai viré mon radiateur chinois moisi et pris le même bleu que @Klausmh, c'est bien mieux

     - chose étonnante, ça refroidit mieux quand le ventilo aspire l'air via le rad, plutot que quand il pousse dedans. OK ...

- le boitier s'imprime, mais j'ai presque plus de filament, pas d'autre essai avant quelques jours

- elle pèse 240g sans le plastique, poids final estimé autour de 280g ( @dpapavoine challenge réussi ! largement sous les 500g !)

- ma carte actuelle a un ADC 14bits, donc c'est pas la finale, elle pourra partir en pret chez les gens qui font du code (poke @Greg34 )

- la carte ronde, on verra plus tard, là ça me démange de sortir tester, quand même (mais le scope est encore en pièce ...), mais j'ai repassé une couche dessus, ça va marcher. à voir si ça interesse du monde pour essayer

 

 

20210711_055109.jpg

 

 

Edited by lordzurp
  • J'aime 2
  • Merci / Quelle qualité! 3
Link to comment
Share on other sites

Hi !

 

allez, ça y est, c'est validé ! je viens de publier les docs sur mon github, vous pouvez officiellement vous lancer dedans :)

 

tout est ici : https://github.com/lordzurp/cam87-box

il me reste encore de la doc à écrire, mais il y a tout ce qu'il faut pour fabriquer sa cam87

 

je vais pas lancer de version 1.2 pour le moment, mais à l'automne je prévois de faire un batch de caméras, en kit ou assemblées. je reviendrai en parler au bon moment

 

Message de service :

il me reste des PCB de la version 1.1 4 alims, 4 cartes capteur, 1 carte logique assemblée (sauf 2 chips), et 3 cartes logiques nues

j'ai aussi des pcb de la version 1.0, qui peut servir pour peupler la 1.1 ou une 1.2

si ça vous interesse -> MP

  • Merci / Quelle qualité! 2
Link to comment
Share on other sites

Salut @kelvin

Were you able to get cam86 working with 328PB? I have soldered PB version and now I'm reading your posts as the only source of knowledge :D

 

google-translate:

Avez-vous pu faire fonctionner cam86 avec 328PB ? J'ai soudé la version PB et maintenant je lis vos messages comme la seule source de connaissances

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.