Argonothe

Contrôle setup astrophotographie nomade

Recommended Posts

Bonsoir,

 

Un petit retour d'expérience.
Alors je n'ai toujours pas une configuration fonctionnelle mais ça avance.
1° Pour la caméra, la dernière mise à jour d'indi intègre un nouveau SDK (5.03) de chez QHY qui permet de contrôler ma caméra. Au passage un gentil M. de chez QHY me l'avait envoyé en primeur mais bon il est paru dans la foulée.

2° Par contre je n'ai pas encore le contrôle de la roue à filtre branchée sur le port de la caméra. Faut que je fasse d'autres essais mais la brancher en USB directement sur le Pi nécessite de l'ouvrir pour basculer le commutateur de RS232 à USB...et j'ai la flemme, j'avoue....mais je suis en vacances la semaine prochaine donc wait and see...

3° Pour mon problème de focuser là aussi j'ai des nouvelles : j'ai trouvé une explication où le gus dit qu'en créant un lien symbolique il a récupéré son focuser.  Ca fonctionnait avant sous indi mais plus maintenant.
Le pb semble bien venir de là : le driver n'est plus mis à jour et il y a eu pas mal d'évolutions depuis sa sortie niveau lib.so....(mais pourquoi faire un lien statique et pas un dynamique ???)

Malheureusement j’avais créé le lien MAIS j'ai ensuite fait un apt-get upgrade...qui m'a perdu le lien donc mon test n'a pas été concluant ;-)
Je referai ça quand j'aurai le Pi de connecté à internet....

 

Voili voilou et encore merci à la communauté !!

Share this post


Link to post
Share on other sites
Il y a 15 heures, gbs a dit :

Bonsoir,

 

Un petit retour d'expérience.
Alors je n'ai toujours pas une configuration fonctionnelle mais ça avance.
1° Pour la caméra, la dernière mise à jour d'indi intègre un nouveau SDK (5.03) de chez QHY qui permet de contrôler ma caméra. Au passage un gentil M. de chez QHY me l'avait envoyé en primeur mais bon il est paru dans la foulée.

2° Par contre je n'ai pas encore le contrôle de la roue à filtre branchée sur le port de la caméra. Faut que je fasse d'autres essais mais la brancher en USB directement sur le Pi nécessite de l'ouvrir pour basculer le commutateur de RS232 à USB...et j'ai la flemme, j'avoue....mais je suis en vacances la semaine prochaine donc wait and see...

3° Pour mon problème de focuser là aussi j'ai des nouvelles : j'ai trouvé une explication où le gus dit qu'en créant un lien symbolique il a récupéré son focuser.  Ca fonctionnait avant sous indi mais plus maintenant.
Le pb semble bien venir de là : le driver n'est plus mis à jour et il y a eu pas mal d'évolutions depuis sa sortie niveau lib.so....(mais pourquoi faire un lien statique et pas un dynamique ???)

Malheureusement j’avais créé le lien MAIS j'ai ensuite fait un apt-get upgrade...qui m'a perdu le lien donc mon test n'a pas été concluant 😉
Je referai ça quand j'aurai le Pi de connecté à internet....

 

Voili voilou et encore merci à la communauté !!

Cool voilà ça avance !

 

Petite règle pour linux. Quand t'a des truc spécifique comme ça d'installer il ne faut pas utiliser apt upgrade. Tu fait juste update puis tu fait apt install xx du truc que tu veut mettre à jour.

Share this post


Link to post
Share on other sites
Posted (edited)

Bon, ça avance encore... 

La caméra ET la raf fonctionnent : il ne fallait pas mettre de raf dans la configuration d'indi/ekos, elle est contrôlée via le driver de la caméra... Nickel. Même le refroidissement... 

 

Mon lien symbolique lui aussi a fonctionné, le focuser est mobile... 

 

Bref, pris séparément tout fonctionne, reste plus qu'à tester sur le ciel mais comme de bien entendu il y a un chouette voile nuageux qui s'installe, à voir s'il disparaît 

Edited by gbs
  • J'aime 1
  • Merci / Quelle qualité! 1

Share this post


Link to post
Share on other sites

Salut, me rev'la pour d'autre questions lol,

j'ai reçu ma cam asi120mm-s, dans ekos elle est bien reconnu, par contre ni le canon 6d ni la star adventurer ne sont detecté...

 

branchement :

Canon directement sur le Pi en usb

Star adventurer en st4 sur la cam

et la cam en usb sur le pi

 

Reglage eqmod, j'ai desactivé automount comme trouvé plusieurs fois sur le forum.

 

J'ai raté quoi??? :cry:

Share this post


Link to post
Share on other sites
Il y a 2 heures, yeantbron a dit :

Salut, me rev'la pour d'autre questions lol,

j'ai reçu ma cam asi120mm-s, dans ekos elle est bien reconnu, par contre ni le canon 6d ni la star adventurer ne sont detecté...

 

branchement :

Canon directement sur le Pi en usb

Star adventurer en st4 sur la cam

et la cam en usb sur le pi

 

Reglage eqmod, j'ai desactivé automount comme trouvé plusieurs fois sur le forum.

 

J'ai raté quoi??? :cry:

 

Pour la star aventurer c'est assez simple tu ne peux pas la piloter y a pas de goto dessus. Tu peut juste faire des corrections sur l'axe d'assension droite en passant par la prise st4. Du coup faudra dire à ekos que ta monture est en st4 pour l'autoguidage en pointant ta caméra ASI.

 

Pour le canon ta bien mis le driver canon dslr dans les driveur a activer ?

Share this post


Link to post
Share on other sites

merci dragonlost, ok pour la SA j'ai compris du coup ;)

Par contre le Canon, j'ai beau essayer, rien a faire, j'ai regardé dans les drivers, dans indi server? je met la ASI, ça connecte, je met canon dslr, can not connect... il est invisible.

J'ai enlevé le blocage du miroir, coupé le wifi (du 6d), enlevé rotation de l'image, installé gphoto, mis gphoto a la place de canon dslr, la il passe en vert ... mais ne trouve aucun appareil.

Bref, l'impasse lol

je met une image, c'est pas ma capture j'ai oublié d'en faire une, mais c'est la dedans que je suis allé.

Résultat de recherche d'images pour "nafabox indi"

Share this post


Link to post
Share on other sites
Il y a 12 heures, yeantbron a dit :

merci dragonlost, ok pour la SA j'ai compris du coup ;)

Par contre le Canon, j'ai beau essayer, rien a faire, j'ai regardé dans les drivers, dans indi server? je met la ASI, ça connecte, je met canon dslr, can not connect... il est invisible.

J'ai enlevé le blocage du miroir, coupé le wifi (du 6d), enlevé rotation de l'image, installé gphoto, mis gphoto a la place de canon dslr, la il passe en vert ... mais ne trouve aucun appareil.

Bref, l'impasse lol

je met une image, c'est pas ma capture j'ai oublié d'en faire une, mais c'est la dedans que je suis allé.

Résultat de recherche d'images pour "nafabox indi"

 

Du coup tu peut démarrer "update_conf".

Puis tu sélectionne juste kstars.

Puis tu sélection juste "Install Gphoto2 driver (Jasem PPA version)"

Puis tu redémarre.

 

Réessaye de connecter ton 6D et dit moi si c'est bon cette fois ci.

Je pense que qu'il ne le vois pas car il a du se monter automatiquement du coup il doit etre actif comme peripherique multimedia et pas appareil photo. le fait d'installer la version modifier de libgphoto devrai régler le problème.

Share this post


Link to post
Share on other sites
Le ‎20‎/‎04‎/‎2019 à 16:18, yeantbron a dit :

Salut, me rev'la pour d'autre questions lol,

j'ai reçu ma cam asi120mm-s, dans ekos elle est bien reconnu, par contre ni le canon 6d ni la star adventurer ne sont detecté...

 

branchement :

Canon directement sur le Pi en usb

Star adventurer en st4 sur la cam

et la cam en usb sur le pi

 

Reglage eqmod, j'ai desactivé automount comme trouvé plusieurs fois sur le forum.

 

J'ai raté quoi??? :cry:

Salut même en passant par hub usb alimenté, ca ne fonctionne pas ?

Share this post


Link to post
Share on other sites
Posted (edited)

Merci, alors pour Gphoto2 j'avais deja fait, par contre je viens de commander un hub, réponse dans quelques jours.

 

La ça fait 2 jours que je cherche pourquoi j'ai l’éclair jaune sans rien de branché dessus, ça le fait avec mes 2 batteries externe, avec un chargeur secteur, le seul avec lequel ça ne le fait fait est modulable en sortie et sort 5.5v constant... 

la c'est un peu mieux avec une double alimentation, le micro usb et le gpio (avec un câble usb d'un coté et les "pinoches" gpio de l'autre) l’éclair est toujours la mais la led rouge clignote beaucoup moins.

 

edit: je viens de retester et ho miracle, il est enfin reconnu et je peux le connecter, j'ai eu 2 retour au bureau avec plantage de kstar, il a fallu que j'éteigne et rallume le canon, il etait detecté mais impossible a connecter, ça fonctionnera peut etre mieux avec le hub. 

Edited by yeantbron

Share this post


Link to post
Share on other sites

Bonjour à tous,

J'ai une question qui va paraitre débile mais bon comme je ne trouve pas de solution, autant passer pour un … et ne plus le rester (enfin au moins sur ce sujet)  ;)

 

-->J'aimerai pouvoir utiliser mon PC avec Kstars (sous win 10) et laisser juste indistarter (indiserver) sur la Tinker pour les drivers.

 

--> et tout marche impeccable...

 

Enfin tout sauf l'astrometry en remote car kstars sous Windows ne fonctionne qu'en online ou en remote.

je precise :

- que le driver Astrometry tourne bien sur indi server (+ tous les autres bien sûr)

- que j'ai ajouté ce driver sous kstars PC, qu'il se connecte bien...et pi rien de bon :(

- que tous les index (sauf celui qui fait 13go) sont sur la tinker et que lorsque j'utilise kstars en local sur la tinker, et en offline pour le solver...tout fonctionne impecc

- et que rien d'autre ne tourne sur la tinker en dehors de indiserver

 

A chaque fois que je veux faire un plate solving en remote, j'ai le droit au "solver failed" immédiatement (en fait il ne se lance même pas)

 

faut il que je fasse tourner quelque chose sous la tinker...mystère !

 

Alors si vous avez la solution, je suis preneur ;)

 

Frank

 

Share this post


Link to post
Share on other sites
il y a une heure, Frank L a dit :

Bonjour à tous,

J'ai une question qui va paraitre débile mais bon comme je ne trouve pas de solution, autant passer pour un … et ne plus le rester (enfin au moins sur ce sujet) 

 

-->J'aimerai pouvoir utiliser mon PC avec Kstars (sous win 10) et laisser juste indistarter (indiserver) sur la Tinker pour les drivers.

 

--> et tout marche impeccable...

 

Enfin tout sauf l'astrometry en remote car kstars sous Windows ne fonctionne qu'en online ou en remote.

je precise :

- que le driver Astrometry tourne bien sur indi server (+ tous les autres bien sûr)

- que j'ai ajouté ce driver sous kstars PC, qu'il se connecte bien...et pi rien de bon

- que tous les index (sauf celui qui fait 13go) sont sur la tinker et que lorsque j'utilise kstars en local sur la tinker, et en offline pour le solver...tout fonctionne impecc

- et que rien d'autre ne tourne sur la tinker en dehors de indiserver

 

A chaque fois que je veux faire un plate solving en remote, j'ai le droit au "solver failed" immédiatement (en fait il ne se lance même pas)

 

faut il que je fasse tourner quelque chose sous la tinker...mystère !

 

Alors si vous avez la solution, je suis preneur

 

Frank

 

Dans les options du solver sur ekos, décoche le --no-fits2fits

  • J'aime 1

Share this post


Link to post
Share on other sites
Posted (edited)

Merci Gilles ;)

 

En mode simulateur, ça a l'air de marcher !

Edited by Frank L
  • Merci / Quelle qualité! 1

Share this post


Link to post
Share on other sites
Posted (edited)
Le 22/04/2019 à 15:23, yeantbron a dit :

Merci, alors pour Gphoto2 j'avais deja fait, par contre je viens de commander un hub, réponse dans quelques jours.

 

La ça fait 2 jours que je cherche pourquoi j'ai l’éclair jaune sans rien de branché dessus, ça le fait avec mes 2 batteries externe, avec un chargeur secteur, le seul avec lequel ça ne le fait fait est modulable en sortie et sort 5.5v constant... 

la c'est un peu mieux avec une double alimentation, le micro usb et le gpio (avec un câble usb d'un coté et les "pinoches" gpio de l'autre) l’éclair est toujours la mais la led rouge clignote beaucoup moins.

 

edit: je viens de retester et ho miracle, il est enfin reconnu et je peux le connecter, j'ai eu 2 retour au bureau avec plantage de kstar, il a fallu que j'éteigne et rallume le canon, il etait detecté mais impossible a connecter, ça fonctionnera peut etre mieux avec le hub. 

 

Ok alors ce petit éclaire jaune expliquerai beaucoup de chose !! ce petit éclair jaune apparaît quand la carte détecte que la tension d'alimentation est trop faible. Bref ça veut dire que ta source d'alimentation est pourri.

Si tes batterie donne un voltage de 5.0V, quand tu vas venir tirer de la puissance dessus, le voltage vas s'écrouler et être inférieur à 5.0v.

Attention : il ne faut pas alimenter avec les GPIO ET le micro USB. Tu risque de créer des conflit dans l’alimentation de ta carte et simplement griller ton Raspberry. C'est soit l'un soit l'autre pas les 2.

 

Du coup je comprend mieux l’absence de connection, si tu est déjà juste en alimentation pour faire tourner le Raspberry alors brancher quelque chose en USB vas soit tout faire planter soit ne pas marcher.

Du coup si tu utilise une bonne alimentation ( min 2.5A en 5.2v ) tes problème USB devrait être moins important.

 

L'éclaire jaune peut aussi indique un voltage superieur à 5.0v et trop proche de la limite. 5.5v c'est trop élevé. Le tip top c'est un voltage qui oscille entre 4.9 et 5.3v.

 

 

 

 

 

Edited by dragonlost

Share this post


Link to post
Share on other sites

alors hub reçu, nouvelle alim reçu aussi, tout fonctionne nickel :banana:

reste plus qu'a chasser les nuages et virer le vent pour tester en condition réelle.

Share this post


Link to post
Share on other sites
Il y a 22 heures, yeantbron a dit :

alors hub reçu, nouvelle alim reçu aussi, tout fonctionne nickel :banana:

reste plus qu'a chasser les nuages et virer le vent pour tester en condition réelle.

 

ha bas voilà ! cool

Share this post


Link to post
Share on other sites

Bonjour à tous,

Je vais encore passer pour une andouille mais bon, je m' lance !

 

Ma question porte sur l'astrométrie ; je sais grâce à vous où je dois enregistrer les fichiers sur PC ubuntu quand je l'utilise sur une Tinker mais qu'en est-il de l'utilisation de Kstars depuis un win10 en remote sur une Tinker ? Je les mets où les fichiers ?  Est ce que win 10 utilise les fichiers sur Tinker ou bien sur un répertoire qu'il faut créer sur win 10 ? J'ai pas encore eu l'occasion de tester 😞

Merci du coup de main !

Bonne soirée.

 

 

Share this post


Link to post
Share on other sites
Il y a 15 heures, Lucky062 a dit :

Bonjour à tous,

Je vais encore passer pour une andouille mais bon, je m' lance !

 

Ma question porte sur l'astrométrie ; je sais grâce à vous où je dois enregistrer les fichiers sur PC ubuntu quand je l'utilise sur une Tinker mais qu'en est-il de l'utilisation de Kstars depuis un win10 en remote sur une Tinker ? Je les mets où les fichiers ?  Est ce que win 10 utilise les fichiers sur Tinker ou bien sur un répertoire qu'il faut créer sur win 10 ? J'ai pas encore eu l'occasion de tester 😞

Merci du coup de main !

Bonne soirée.

 

Quand tu utilise kstars/ekos sur Windows 10, si tu souhaite faire de l'astrometrie il faut que tu selectione (dans la partie astrometrique de ekos) soit online si ton pc est connecté a internet (a ce moment c'est un serveur qui fera le calcul) ou remote (a ce moment c'est la tinkerboard qui fera le calcul).

Mais si tu te connect au serveur indi de ta tinkerboard, tu verra que dans l'onglet astrometrique de ekos la partie remote est grisé, c'est que dans le serveur indi que tu as créé tu n'a pas choisi "astrometrie" dans les accessoires afin de permettre a ta tinkerboard de faire le calcul.

 

Du coup pour les fichier d'astrometrie, si tu le fait en online tu t'en fou. Si tu fait en remote ils doivent être dans la tinkerboard.

Tu aurai pu le faire en local si ton ordinateur de contrôle serai aussi sur linux.

Share this post


Link to post
Share on other sites

Salut tout le monde,

 

Un grand merci dragonlost ; je vais voir ça !

Bonne semaine 😉

Share this post


Link to post
Share on other sites
Il y a 7 heures, gehelem a dit :

Eeeeeeeexcellent !!!!!!

Qui a essayé  ?

 

Ouaou ! ça c'est bien super bien développer ! Motiver le mec !

Share this post


Link to post
Share on other sites
Il y a 2 heures, dragonlost a dit :

 

Ouaou ! ça c'est bien super bien développer ! Motiver le mec !

oh dis, hein ?

tu crois que je suis en train de faire quoi là ?

edit : et donc marche pas, mon pc est cassé

Share this post


Link to post
Share on other sites

bon je n'y arrive pas, ça plante de cette façon

odroid@odroid:~/mobindi$ npm start

> mobindi-backend@0.0.0 start /home/odroid/mobindi
> node dist/app.js

module.js:550
    throw err;
    ^

Error: Cannot find module '/home/odroid/mobindi/dist/app.js'
    at Function.Module._resolveFilename (module.js:548:15)
    at Function.Module._load (module.js:475:25)
    at Function.Module.runMain (module.js:694:10)
    at startup (bootstrap_node.js:204:16)
    at bootstrap_node.js:625:3
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! mobindi-backend@0.0.0 start: `node dist/app.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the mobindi-backend@0.0.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/odroid/.npm/_logs/2019-05-11T22_24_55_506Z-debug.log
odroid@odroid:~/mobindi$ 

ça marche pour vous ?

 

J'ai posté sur le forum indi pour demander

Share this post


Link to post
Share on other sites

Donc pour les copains qui comme moi copient/collent dans un terminal sans trop savoir, voilà ce qu'il faut faire :

sudo apt-get install git cmake zlib1g-dev libcurl4-openssl-dev libgsl-dev libraw-dev libcfitsio-dev libjpeg-dev libpng-dev libcgicc-dev daemontools

curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
sudo apt-get install -y nodejs
npm install

git clone https://github.com/pludov/mobindi.git

cd mobindi && npm install && npm run-script build
cd ui && npm install && npm run-script build
cd ..
cd fitsviewer && cmake . && make
cd ..

Et pour lancer le machin

npm start

(il manquait qq bouts, le développeur m'a répondu tout de suite 🙂 )

Share this post


Link to post
Share on other sites

Super, merci les testeurs. Moi j'ai pas encore testé. Une question est: est-ce que ça fonctionne en local?

Je veux dire sur le RPi ou la Tinker muni d'un petit écran de 7" qui consomme rien.

Ça ferait un truc avec des contrôles directement accessibles pour tout ce qui est réglages, alignement polaire surtout.

Share this post


Link to post
Share on other sites

Cool cela marche sur une tinker board.  Je vais tester sur un RPI ce soir

Je ne suis pas sur que cela soit raisonnable sur un RPI même un 3B+ trop peu de mémoire .

 

Maintenant j'ai un doute sur son utilité, il faut démarrer Indi et Phd2 avant il nous faut donc accéder au nanoPC pour les lancer via VNC par exemple, et dommage que cela ne fonctionne pas en INDI remote (Enfin j'ai pas trouvé, mais j'ai pas chercher très longtemps)

 

En revanche pour une utilisation astrophoto Why not tout les outils y sont
Ceci dit c'est a suivre

 

 

 

Share this post


Link to post
Share on other sites

J'ai fais le test sur RPI3, comme prévu cela manque de mémoire, j'ai même eu du Swap.

Donc a réserver au conf un peu plus solide en mémoire. 

Je ne sais pas si c'est dû au RPI mais j'ai eu beaucoup de bug d'affichage, problème de stabilité du serveur.

Share this post


Link to post
Share on other sites

Bonjour,

Je viens de tester hier mobindi (Tardivement car j'étais en vacances) et c'est vraiment très bien. Sur un smartphone, on y arrive.

Mais je n'ai pas vu quelque chose qui m'intéresserai y-a-til possibilité de faire un goto sur un objet ? J'ai rien trouvé, ni en manipulant ni dans la doc dans le github ?

Quelqu'un a vu quelque chose ?

Je vois ici avant de poser la question sur le forum indi.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.