Recommended Posts

il y a 11 minutes, gehelem a dit :

Mais en fait c'est censé être reconnu comme une webcam toute bête, non ?

Oui, tout à fait, alors bon, à mon avis la soluce n'est pas loin : firmware et pilote, et ça marche, j'en suis persuadé.

Pour Linux, les fabricants sont souvent feignants comme il n'est pas permis pour mettre à jour leurs propres produits, mais sous Nux on a tellement l'habitude que ça en devient un jeu (si on aime ça). :be:

Même pour les Atik il y a des solutions, d'après ce que j'avais pu voir, alors qu'au départ, plein d'esprits chagrins pleurent ça marche paaaaas, impossible sous Linux ! :rolleyes:

 

Share this post


Link to post
Share on other sites

Le pire c'est que je viens de faire le test avec un très vieille Quickcam et elle est reconnue et fonctionne sans aucun problème... C'est rageant !

 

Share this post


Link to post
Share on other sites

Si j'avais cette cam, j'essaierais chez moi, désolé !

Peut-être en posant la question sur CN ? C'est lu surtout par les Américains du Nord mais pas seulement, tu toucheras plus de monde que sur WA. ;)

 

Tu n'oses pas installer le firmware ? Si c'est le bon pour ta cam, bien sûr.

Share this post


Link to post
Share on other sites

Mes connaissances en linux sont limitées donc je ne suis pas sûr de le faire correctement 

et une update du firmware empecherait-elle de la faire tourner aussi sous Windows ?

Share this post


Link to post
Share on other sites
il y a une heure, Lensed Star a dit :

Mes connaissances en linux sont limitées donc je ne suis pas sûr de le faire correctement 

et une update du firmware empecherait-elle de la faire tourner aussi sous Windows ?

Si le firmware est bien installé, au pire bien évidemment elle fonctionnera sous Windows, mais à mon avis elle fonctionnera avant sous Linux.:be:

 

On apprend en faisant, comme jouer du piano... ;)

 

Je pars en HS, mais je dirais qu'il y a deux choses essentielles à considérer :

 

1) si on décide de fonctionner sous Nux (terme familier affectueux ;)), on fera un minimum attention pour que les appareils ou applications à faire tourner soient compatibles, à présent ils le sont à 90%, en trèèèès nette augmentation depuis le début des années 2000, mais il faut jeter un œil sur la doc avant, et/ou effectuer une petite recherche sur Internénette pour s'en assurer, j'ai pris le réflexe et ça prend quelques minutes,

2) on finit par prendre le problème à l'envers en étant exclusivement sous Linux : on prend ce qui fonctionne, comme je ne mets pas de gas-oil dans mon moteur à essence, et franchement je ne vois pas ce qui me manque depuis 10 ans que je tourne à 100% sous Linux, Windows c'est du passé pour moi comme pour beaucoup de linuxiens.

 

C'est un peu comme se passer de Google, si on décide de le faire ça va très bien et qui plus est on gagne en furtivité et en ramassage de données rebalancées en SPAMs et autres spywares. :cool:

Mais cela reste un avis personnel, chacun fait comme il l'entend.

Share this post


Link to post
Share on other sites
il y a 40 minutes, Lensed Star a dit :

il faut juste que je comprenne les étapes d'installation du firmware pour ne pas commettre d'erreur

C'est de la ligne de commande, j'en faisais aussi sous Windows, mais si tu commets une erreur, le PC ne va pas exploser, ça ne va pas s'installer, point.

Finalement, si tu connais quand même quelques rudiments, tu fais un copier-coller des commandes, et paf ça démarre.

 

1) l'appli ou le pilote, ou le firmware, te parvient sous forme de fichier de compressé, donc tu le décompresses,

2) il y a toujours un petit fichier Readme à lire dans le dossier obtenu,

3) dans le lien que j'ai donné le gars donne la commande (à faire en root, c'est-à-dire en tant qu'administrateur, avec sudo ou su - :).

 

Un petit message à l'auteur de ce topic pourrait éventuellement t'aider ?

 

Bon, je comprendrais que tu trouves tout cela assez compliqué, mais tu t'es attaqué à un truc qui, à l'origine, n'était pas spécialement prévu pour fonctionner sous Linux non plus ! :be:

Share this post


Link to post
Share on other sites

Oui, tiens-nous bien sûr au courant !

 

Cela peut intéresser par ailleurs d'autres astrams !!

Share this post


Link to post
Share on other sites
Le 22/08/2018 à 19:34, paradise a dit :

Facile à trouver si pas dans les dépôts de base : par exemple ici si tu dois utiliser du .deb : http://ftp.univ-avignon.fr/pool/main/libu/libuvc/

 

Quand j'ai affaire au son et à la vidéo, j'installe presque tout... :be:

 

Sur le site ils disent texto qu'il n'est pas nécessaire d'updater le firmware, puisqu'il y a un oitil d'installation fourni, mais même pour un dongle Wifi dernière génération à antenne bi-bande, j'ai dû aller chercher un pilote à jour sur Github, alors bon...

Il y a la liste des caméras aussi :

https://github.com/TheImagingSource/tiscamera/wiki/Getting-Started-with-USB-2.0-CMOS-Cameras

 

Le gars a pourtant updaté, il est allé chercher ça :

https://github.com/TheImagingSource/tiscamera/blob/master/data/firmware/usb2/dfk72uc02_3012.euvc

 

Cliquer sur Download pour avoir le fichier d'install du firmware, qui est au format .euvc

Je suis reparti de 0 pour faire proporement mais pour libuvc il y a un problème :

 

-- The C compiler identification is GNU 7.3.0
-- The CXX compiler identification is unknown
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
CMake Error at CMakeLists.txt:2 (project):
  No CMAKE_CXX_COMPILER could be found.

  Tell CMake where to find the compiler by setting either the environment
  variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
  to the compiler, or to the compiler name if it is in the PATH.


-- Configuring incomplete, errors occurred!
 

J'ai beau chercher je pense que mes compétences en Linux sont insuffisantes pour y arriver.

 

Edited by Lensed Star

Share this post


Link to post
Share on other sites
Citation

The CXX compiler identification is unknown

Il te manque des outils de compilation.
Quand tu installes une distribution grand public, c'est au départ installé pour une utilisation grand public,
mais si tu te lances dans les compilations, il faut installer d'office les outils comme gcc+, cmake,
et autres.
Si tu es sous Ubuntu, complète ton installation avec :
# sudo aptitude install build-essential

ou

# sudo apt-get-install build-essential
et essaye à nouveau.

Share this post


Link to post
Share on other sites

y'a du mieux 

quand je fais

git clone https://github.com/ktossell/libuvc
cd libuvc
mkdir build
cd build
cmake ..

tout se passe bien mais en arrivant à make && sudo make install

 

fatal error: libusb.h: Aucun fichier ou dossier de ce type
 #include <libusb.h>
          ^~~~~~~~~~
compilation terminated.
CMakeFiles/uvc_static.dir/build.make:62: recipe for target 'CMakeFiles/uvc_static.dir/src/ctrl.c.o' failed
make[2]: *** [CMakeFiles/uvc_static.dir/src/ctrl.c.o] Error 1
CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/uvc_static.dir/all' failed
make[1]: *** [CMakeFiles/uvc_static.dir/all] Error 2
Makefile:129: recipe for target 'all' failed
make: *** [all] Error 2
 

Share this post


Link to post
Share on other sites

Il te manque les sources de libusb 

Pour les installer :

sudo apt install libusb-dev

Share this post


Link to post
Share on other sites

bon pour libuvc et libusb cette fois c'est bon, il a fallu que j'installe quelques autres petites choses qui me manquaient comme pkgconf...

Bref tout c'est est bien installé cette fois

Mais toujours rien sous EKOS donc il reste la partie du firmware à attaquer et là je nage encore un peu...

Linux au quotidien c'est simple mais pour cette caméra faut vraiment se battre !

 

Share this post


Link to post
Share on other sites

j’avance, j'avance 

 

j'en suis à sudo ./firmware-update -l

 

Found 1 device(s).

Name           - ID        - Serialnumber
NexImage 5     - 199e:8207 - 19314002
 

 

La Neximage est bien là !

Edited by Lensed Star

Share this post


Link to post
Share on other sites
il y a 33 minutes, Lensed Star a dit :

La Neximage est bien là !

ahah !

c'est encourageant, ça !

Bravo

Share this post


Link to post
Share on other sites

et encore mieux, merci beaucoup à vous pour toute l'aide apportée. La Neximage est reconnue et se lance. Bon sous EKOS il y a eu un crash du driver Indi mais elle fonctionne tout de même. Me reste à tester ça en condition réelle maintenant 

 

 

Capture du 2018-08-26 16-53-29.png

  • J'aime 1

Share this post


Link to post
Share on other sites

Super ! :banana:  Bravo aussi pour ta ténacité !

 

Quand je dis que sous Nux tout finit par fonctionner ! ;)

 

Ce qu'il y a, c'est que les fabricants ne se bousculent pas pour fournir les paquets et firmware à jour pour Linux, et il faut aussi compléter sa distribution avec les applis et dépendances (bibliothèques) dont on a besoin dès qu'on sort d'une utilisation basique.

Share this post


Link to post
Share on other sites

En tout cas merci beaucoup sans votre aide je n'y serai pas arrivé Paradise et Gehelem.

Il manquait effectivement beaucoup de dépendances et paquets au départ.

Je vais essayer de compiler tout ça dans une fiche récapitulative quand j'aurai un moment. Cela pourra toujours servir à quelqu'un d'autre.

Content de ne pas avoir eu à installer windows. Le PC portable que j'ai dédié à l'astronomie date de 2013 donc sous Ubuntu (version 18.04 en environnement budgie) il tourne bien. Je pense même changer le disque dur pour un SDD. Mais là pour ne pas avoir à tout refaire je vais voir comment cloner mon disque puis réinstaller l'image directement sur un SSD.

Bref ça marche et c'est super.

Encore merci mille fois.

  • J'aime 1
  • Merci / Quelle qualité! 1

Share this post


Link to post
Share on other sites

Juste pour confirmer :

J'ai installé un SSD à la place du HDD 5400 rpm de base. Y'a pas photo niveau accélération.

Du coup comme je ne suis pas parvenu à cloner mon disque j'ai réinstaller ma distri Ubuntu Budgie.

Et bien tout refonctionne nikel pour la Neximage et je l'ai aussi testée sous windows 7 elle marche impeccable aussi.

Bon je reste sous Linux pour le pC portable et mon iMac pour le fixe. Les deux se complètent bien.

 

Petite question, ma version de Kstar n'est pas totalement francisée, y'a moyen de remédier à ça ?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.