Jump to content
Colmic

TUTORIAL pour le traitement complet d'une image APN avec les scripts SIRIL et PHOTOSHOP

Recommended Posts

Il y a 12 heures, QualQuek a dit :

Cette fois, 3200 iso et 70 photos de 30sec, ben désolé mais je ne vois pas de changement l'image après traitement SiRiL est très bruitée, je ne vois pas la différence entre des pauses de 2 minutes et de 30 sec.

Alors certes je n'ai plus du tout le souci de flats car j'ai fait attention a ne pas déplacer la monture, pas éteindre l'appareil photo etc...Mais ça reste super bruitée je trouve.

 

70 x 30s ça fait 35 minutes de pose. C'est relativement insuffisant pour supprimer totalement le bruit.

Autre point : ton ciel a l'air assez pollué. Pas d'autre solution que de trouver un meilleur ciel.

Ne pas oublier de faire du dithering pour limiter la trame.

Share this post


Link to post
Share on other sites

C'est noté, je vais faire beaucoup plus de pause, la dernière fois je n'ai pu en sauver que 70 avant les nuages.

Par contre mon ciel n'est pas tant pollué que ça je suis à Lailly-en-Val en campagne et l'éclairage publique est éteint la nuit après 23h30, normalement c'est pas mal comme condition enfin je pensais.

Je vais voir les réglages avec PHD2 pour le dithering.

 

Encore merci pour ton temps @Colmic je vais devenir ton padawan à force :lol:

Share this post


Link to post
Share on other sites
Le 23/02/2020 à 08:19, lock042 a dit :

Oui, celle des PPA ca va.

 

Vincent parle surtout de celle en ce moment dans les sources :). Mais celle des PPA elle peut être utilisé sans trop de soucis.

Bon, alors, finalement, je me demande si elle ne souffrirait pas de problèmes de mémoire...😜

Ça fait une bonne quinzaine de jours que je me casse les dents sur le traitement de 500 photos de la lune, et tout se passe bien jusqu'au moment de l'alignement.

Et, là, au bout d'un (trèèèèèès) long moment, ça plante direct sans crier gare. Et je ne sais même pas où trouver un log qui pourrait être utile.

Je suis sous Ubuntu 18.04 sur un Dell 5530 avec 8 Go. Comment puis-je participer à la résolution ?

Share this post


Link to post
Share on other sites
il y a 10 minutes, FalCT60 a dit :

Bon, alors, finalement, je me demande si elle ne souffrirait pas de problèmes de mémoire...😜

Ça fait une bonne quinzaine de jours que je me casse les dents sur le traitement de 500 photos de la lune, et tout se passe bien jusqu'au moment de l'alignement.

Et, là, au bout d'un (trèèèèèès) long moment, ça plante direct sans crier gare. Et je ne sais même pas où trouver un log qui pourrait être utile.

Je suis sous Ubuntu 18.04 sur un Dell 5530 avec 8 Go. Comment puis-je participer à la résolution ?


8 Gb C’est très peu. J’avais 12Gb et ça plantait régulièrement. Je viens de passer à 32Gb et ça marche super bien, même si visiblement Siril ne gère que 16Gb... ça laisse 16Gb pour le reste !


Quant à PS CC, c’est un régal.

Share this post


Link to post
Share on other sites
Posted (edited)
il y a une heure, Fred_76 a dit :

même si visiblement Siril ne gère que 16Gb

Il n'y a aucune raison à ça. J'ai 16Go et ca plante jamais dans mes traitement.

 

@FalCT60: Si niveau mémoire ca va pas il faut aller dans les paramètres.

Edited by lock042

Share this post


Link to post
Share on other sites
Il y a 16 heures, lock042 a dit :

Il n'y a aucune raison à ça. J'ai 16Go et ca plante jamais dans mes traitement.

 

@FalCT60: Si niveau mémoire ca va pas il faut aller dans les paramètres.

En fait j’utilise Sirilic. Et avec 32Gb d’installés, Dans le log de Sirilic je lisais au mieux 15 Gb d’utilisés. J’ai mis tout à zéro dans les paramètres de Siril et de Sirilic et maintenant ça utilise jusqu’à environ 25Gb, et ça fonce !

 

Avec 12 Gb, ça plantait régulièrement en drizzle avec des images de 1000D. Par contre en changeant la mémoire je me suis rendu compte qu’Asus avait utilisé 2 Sdram, une Samsung de 4 Gb CL 11 et une SK Hynix de 8 Gb CL 11, pas la même marque, pas la même taille... donc mémoires probablement mal synchronisées. J’ai maintenant 2x16 Gb CAS Kingston HyperX CL16 appariées et ça marche très bien.

Share this post


Link to post
Share on other sites

La gestion de la mémoire n'est pas la même entre windows et linux, et là ou le premier nécessite 32 Go, le second se contente généralement de 8.

J'ai évoqué des problèmes de mémoire, car tout semble se passer comme si elle n'était pas correctement restituée au fur et à mesure des opérations.

C'est une simple hypothèse, cela fait trèèèès longtemps que je ne programme plus, et depuis les choses ont énooooormément évolué.

Mais ça y ressemble fortement.

Je vais passer la mémoire en illimité dans les paramètres et voir ce qu'il advient.

Share this post


Link to post
Share on other sites

La taille des images est la même, y'a pas de raison que ça prenne plus sur un OS que sur un autre.

  • J'aime 1

Share this post


Link to post
Share on other sites

D'autant plus qu'il n'y a pas de différence dans le code entre les deux OS.

La seule différence, c'est le code qui estime la RAM dispo. Et pour Windows on utilise les API Microsoft.

Share this post


Link to post
Share on other sites

Ma comparaison entre les deux OS s'arrête au fait qu'à quantité de mémoire égale, disons 8 Go, windows a déjà besoin de la moitié pour lui tout seul, alors que linux se contente du quart.

Pour ce qui est de mon problème, ce qui m'agace c'est que d'une fois à l'autre ça ne plante pas au même moment et, hier, c'est même allé jusqu'au bout.

Après, comme il est bien indiqué que cette version n'est pas totalement exempte de bugs, je ne m'en fais pas trop, et si je peux aider à améliorer, je suis d'accord. Mais il faut m'y aider.

J'espère n'avoir froissé personne, je n'en ai jamais eu l'intention.

Share this post


Link to post
Share on other sites
Il y a 7 heures, FalCT60 a dit :

Pour ce qui est de mon problème, ce qui m'agace c'est que d'une fois à l'autre ça ne plante pas au même moment et, hier, c'est même allé jusqu'au bout.

Ca ressemble clairement à un soucis de mémoire.

As tu essayé de passer tes options en mémoire "illimité" ?

Share this post


Link to post
Share on other sites

Au contraire je dirais qu'il faut la limiter plus qu'avant si ça plante.
Mais comme j'ai déjà dit, siril calcule la mémoire disponible au démarrage d'un empilement et considère que cette mémoire restera disponible durant l'empilement (et la normalisation). Si le système fait autre chose, il faut limiter siril à la moitié de la mémoire libre par exemple en mettant 0.5 comme facteur d'utilisation mémoire.

  • J'aime 1

Share this post


Link to post
Share on other sites

@Lock042 : le fait de passer en illimité ne change rien. Un moment, j'y ai cru, puisque ça a abouti, mais toutes les fois suivantes ça a de nouveau planté, ainsi que je l'ai mentionné, à des stades différents.

Il est à noter que j'ai dernièrement réinstallé totalement ma machine, je suis donc reparti sur du propre et, pour pouvoir utiliser sirilic, j'ai même désinstallé Python 2.7, ce qui a eu pour conséquence de désinstaller par la même occasion deux ou trois autres logiciels (dont Inkscape).

 

@vinvin : je vais tenter en limitant à 50%, comme tu le préconises.

Pour tout dire, j'ignore si le système fait autre chose que ce que je lui demande, cependant lorsque ça plante la machine est ralentie pendant un certain temps.

Share this post


Link to post
Share on other sites

oui c'est parce que ça sort de la mémoire que ça fait ça

regarde dans le gestionnaire de tâches de windows (control-shitf-escape) en triant par la colonne mémoire quels sont les processus qui prennent beaucoup de mémoire, et éventuellement ferme les si tu ne t'en sers pas pour en gagner.

Share this post


Link to post
Share on other sites

J'ai commandé de la RAM. Dommage que mon ordi soit limité à 16 Go.

Mais il s'agit néanmoins bien d'un problème de RAM, d'une manière ou d'une autre. Lors du plantage, la machine devient très fortement ralentie, la simple ouverture d'une fenêtre demande plusieurs sollicitations et ne survient qu'au bout d'une ou deux minutes. Puis, tout redevient normal.

À suivre...

Share this post


Link to post
Share on other sites

Non mais si tu limites siril ça n'arrivera pas. Je traite avec 2 ou 4G de RAM et j'ai pas de problème.

Share this post


Link to post
Share on other sites

Je l'ai limité à 50%, il a planté sec un peu après avoir débuté l'alignement.

J'attends ma RAM, je recommencerai une fois installée.

Share this post


Link to post
Share on other sites

Ah oui tu as ubuntu pardon, donc regarde avec 'free -h' combien tu as de libre sans lancer siril. Essaie de vérifier combien il détecte de libre et combien il compte utiliser dans la sortie console.
Est-ce que tu l'as compilé en 64 bits ou 32 ? Parce que si ça plante sans prévenir c'est peut-être parce qu'il est en 32 et qu'il veut plus de 2G de mémoire (ça m'arrive...).

Share this post


Link to post
Share on other sites

Petite interrogation : durant la nuit l'appareil s'est retrouvé à shooter en portrait, est-ce que SiRiL va reconnaître ces images ou les écarter?

Est-il possible de les remettre en paysage?

Share this post


Link to post
Share on other sites

Cela n’a aucune incidence avec Siril.

 

Par contre ça en a une avec Sequator, si tu l’utilises.

Share this post


Link to post
Share on other sites
à l’instant, Fred_76 a dit :

Cela n’a aucune incidence avec Siril.

 

Par contre ça en a une avec Sequator, si tu l’utilises.

 

Han génial ce SiRiL merci de la réponse!

Share this post


Link to post
Share on other sites

Normalement tu peux désactiver la rotation automatique. C’est plus pratique pour prévisualiser les photos astro après sur l’ordinateur.

Share this post


Link to post
Share on other sites

J'ai en effet désactivé la rotation de l'affichage dans le menu "playback" j'espère que c'est bien ça car j n'ai pas trouvé d'autre réglage pour ça.

Encore merci @Fred_76

Share this post


Link to post
Share on other sites
Il y a 1 heure, QualQuek a dit :

Petite interrogation : durant la nuit l'appareil s'est retrouvé à shooter en portrait, est-ce que SiRiL va reconnaître ces images ou les écarter?

 

Ce n'est que de l'affichage, les images continuent à s'enregistrer en paysage, et c'est normal, ton capteur ne bouge pas physiquement dans le boîtier :)

Share this post


Link to post
Share on other sites
Le 23/03/2020 à 22:42, vinvin a dit :

Ah oui tu as ubuntu pardon, donc regarde avec 'free -h' combien tu as de libre sans lancer siril. Essaie de vérifier combien il détecte de libre et combien il compte utiliser dans la sortie console.
Est-ce que tu l'as compilé en 64 bits ou 32 ? Parce que si ça plante sans prévenir c'est peut-être parce qu'il est en 32 et qu'il veut plus de 2G de mémoire (ça m'arrive...).

J'utilise la version du dépôt.

J'ai reçu la RAM aujourd'hui - 16 Go -, installée, ça tourne depuis 19h40 environ.

23 min pour la conversion, je n'ai pas relevé le temps mis pour l'exportation avec normalisation.

Là, il en est à l'alignement, et ça doit durer encore une trentaine de minutes environ avant que je puisse lancer l'empilement.

Niveau mémoire, il tape à hauteur de près de 10 Go.

Faut quand même reconnaître qu'il doit falloir pas mal de ressources, pour traiter 500 photos de 36 Mo !

Share this post


Link to post
Share on other sites
Posted (edited)
Il y a 12 heures, QualQuek a dit :

Petite interrogation : durant la nuit l'appareil s'est retrouvé à shooter en portrait,

Ton appareil a effectué une rotation de 90° sur son axe optique ?

Edited by FalCT60

Share this post


Link to post
Share on other sites
il y a 13 minutes, FalCT60 a dit :

Ton appareil a effectué une rotation de 90° sur son axe optique ?

Non il suffit juste de basculer un peu pour que le capteur de position décide d’orienter le paramètre de portrait à paysage...

Share this post


Link to post
Share on other sites
Posted (edited)

Ah ! d'accord, c'est juste l'orientation sur l'écran de contrôle qui est affectée suite à bascule de l'appareil autour de l'axe AD. 😎

-- -- --

Suite de mes aventures de traitement lunaire : j'ai débuté l'empilement à 22h54, la mémoire utile est estimée à ~7 Go.
Ça vient juste de finir : 23h05. Il ne me reste plus qu'à effectuer le traitement final... voiià :

20200229-2.jpg

Edited by FalCT60

Share this post


Link to post
Share on other sites

La mémoire est estimée à 7G pour 16 d'installés, t'as laissé le facteur 0.5 dans les paramètres non ? Si tu ne fais pas trop de trucs en même temps tu peux réessayer avec 0.9 environ pour voir si ça va plus vite et à quel point il en bouffe :)

D'un autre coté, en donner moins à siril permet d'en donner plus à la mémoire cache du système, donc ça pourrait aussi améliorer la charge I/O et faire que ça va plus vite dans la globalité... Ca dépend de la machine je suppose.

Share this post


Link to post
Share on other sites

Par contre j'ai 360 photos de 30sec à 2500 iso sur M106 et le résultat est franchement pas terrible, c'est extrêmement bruité je ne comprends pas pourquoi c'est à ce point bruité.

J'ai pourtant pris 65 dark, 100 offset et 100 flat, ça ne change absolument rien, le résultat est toujours très bruité voir inexploitable ensuite sous lightroom.

Je vous joins  une capture d'une brute  et le résultat sorti de SiRiL, j'ai entendu vanter les mérite de l'A7S en astrophoto mais là c'est vraiment pas jojo.

 

m106_brute.PNG

m106_SiRiL.PNG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.