Jump to content
Argonothe

Installation de la version de développement de Siril sous Windows10 ou W7 64 bit

Recommended Posts

il y a 20 minutes, Colmic a dit :

Est-ce un comportement voulu ?

Il faut charger la séquence en cliquant sur l'option "forcer a recalculer ..."

Share this post


Link to post
Share on other sites
il y a 14 minutes, Colmic a dit :

Autre question :

- J'ai 4 séquences d'images : L R V et B

- SiriL n'arrive pas à m'aligner les images lors de la composition RVB. J'ai essayé les différentes méthodes sans succès.

-  de plus je n'arrive pas à utiliser le mode manuel qui consiste à donner le décalage x et y. C'est systématiquement grisé.

Crée une sequence de tes 4 images. Genre image_1 image_3 ....

Fait un alignement global sur ces images. Renome les fichiers créés comme tu veux et utilise l'outil de composition RVB. Dans ce dernier on gère pas la rotation, ca serait bien trop chiant. De plus on ne permet pas un alignement manuel actuellement dans ce module.

Share this post


Link to post
Share on other sites
il y a 4 minutes, lock042 a dit :

Crée une sequence de tes 4 images. Genre image_1 image_3 ....

Fait un alignement global sur ces images. Renome les fichiers créés comme tu veux et utilise l'outil de composition RVB. Dans ce dernier on gère pas la rotation, ca serait bien trop chiant. De plus on ne permet pas un alignement manuel actuellement dans ce module.

 

Ok capiche :)

Share this post


Link to post
Share on other sites

Si l'alignement ne marche pas. Pour cause de trop grosse différence de luminosité dis le moi. Je te donnerai une astuce.

Share this post


Link to post
Share on other sites
il y a 20 minutes, lock042 a dit :

Si l'alignement ne marche pas. Pour cause de trop grosse différence de luminosité dis le moi. Je te donnerai une astuce.

 

Non ça a marché :) Merci

Maintenant il faut que je fasse un vert synthétique car j'ai pas pu le faire pour 2 images.

Il me semble que les scripts Photoshop savent faire ça, mais est-ce qu'il y a moyen d'en générer un sous SiriL ou Iris ?

Share this post


Link to post
Share on other sites

Dans l'outil de composition RGB, on peut affecter une couleur à une couche, et il y a des couleurs prédéfinies pour les filtres classiques, donc l'OIII aura une couleur entre le bleu et le vert, peut-être que ça pourrait marcher pour ce que tu veux faire.

  • J'aime 1

Share this post


Link to post
Share on other sites
Il y a 20 heures, Pulsar59 a dit :

Sinon j'ai observé un gain de vitesse d'un facteur 3,5x entre 0.9.10 et 0.9.11 sur un script CCD complet (prétraitement-alignement-empilement). I7, 8GB de RAM, win 8.1.

Oui, et une branche en construction permet encore une augmentation de la vitesse. Bientôt les images seront traitées avant les prises de vue ;).

Share this post


Link to post
Share on other sites
Il y a 15 heures, Colmic a dit :

 

Non ça a marché :) Merci

Maintenant il faut que je fasse un vert synthétique car j'ai pas pu le faire pour 2 images.

Il me semble que les scripts Photoshop savent faire ça, mais est-ce qu'il y a moyen d'en générer un sous SiriL ou Iris ?

Pour faire ça, en général :

- je normalise le fdc de B et R (fonctions stat et fmul)

- je fais V = 0,5(B+R) (fonctions fmul et iadd)

- j'équilibre les couleurs R V B par astrométrie.

 

C'est tout, pas très compliqué.

Share this post


Link to post
Share on other sites
Il y a 5 heures, Pulsar59 a dit :

Pour faire ça, en général :

- je normalise le fdc de B et R (fonctions stat et fmul)

- je fais V = 0,5(B+R) (fonctions fmul et iadd)

- j'équilibre les couleurs R V B par astrométrie.

 

C'est tout, pas très compliqué.

 

Merci je vais tester ça sous Iris, en attendant que ça soit développé sous SiriL :)

 

Share this post


Link to post
Share on other sites
il y a 30 minutes, lock042 a dit :

Cest sous siril ce qu'il te dit @Colmic

 

AHHHHHHHH.

Et tu le fais en script ?

Oué je suis nul, faut me mâcher un peu le boulot :)

Merci !

Share this post


Link to post
Share on other sites

Tape les commandes dans la console Siril tu te fera moins chier. Un script pour ca c'est un peu overkill

Share this post


Link to post
Share on other sites

Bonsoir lock042,

 

Un problème avec SIRIL 11 alpha5.

 

J'avais installé cette version par la méthode de Ryo en mars sur 1 micro sous W7 et un autre sous W10. J'ai utilisé plusieurs fois mes scripts pour mon ASI 294MC sans aucun souci. A mon retour de vacances, plus d'onglet ''Script'' sur mes 2 micros! J'ai essayé de rinstaller une éventuelle mise à jour avec les commandes que tu as donné le 5 avril, mais j'ai une erreur à la ligne ''make $$ make install'' et pas d'installation.

Comment faire pour récupérer les scripts?

Merci pour une réponse.

 

Edit: problème résolu.

Jean Louis.

 

 

Edited by COOPER168
Fichier effacé par erreur.

Share this post


Link to post
Share on other sites

Bon j'espère ne pas trop déterrer le sujet, mais mon souci du jour correspond pile poil au topic.

Je suis sous W10 et j'utilise Siril en version beta moyennant l'install de MINGW64 comme décrit ici.

Je met à jour Siril avant chaque utilisation. Tout est parfait.

cd siril
git pull
./autogen.sh
make
make install

 

Sauf ce matin. A la commande:

$ ./autogen.sh
bash: ./autogen.sh : /bin/sh : mauvais interpréteur: No such file or directory

 

Je sais que c'est purement du Linux, mais comme je suis une buse...

Qqn peut m'aider?

 

Fred

 

Share this post


Link to post
Share on other sites

C'est pas banal ça ! Comment ça serait possible de ne pas avoir /bin/sh ? Peut-être qu'il faut remplacer le début du fichier par /bin/bash ?

Share this post


Link to post
Share on other sites

Comme ça?

$ /bin/bash/./autogen.sh
bash: /bin/bash/./autogen.sh: No such file or directory

 

Hum, on dirait qu'il manque un truc.

Malgré tout (mais ça n'a certainement rien a voir) Siril fonctionne bien dans sa version non mise à jour.

Pour tout dire, j'ai cloné mon HDD vers un SSD il y a qqs jours sans aucun souci par ailleurs. Surement sans rapport.

 

Sinon, je refais l'install de MINGW depuis le début...

 

Fred

Share this post


Link to post
Share on other sites

C'est un soucis de fichier type windows vs UNIX.

Ta copie a foutu le bordel je pense.

 

Sinon la version windows a actuellement un bug d'affichage au niveau de l'histogramme avec l'ascenseur de la fenetre qui empêche d'utiliser les curseurs.

J y travaille

  • J'aime 1

Share this post


Link to post
Share on other sites
Le ‎11‎/‎09‎/‎2019 à 11:09, Batbihirulau a dit :

Je met à jour Siril avant chaque utilisation. Tout est parfait.

 

 

Si cela peu t'aidée j'ai fais la mise a jour et aucun pb pour moi

 

bon ciel

 

 

 

  • J'aime 1

Share this post


Link to post
Share on other sites

Merci Ryo,

Tout est rentré dans l'ordre, les Màj se font bien, maintenant que j'ai ré-installé la totale.

C'est mon clonage HDD->SDSD qui a mis le souk. Bizarre, pas d'autre souci sur le reste.

Bref, tout est OK.

Share this post


Link to post
Share on other sites

Pour info, pour faire la maj j'ai dû lancer les 2commandes suivantes en plus des commandes listées ci-dessous :

pacman -S mingw-w64-x86_64-exiv2
pacman -S mingw-w64-x86_64-libheif

 

image.png.72c5094b024fc6151ab147a6eb82be74.png

Edited by Stéphiou

Share this post


Link to post
Share on other sites

Ce sont des nouvelles dépendances de la future version de siril, merci pour la mise à jour.

Share this post


Link to post
Share on other sites

Salut,

j'ai fini par réussir à installer la version dev en suivant les instructions (et en rajoutant les dépendances indiquées par Stephiou).

J'ai du m'y reprendre à 2 fois, desinstall de MSYS/reinstall (MSYS et tous les packages, pfffiou c'était long!!!) mais ça bloquait toujours au moment du make.

image.png.9019f80ab2d52ef7fada6413c22a2494.png

Alors, si j'avais réfléchi, je me serais évité la réinstall pour rien....J'ai un peu farfouillé, beaucoup transpiré, puis j'ai modifié toutes ces lignes dans les makefile qui ont les slashs qui se sont mis windows-style...je sais pas bien pourquoi:

CC = C:\MinGW64\mingw64\bin\gcc.exe

modifié en:

CC = C:/MinGW64/mingw64/bin/gcc.exe

 

J'imagine bien que c'est pas lié à Siril mais plus à Msys mais bon, des fois que ça bloque quelqu'un d'autre qui a trop hâte de voir la nouvelle version!

Pour le moment, j'ai juste ouvert l'interface. Je cherche encore un peu les menus mais l'intégration des fenêtres de visu et des actions est vraiment super! J'ai un bug sur la maximisation de la fenêtre, le bas est masqué par la barre des taches. J'essaie de faire passer un script demain pour voir...

Share this post


Link to post
Share on other sites

J'ai eu le temps de jouer avec la v0.99 sur W10. J'ai 2-3 trucs qui marchent pas ou pas comme je m'y attendrais, je les poste ici, ou y a un post dédié? Ou je les poste sur Gitlab?

 

Share this post


Link to post
Share on other sites

Sur gitlab c'est les reports de bug.

Attention la vraie version de développement actuelle n'est pas celle sur la branche master, mais float.

Share this post


Link to post
Share on other sites

Ah ben mince, j'ai bien l'impression que c'est la master que je teste (802ebdc5). En plus, c'est bien écrit en gros à l'ouverture qu'on reporte des bugs que sur la master 😇!

Tu veux bien m'expliquer comment je fais pour récupérer une autre branche, stp?

 

Share this post


Link to post
Share on other sites

On va bientôt faire le merge. Ça va être un gros truc. 

Tu peux tjs dire ici si tu as des bugs. 

Share this post


Link to post
Share on other sites

C'est pas grand-chose, mais bon:

- Quand je maximise la fenêtre pour profiter pleinement de la nouvelle interface, j'ai le bas qui est masqué par la barre des taches. Si je la mets en auto-hide, on voit que la fenetre va pas non plus jusqu'en bas (voir photos cachées pour pas pourrir le post). j'ai vérifié dans 0.9.12, ça faisait pas çà.

- Quand je veux faire une déconvolution, il se passe rien (ni sur mon image, ni trace dans le log).

- J'ai eu une fois la fenetre de calibration des couleurs classique (pas celle par photométrie) qui ne voulait pas s'ouvrir, mais j'arrive pas à reproduire.

Et sinon, j'attendrai le merge...

 

C.

 

Spoiler

Taskbar1.thumb.png.d2ee16c5d7a78311e23302cd2a1253bd.png

 

Spoiler

Taskbar1afterAutohide.thumb.png.70209739e76e91c0db7211062fc5fe90.png

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.