lock042

Siril 0.9.10

Messages recommandés

Posté(e) (modifié)

@impla007

ci-joint un script python alléger ( utilisant le pipe) pour lancer un script siril  dans la console ( c'est équivalent à "siril --script script.ssf" si ça marchait  sur Windows10 😂  )

 

runscript.py ** EDIT: nouvelle version **

 

pour le lancer,  il faut taper :

  • runscript.py script.ssf

ou

  • runscript.py "C:\Program Files\SiriL\bin\siril.exe"  script.ssf

 

si ça peut t'aider, alors ce sera bien
 

** EDIT ** :

il faut que la librairie pypiwin32 soit installée:

 

taper cette instruction dans une console "cmd.exe": python.exe -m pip install pypiwin32 

pypiwin32.jpg

 

Modifié par m27trognondepomme

Partager ce message


Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Au fait. @Colmic, @m27trognondepomme, il y a une nouvelle option à la commande preprocess que j'ai mis par défaut dans les nouveaux scripts.

Il s'agit de l'option -stretch. Je la place après -debayer. L'ordre n'a pas d'importance mais cette option n'a pas de sens si on ne debayerise pas.

Aussi elle a un sens que pour les images apn converti par siril >= 0.9.11.

Modifié par lock042

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, lock042 a dit :

Au fait. @Colmic, @m27trognondepomme, il y a une nouvelle option à la commande preprocess que j'ai mis par défaut dans les nouveaux scripts.

Il s'agit de l'option -stretch. Je la place après -debayer. L'ordre n'a pas d'importance mais cette option n'a pas de sens si on ne debayerise pas.

Aussi elle a un sens que pour les images apn converti par siril >= 0.9.11.

 

Et elle fait quoi cette option ?

 

Concernant mon soucis de souris qui disparait, je te confirme que je le reproduis systématiquement, quand j'utilise l'ajustement d'histogramme, je perds le curseur de la souris dès que j'ai cliqué sur apply.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, Colmic a dit :

Et elle fait quoi cette option ?

Elle normalise le dématriçage sur 16bits. Ca permet de gagner plus de dynamique !!

 

il y a 1 minute, Colmic a dit :

je perds le curseur de la souris dès que j'ai cliqué sur apply.

Ah, je pensais que c'était quand tu cliquais sur l'engrenage. OK je reproduis sur Windows.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 25 minutes, Colmic a dit :

je perds le curseur de la souris dès que j'ai cliqué sur apply. 

git pull .....

c'est corrigé ;)

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 4 heures, lock042 a dit :

git pull .....

c'est corrigé ;)

 

Super, je teste ça ce soir. 

Pour info hier soir j'ai re-traité ma M31 (304 brutes). 1h01 de traitement en drizzle 2x.

Je n'arrive pas à obtenir de belles couleurs avec l'ajustement photométrique.

Pourtant pour l'instant ça avait bien marché avec NGC7000, M45, M42, IC434.

Et là, je trouve que par rapport à ce que j'obtenais sous 0.9.9, c'est moins beau.

Je vous la soumets ce soir en rentrant.

  • Merci / Quelle qualité! 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 8 minutes, Colmic a dit :

Je n'arrive pas à obtenir de belles couleurs avec l'ajustement photométrique.

Le but n'est pas d'obtenir de belles couleurs, mais des couleurs réalistes. Ensuite il y'a toujours un travail a faire derrière. Comme tous les algos, c'est pas magique.

Après tu peux aussi sélectionner ton fond de ciel manuellement, car quand l'objet prend une grande place, comme M31, le calcul auto du fond de ciel peut etre foireux.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 15/03/2019 à 07:25, lock042 a dit :

Au fait. @Colmic, @m27trognondepomme, il y a une nouvelle option à la commande preprocess que j'ai mis par défaut dans les nouveaux scripts.

Il s'agit de l'option -stretch. Je la place après -debayer. L'ordre n'a pas d'importance mais cette option n'a pas de sens si on ne debayerise pas.

Aussi elle a un sens que pour les images apn converti par siril >= 0.9.11.

 

@lock042 Ok, j'ai pris en compte "-stretch",  elle sera couplée avec "-debayer". Je la rendrai optionnelle dans sirilic via l'interface graphique  s'il y a  un réel besoin.  J'attends donc la sortie de  0.9.11 avant de la pousser sur Gitlab .

  • J'aime 2

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, m27trognondepomme a dit :

s'il y a  un réel besoin

Personnellement je l'ai mise par défaut dans les scripts. Ca permet de grapiller un peu de dynamique.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

Ma modeste contribution avec un crop du champ de m106 obtenu avec mon feu X-T10 + WO Z61 + monture SA + autoguidage, après pré-traitement avec SIRIL 0.9.11-Alpha2 + finition Luminar.

J'ai utilisé entre autres l'étalonnage couleur par photométrie + l'étirement d'histo Asinh en toute fin de pré-traitement.

Cyril, j'attends un X-T20 en remplacement du X-T10 : je te fournirai un flat au X-T20 si tu en as tjrs besoin.

Encore BRAVO pour le boulot sur SIRIL !

 

 

m106-v5-small.jpg

Modifié par Stéphiou

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour info après maj de la version de dév sous Windaube10 juste maintenant.

SIRIL démarre sans pb et la version reste en Alpha2.

Capture.thumb.JPG.75b5eda9c3f218e41957146dadc976f1.JPG

Modifié par Stéphiou

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 15/03/2019 à 15:55, lock042 a dit :

Le but n'est pas d'obtenir de belles couleurs, mais des couleurs réalistes. Ensuite il y'a toujours un travail a faire derrière. Comme tous les algos, c'est pas magique.

Après tu peux aussi sélectionner ton fond de ciel manuellement, car quand l'objet prend une grande place, comme M31, le calcul auto du fond de ciel peut etre foireux.

 

Voici la brute d'empilement de ma M31 (sous SiriL 0.9.11) : http://www.astrosurf.com/colmic/SiriL0.9.10_64_bits/resultat.fit

Si tu arrives à en sortir un truc sympa, décris-moi précisément ton process stp :)

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, Colmic a dit :

 

Voici la brute d'empilement de ma M31 (sous SiriL 0.9.11) : http://www.astrosurf.com/colmic/SiriL0.9.10_64_bits/resultat.fit

Si tu arrives à en sortir un truc sympa, décris-moi précisément ton process stp

 

 

 

 

Il me semble foireux ton lien ! :?:

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, Great gig in the sky a dit :

Il me semble foireux ton lien ! 

 

Enregistrer la cible du lien sous...

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Colmic a dit :

Si tu arrives à en sortir un truc sympa, décris-moi précisément ton process stp

Les couleurs sont pas top. J'ai essayé avec PI pour voir, cela donne le même rendu jaunatre.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 4 heures, Stéphiou a dit :

Encore BRAVO pour le boulot sur SIRIL !

Merci à toi pour ton retour.

 

Il y a 4 heures, Stéphiou a dit :

SIRIL démarre sans pb et la version reste en Alpha2.

Pas de soucis, juste des warnings.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bizarrement sous SiriL 0.9.9 j'obtenais des couleurs plus sympa.

J'ai essayé avec color calibration normal, et c'est pareil que le photométrique.

Je vois pas ce qui peut clocher.

 

Pour info, avec SiriL 0.9.9 :

M31FSQ106-304x30s-3200iso-14082018.jpg

 

Puis sous 0.9.10 :

M31FSQ106-304x30s-3200iso-14082018_siril0_9_10.jpg

 

Et sous SiriL 0.9.11 :

M31_siril0_9_11.jpg

 

Je sais pas quoi en penser...

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Il n'y a rien a penser. Il y'a probablement des fois ou le photométrique marche pas top. J'ai essayé avec plusieurs softs c pareil.

Siril 0.9.9, 0.9.10 et 0.9.11 ont exactement le même algo de calibration manuel. Il faut donc que tu refasses les mêmes sélections pour retrouver pareil.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de voir un truc bizarre : on dirait qu'on distingue des dégradés sur la dernière image, comme si on n'était pas en 16 bits mais en 8 bits.

 

EDIT : ah, et j'arrive pas à me servir du asinh correctement.

Tu le fais avant l'histogramme ou après ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de reprendre tout le traitement sans l'ajustement photométrique.

C'est bien là qu'il se passe un truc chelou. Ca rajoute des aplats dégradés comme si on travaillait en 8 bits et pas en 16.

 

Celle-ci je l'aime bien (avec ajustement normal des couleurs et asinh) :

M31b_siril0_9_11.jpg

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Cette dernière version se rapproche des teintes données par la photometrie.

Aussi tu devrais refaire le pretraitement entier avec l'option -stretch.

Modifié par lock042

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.