Recommended Posts

Posted (edited)
Il y a 10 heures, Lucky062 a dit :

Ok ! je pensais aussi à un truc du genre ! Je vais améliorer les contacts ! 

Merci encore gehelem !

Par contre on oublie la colle car si elle coule, même très légèrement sur les contacts c'est foutue.

Edited by dragonlost

Share this post


Link to post
Share on other sites

Hello hello

un petit teaser à 9m30 :

https://youtu.be/1LUFzWRw-4s

 

Christophe est venu nous voir pour faire un épisode sur la Nafa, c'est dans la boite, ça sortira quand il aura fait le montage

Vous y verrez vos deux zozos de service (Patrick et moi) qui essaient d'appâter le chaland avec les magnifiques montages d'Hugues...

On s'est bien marrés 🙂

En tout cas pas mal de curieux sont venus nous voir sur les 3 jours, échanges riches et toujours sympathiques.

 

Share this post


Link to post
Share on other sites

Les Nafaboys aux RAP

De gauche à droite @huguesmaillet et son fils, @patdut  @Argonothe

Et vautré dans la chaise bibi fricotin.

(et pour anticiper sur la question qui arrivera forcément : la caisse de pinard sous ma monture est arrivée sur place vide)

 

IMG_3679.JPG.ebc17183beba6eb3fcf336829dfed9c4.JPG

  • Merci / Quelle qualité! 1
  • Haha 2

Share this post


Link to post
Share on other sites
Posted (edited)

Salut à tous, à ceux qui sont debout comme à ceux qui sont vautrés dans leur transat en train de siroter du rouge....

 

Bon alors comme je ne peux plus pratiquer d'astro pour quelques mois, je me tourne vers la configuration histoire d'être bien prêt quand je pourrai de nouveau monter mon matos.

Plusieurs changements de mon côté.

1° Après avoir cramé une T7 mono (fait ch@*!) en voulant mettre à jour le firmware pour la faire tourner sous linux, j'ai déniché ici sur les PA une autre caméra. C'est une DFK23U445, j'ai fait quelques essais sous linux avec un PC portable (vieux icore3) ça passe avec le driver V4L donc bon espoir de faire tourner ça sur une micro machine.

Je l'ai testé sur ma NAFABox installée  sur un raspberry Pi3B+, pas très concluant, mais il y a eu des images. Après j'avais des images fixes aussi avec la T7...mais le guidage et les vidéo ne passaient pas.

 

2° Et donc j'ai arrété les tests sur le Pi3 car j'ai acquis sur la Baie pour 25€  une petite Nano Pi M4 avec 2Gb de mémoire seulement mais on va pas se plaindre hein...

Là je suis en train de faire l'install sur la M4. Je compléterais plus tard.
Pour l'instant, j'ai récupéré l'ARMBIAN correspondant et je l'ai mis sur la carte SD puis démarrage et première configuration en SSH pour lancer VNC et avoir accès à l'interface graphique puis récupération du script nafa sur le github et je suis les instruction du README_FR....

Le Pre_Install a bien fonctionné puis Install.sh, après avoir mis le mode graphique car via SSH ça passait pas, ça a lancé pas mal de chose.

Les menus ne sont pas identiques à ceux du site http://nafabox.linux-astro.fr/#scriptinstallation.

C'est normal ?

Là j'ai un joli bug.... le truc suivant tourne en boucle....

image.thumb.png.5e4ea8780e31f80098de78665fac3741.png

 

 

EDIT :

J'ai trouvé comment contourner le problème en faisant un lien symbolique

ln -s /root/.vnc /home/root/

 

Je ne sais pas pourquoi (et j'ai la flemme tout de suite de chercher) mais le script modifie le fichier dans /root/.vnc mais attend de le trouver dans /home/root/.vnc.....

 

Je continue

 

image.png

Edited by gbs
Continue d'installer

Share this post


Link to post
Share on other sites
Le 16/02/2019 à 10:29, patdut a dit :

 

 

Nous testons aussi de nouvelles cartes autres que Tinker ou RPi beaucoup plus puissantes et équipées d'USB3. L'idée c'est d'étendre les capacités du système à la prise de vue planétaire, ce qui nécessite puissance et rapidité.

Bonjour,

 

Si ça peut aider, Phoronix teste régulièrement pas mal de hardware sous Linux. Récemment ils ont fait quelques benchmark sur des board ARM: https://www.phoronix.com/scan.php?page=article&item=nvidia-jetson-nano&num=4

 

En gros, rpi 3 < thinkerboard < odroid xu4 < Nvidia Jetson.

 

Après je ne connais pas les specs détaillées de chaque board ni le coût, on parle de $99 pour la Jetson nano.

Share this post


Link to post
Share on other sites

Oh oui je l'avais oubliée celle là, avec siril en CUDA ça enverrait bien du paté ! Bon ben je sais ce que j'ai à faire.

Share this post


Link to post
Share on other sites

L'avantage des jets on c'est qu'il existe un système Ubuntu préparer au petit oignon par NVIDIA ! Je pense que c'est ma prochaine acquisition !

Share this post


Link to post
Share on other sites
Posted (edited)
Il y a 7 heures, dragonlost a dit :

L'avantage des jets on c'est qu'il existe un système Ubuntu préparer au petit oignon par NVIDIA ! Je pense que c'est ma prochaine acquisition !

Oui mais les Jetson pas chères sont animés par un coeur ARM un peu léger. Et puis il y a la conso qui risque être handicapante. Les coeurs Cuda embarqués par contre sont super intéressants pour faire un petit serveur de traitement Siril.

Edited by patdut

Share this post


Link to post
Share on other sites
Il y a 14 heures, gbs a dit :

Salut à tous, à ceux qui sont debout comme à ceux qui sont vautrés dans leur transat en train de siroter du rouge....

 

Bon alors comme je ne peux plus pratiquer d'astro pour quelques mois, je me tourne vers la configuration histoire d'être bien prêt quand je pourrai de nouveau monter mon matos.

Plusieurs changements de mon côté.

1° Après avoir cramé une T7 mono (fait ch@*!) en voulant mettre à jour le firmware pour la faire tourner sous linux, j'ai déniché ici sur les PA une autre caméra. C'est une DFK23U445, j'ai fait quelques essais sous linux avec un PC portable (vieux icore3) ça passe avec le driver V4L donc bon espoir de faire tourner ça sur une micro machine.

Je l'ai testé sur ma NAFABox installée  sur un raspberry Pi3B+, pas très concluant, mais il y a eu des images. Après j'avais des images fixes aussi avec la T7...mais le guidage et les vidéo ne passaient pas.

 

2° Et donc j'ai arrété les tests sur le Pi3 car j'ai acquis sur la Baie pour 25€  une petite Nano Pi M4 avec 2Gb de mémoire seulement mais on va pas se plaindre hein...

Là je suis en train de faire l'install sur la M4. Je compléterais plus tard.
Pour l'instant, j'ai récupéré l'ARMBIAN correspondant et je l'ai mis sur la carte SD puis démarrage et première configuration en SSH pour lancer VNC et avoir accès à l'interface graphique puis récupération du script nafa sur le github et je suis les instruction du README_FR....

Le Pre_Install a bien fonctionné puis Install.sh, après avoir mis le mode graphique car via SSH ça passait pas, ça a lancé pas mal de chose.

Les menus ne sont pas identiques à ceux du site http://nafabox.linux-astro.fr/#scriptinstallation.

C'est normal ?

Là j'ai un joli bug.... le truc suivant tourne en boucle....

image.thumb.png.5e4ea8780e31f80098de78665fac3741.png

 

 

EDIT :

J'ai trouvé comment contourner le problème en faisant un lien symbolique

ln -s /root/.vnc /home/root/

 

Je ne sais pas pourquoi (et j'ai la flemme tout de suite de chercher) mais le script modifie le fichier dans /root/.vnc mais attend de le trouver dans /home/root/.vnc.....

 

Je continue

 

image.png

 

Hello.

Pour le site c'est normale. On a pas encore eu le temps de mettre a jour tout ça.

Il faudrait que je prenne du temps pour ça car c'est important.

 

Pour armbian tu as bien pris la version bionic ?

Au vue des capture que tu as fait je pense que tu as plutôt pris la version stretch qui n'est pas compatible avec les scripts NAFABOX (car les pakages debian sont trop vieux).

 

Pour le bug c'est du au scripts qui vérifie si le fichier de mots de passe est créé sinon il le relance (il considère que tu tes gouré de mot de passe).

Si tu as utilisé la version debian, je pense qu'elle doit pas installer par défaut le fichier de mots de passe au même endroit.

Share this post


Link to post
Share on other sites
Le 03/06/2019 à 11:53, gehelem a dit :

Les Nafaboys aux RAP

De gauche à droite @huguesmaillet et son fils, @patdut  @Argonothe

Et vautré dans la chaise bibi fricotin.

(et pour anticiper sur la question qui arrivera forcément : la caisse de pinard sous ma monture est arrivée sur place vide)

 

IMG_3679.JPG.ebc17183beba6eb3fcf336829dfed9c4.JPG

 

Un plaisir de vous rencontrer et de découvrir vos travaux lors des RAP 2019.

Je suis désormais abonné à ce fil afin de suivre l'avancée des travaux.

Viendra le jour où l'architecture du photoStrock V4 sera totalement fiabilisée et pourra alors être équipée d'une NAFA box...

J'adresse d'ici là mes plus sincères félicitations à tous les acteurs de ce projet!

 

Chrisotphe

 

  • Merci / Quelle qualité! 1

Share this post


Link to post
Share on other sites
Il y a 5 heures, dragonlost a dit :

 

Hello.

Pour le site c'est normale. On a pas encore eu le temps de mettre a jour tout ça.

Il faudrait que je prenne du temps pour ça car c'est important.

Ouf...je sais lire....

Il y a 5 heures, dragonlost a dit :

Pour armbian tu as bien pris la version bionic ?

Au vue des capture que tu as fait je pense que tu as plutôt pris la version stretch qui n'est pas compatible avec les scripts NAFABOX (car les pakages debian sont trop vieux).

J'ai mis ça : Armbian_5.75_Nanopim4_Ubuntu_bionic_default_4.4.174_desktop.img

Il y a 5 heures, dragonlost a dit :

Pour le bug c'est du au scripts qui vérifie si le fichier de mots de passe est créé sinon il le relance (il considère que tu tes gouré de mot de passe).

Si tu as utilisé la version debian, je pense qu'elle doit pas installer par défaut le fichier de mots de passe au même endroit.

Oui, je confirme, il se goure d'endroit, et un bête lien  atout remis en place. J'ai fait un lien car je ne sais pas si le "bon" compte est celui /root/ ou /home/root.

Share this post


Link to post
Share on other sites
Il y a 15 heures, patdut a dit :

Les coeurs Cuda embarqués par contre sont super intéressants pour faire un petit serveur de traitement Siril.

Bon en fait je connaissais la carte de base, la TX1, mais elle coûte encore trop cher (> 300). Et pour n'importe laquelle, il y a le problème du stockage qui est trop faible, comme pour les autres SBC.

 

Edit : ah en fait y'a du SATA sur la TX1 et la TX2 !

Share this post


Link to post
Share on other sites

Perso, je vais tester la M4 justement pour ça un peu plus de pêche pour le suivi de la cam de guidage.
Il y 4 ports USB3 (enfin faut que je regarde ce qu'il y a comme pont/HUB derrière, ça doit être partagé avec pas mal de trucs), du WIFI et Bluetooth en natif comme les Pi alosr que l'odroid nécessite un dongle, un proc du niveau des Odroid et 2Go de ram seulement pour mon nano M4, mais comme les XU4 et certaines M4 sont à 4Go de RAM, un poil plus cher à peine en neuf (je rappelle que c'esst une occaz que j'ai reçue).

L'environnement logiciel est plus réduit mais bon si j'arrive à finir l'install de la nafa, je vous dirais ce que ça donne de plus que le RPi3B+

Là mon réseau ADSL étant au top depuis que France Télécom a (pas) investi dedans, je suis en train de télécharger les fichiers, 1_Mo en 6 minutes...il en reste des minutes....

 

Il y a l'odroid M2 aussi qui doit être bien niveau perf/matos.

Share this post


Link to post
Share on other sites

Bon je me bats avec l'auto-login et le lancement du serveur VNC au boot.... et je ne trouve pas de doc très explicite. 
Je viens de demander dans armbian-config à avoir l'auto-login....mais ça ne passe pas. Il ne semble pas modifier les fichiers de conf (qui sont où d'ailleurs) mais seulement faire un apt pour installer ce qu'il faut....

Je continue mes essaies

Share this post


Link to post
Share on other sites
Le 04/06/2019 à 00:28, dragonlost a dit :

L'avantage des jets on c'est qu'il existe un système Ubuntu préparer au petit oignon par NVIDIA ! Je pense que c'est ma prochaine acquisition !

 

Il faut voir si ce sera toujours le cas dans 6 mois, Linux évolue vite et il y a des tas de boards ARM laissées à l'abandon par leurs constructeurs.

C'est la raison pour laquelle je reste sur des Raspberry Pi. Niveau hardware ce n'est pas le meilleur, mais niveau support et communauté c'est top.

Share this post


Link to post
Share on other sites
Il y a 2 heures, src386 a dit :

 

Il faut voir si ce sera toujours le cas dans 6 mois, Linux évolue vite et il y a des tas de boards ARM laissées à l'abandon par leurs constructeurs.

C'est la raison pour laquelle je reste sur des Raspberry Pi. Niveau hardware ce n'est pas le meilleur, mais niveau support et communauté c'est top.

Pour le coup ça fait 5 ans que les jetson existe et ça fait 5 ans que NVIDIA fournie une distribution a jour pour ses cartes.

Seule hic c'est qu'a moins d'avoir des compétences en accélération GPU les logiciel qui en profite sont très très rare en astro. Du coup je reste sur ma nanopi-m4 (voir nanopc-t4).

Share this post


Link to post
Share on other sites
Il y a 5 heures, gbs a dit :

Bon je me bats avec l'auto-login et le lancement du serveur VNC au boot.... et je ne trouve pas de doc très explicite. 
Je viens de demander dans armbian-config à avoir l'auto-login....mais ça ne passe pas. Il ne semble pas modifier les fichiers de conf (qui sont où d'ailleurs) mais seulement faire un apt pour installer ce qu'il faut....

Je continue mes essaies

 

Je comprends pas, l'autologin est déjà activer par défaut sur armbian.

Pour le démarrage auto de vnc, si tu as installé vnc via les scripts nafabox c'est bon aussi.

 

Share this post


Link to post
Share on other sites

Ben non justement... Un truc merde... Ou alors j'ai modifié sans le vouloir... 

Est-ce que tu sais dans quel fichier ça se trouve ? C'est lightdm le manager ? 

Share this post


Link to post
Share on other sites

Ah mince ta pas du sélectionner GDM mais lightdm lors de l'installation.

Vas falloir que je trouve une solution a ca.

Dans les scripts on installe lightdm (faut que je vois si c'est toujours nécessaire d'ailleurs), et quand c'est fait le packet te demande si tu veut aller sur lightdm ou GDM. Si tu choisie pas lightdm tu te retrouve sans log automatique.

Pour vnc. Si j'ai bien suivi tu l'as installer avant les scripts nafabox. Mais du coup, tu l'as réinstaller avec les scripts nafabox ?

Share this post


Link to post
Share on other sites

Tu peux me préciser un truc. Dans tes scripts NAFABOX, c'est gdm qui est utilisé ou lightdm ??

Share this post


Link to post
Share on other sites

Dans armbian c'est GDM qui est utilisé et c'est préférable de le garder. Mais en soit les scripts marche avec lightdm et GDM.

  • J'aime 1

Share this post


Link to post
Share on other sites

Salut, une petite question, que faut il faire ou installer pour avoir des bases locales d'astrometrie sur la Nafa ?

 

Même sous win10 ou Ubuntu je ne trouve rien de compréhensible pour moi.

 

Pareil pour apprivoiser Kstar, avez vous des liens qui commence à la base je prend. 

Les tutos que j'ai trouvé partent de points ou je ne suis pas encore arrivé ( Par exemple sur win10 et Ubuntu mes Kstar parlent toujours anglais bien que j'ai demandé français dans le setup) sur la Nafa c'est bien mieux traduit donc ça doit être possible. C'est des détails mais ça gonfle quand on n'arrive à rien. 

 

A+ Philippe

Share this post


Link to post
Share on other sites
Posted (edited)
il y a 59 minutes, Bandit 88 a dit :

Salut, une petite question, que faut il faire ou installer pour avoir des bases locales d'astrometrie sur la Nafa ?

 

Même sous win10 ou Ubuntu je ne trouve rien de compréhensible pour moi.

 

Pareil pour apprivoiser Kstar, avez vous des liens qui commence à la base je prend. 

Les tutos que j'ai trouvé partent de points ou je ne suis pas encore arrivé ( Par exemple sur win10 et Ubuntu mes Kstar parlent toujours anglais bien que j'ai demandé français dans le setup) sur la Nafa c'est bien mieux traduit donc ça doit être possible. C'est des détails mais ça gonfle quand on n'arrive à rien. 

 

A+ Philippe

Pour l'astrometrie quand tu installes la Nafa sur le bureau tu dois avoir une icone marquée "Index" tu lances et renseignes ce qu'il te demande (focale,etc...). Il installera automatiquement les index astrométriques nécessaires ( la nafa doit etre reliée à internet).

Pour Kstars voir sur youtube les vidéos de @gehelemet celles de Jasem Mutlaq

Edited by huguesmaillet

Share this post


Link to post
Share on other sites
il y a 52 minutes, huguesmaillet a dit :

Pour l'astrometrie quand tu installes la Nafa sur le bureau tu dois avoir une icone marquée "Index" tu lances et renseignes ce qu'il te demande (focale,etc...). Il installera automatiquement les index astrométriques nécessaires ( la nafa doit etre reliée à internet).

Pour Kstars voir sur youtube les vidéos de @gehelemet celles de Jasem Mutlaq

Merci Hugues je regarde pour les vidéos et la Nafa.

 

Cdt

 

Share this post


Link to post
Share on other sites

Bon alors j'ai essayé le script Install Index, de toute évidence j'ai un défaut dans la config. il manquerait de la place.

 

Il reste 22 giga sur la carte c'est insuffisant ?

 

A+

 

Erreur astro.jpg

Share this post


Link to post
Share on other sites

Avec une carte de 32Go, tu as largement la place.  C'est ce que j'ai et j'ai chargé les bases astrometries jusqu'à 8-11' et ça passe large 😉

Et le message que tu as là n'est pas une erreur mais juste un "warning"

Edit : j'ai pas lu le message de la console désolé 😅

Tony

Edited by TonyBANKS75

Share this post


Link to post
Share on other sites
Il y a 4 heures, Bandit 88 a dit :

Bon alors j'ai essayé le script Install Index, de toute évidence j'ai un défaut dans la config. il manquerait de la place.

 

Il reste 22 giga sur la carte c'est insuffisant ?

 

A+

 

Erreur astro.jpg

Après avoir gravé ton image, as tu été comme indiqué dans la doc étendre ta partition avec le programme GPARTED ?

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.