Jump to content
ch_porchet

Problème avec kstars et Focuser AEF

Recommended Posts

Bonjour

Je n'arrive pas a faire fonctionner ce Focuser avec kstars. 

J'ai chaque fois une erreur, mais j'avoue que je comprend pas bien se qu'il faut faire ou qu'est ce que je dois configuré pour qu'il fonctionne. 

Alors si qqun l'utilise avec kstars....... 

Merci

Share this post


Link to post
Share on other sites

Quel pilote indi as-tu utiliser dans ton profil Ekos ?

Share this post


Link to post
Share on other sites

Heuuu, je suis même pas sur d'avoir installé un driver 🙄

Mais pourtant kstars le reconnais... 

Share this post


Link to post
Share on other sites

Dans le module Ekos de Kstars (icone dôme) tu commences par créer un profil matériel : monture, imageur, guideur, focuseur, etc avec un pilote indi pour chacun. 

Si le pilote de ton focuseur n'existe pas explicitement dans la longue liste, il est peut être compatible avec un autre. A tester.

Share this post


Link to post
Share on other sites

Hello

Alors sa c'est OK.

Car j'ai l'onglet Focuser qui apparaît. 

Mais que faut il faire ou configurer dedans, car quand j'essaie de faire la mise au point, il me met une erreur. 

Je ne demande si c'est pas la combine du pas qui est faut. 

Share this post


Link to post
Share on other sites
Posted (edited)

Comme je n'ai pas encore de focuser je ne peux pas te répondre.

Commences par créer un profil Simulation avec les pilotes Indi de simulation, pour la monture, la caméra et le focuseur pour faire tes tests.  Il faut aussi avoir installe le ciel virtuel gsc ( sudo apt install gsc).

 

Edited by rmor51

Share this post


Link to post
Share on other sites
Posted (edited)
Le 03/01/2020 à 10:21, ch_porchet a dit :

Hello

Alors sa c'est OK.

Car j'ai l'onglet Focuser qui apparaît. 

Mais que faut il faire ou configurer dedans, car quand j'essaie de faire la mise au point, il me met une erreur. 

Je ne demande si c'est pas la combine du pas qui est faut. 

 

toujours des difficultés je vois Ch_porchet... Alors sous Ekos dans l'onglet focuser, mettre ZWO EAF le driver fait parti des drivers indi depuis quelques temps... rassure moi tu as rentré tes autres matériels dans les onglet monture, camera et autre ??? Penser aussi à renseigner les focales de tes instruments (guidage et principal). Sinon en se donnant les moyens de chercher un peu il y a une doc pour Ekos et Kstars ainsi que des tutos vidéo à la pelle ( notamment celles de @gehelem

Et celles de Jasem Mutlaq)

Edited by huguesmaillet

Share this post


Link to post
Share on other sites

Hello Huges

Alors j'ai tous qui est rentré correctement , capteur, focale et tous fonctionne nickel, sauf le EAF .

Mais il faut rentré, visiblement le nombre de pas du EAF , ou alors encore autre chose, c'est je pense, la le problème ?

 

Sinon qu'est-ce qui me pose problème ..... A7S , mais pas tous le temps ,cela me semble instable ,car maintenant je peux plus faire de séquence de prise de vue, elle passe pas le première prise et 

après cela tourne en boucle pour prendre la première photos.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Pour le focuser il y a effectivement aussi le.nombre de pas maximum pour que ton focuser soit sorti et rentré entièrement (prends une marge d erreur d au moins 1000 pas pour le.tout sorti et 500 pour le tout rentré ( c est en tout cas ce que j'ai mis : ton focuser est à crémaillère ???). Moi j ai rentré les paramètres la première fois avec le programme Windows et ils sont importés ensuite dans indi driver me semble t il....

ZWO_ASCOM_driver.png

Edited by huguesmaillet

Share this post


Link to post
Share on other sites

Ok je vais voir ça se soir.

 

Par contre mon PC dans mon poste fixe et que sous linux, mais je vais essayer de le démonter et faire des essaies pour voir  si je peux commander qqch depuis kstars.

Share this post


Link to post
Share on other sites

Hello

Alors j'arrive en simulation à le faire fonctionner, MAIS, il faut que chaque fois j'aie changer qqch dans le panneau de contrôle indi , je dois activé dans "contrôle principal" 

la fonction ou c'est marqué "interrompre" le 3ième avant la fin.

Alors pourquoi......... , et  en plus,  je dois chaque fois le faire manuellement, car se choix ne reste pas en mémoire ......

Share this post


Link to post
Share on other sites
Posted (edited)
Il y a 12 heures, ch_porchet a dit :

Hello

Alors j'arrive en simulation à le faire fonctionner, MAIS, il faut que chaque fois j'aie changer qqch dans le panneau de contrôle indi , je dois activé dans "contrôle principal" 

la fonction ou c'est marqué "interrompre" le 3ième avant la fin.

Alors pourquoi......... , et  en plus,  je dois chaque fois le faire manuellement, car se choix ne reste pas en mémoire ......

je ne comprends pas trop, pourquoi passer par les simulateurs alors que tu cherches à faire marcher l'EAF ? il faut dans le panneau de controle indi choisir ZWO EAF dans la case focuser et ensuite lui rentrer tes parametres pour ton focuser (min et max et backlash si tu veux). ensuite tu sauvegarde tes parametres

Pour le problème de mémoire il faut sauvegarder dans le menu Option (par contre je ne sais pas si ca à une action avec le simulateur)

Edited by huguesmaillet

Share this post


Link to post
Share on other sites

hello

je l'ai démonter de mon N250 et pris le pc du poste fixe au chaud pour comprendre ,car hier soir trop froid dehors.

Mais maintenant  je vais faire le teste tous en place pour voir.

A+

Share this post


Link to post
Share on other sites

Je l'ai régler récement le EAF sous KSTAR/EKOS.

 

Pas de problème particulier.

 

1- J'ai fait bouger en position "0 pas" avant de le monter, en regardant le sens de rotation (tu as un bouton pour inverser le sens de rotation).

2- J'ai mesuré la course de mon PO en prenant une marge de 5 mm en butée haute et basse (75 mm de course + 2 marge sur les butées de 5mm).

3- J'ai fixé le EAF sur le PO rétracté (avec la marge de 5 mm, donc PO sorti de 5mm)

4- J'ai bougé le PO de 1000 pas, je mesure la valeur de déplacement

5- Un rapide calcul savant de produit en croix me donne 20000 pas pour la course de mon PO (75mm), que j'informe dans le panel Indi du ZWO EAF (je ne sais plus le nom de la case correspondante, je te dis cela ce soir) 

 

Tout fonctionne nickel.

Share this post


Link to post
Share on other sites
Posted (edited)
Il y a 7 heures, supaii a dit :

Je l'ai régler récement le EAF sous KSTAR/EKOS.

 

Pas de problème particulier.

 

1- J'ai fait bouger en position "0 pas" avant de le monter, en regardant le sens de rotation (tu as un bouton pour inverser le sens de rotation).

2- J'ai mesuré la course de mon PO en prenant une marge de 5 mm en butée haute et basse (75 mm de course + 2 marge sur les butées de 5mm).

3- J'ai fixé le EAF sur le PO rétracté (avec la marge de 5 mm, donc PO sorti de 5mm)

4- J'ai bougé le PO de 1000 pas, je mesure la valeur de déplacement

5- Un rapide calcul savant de produit en croix me donne 20000 pas pour la course de mon PO (75mm), que j'informe dans le panel Indi du ZWO EAF (je ne sais plus le nom de la case correspondante, je te dis cela ce soir) 

 

Tout fonctionne nickel.

C’est expliqué plus clairement que moi avec mes pas de sécurité, mais c'est la même démarche que j'ai effectuée. Merci @supaii des précisions 😉

Pour info tu as évalué le backlash de l'EAF ? Si oui tu trouves combien de pas de jeux ???

Edited by huguesmaillet

Share this post


Link to post
Share on other sites

@huguesmaillet , oui j'ai déterminer un backlash avec mon pied a coulisse à vernier. 50 pas

 

Je referai la mesure avec un comparateur, plus précis....

Share this post


Link to post
Share on other sites
il y a 37 minutes, supaii a dit :

@huguesmaillet , oui j'ai déterminer un backlash avec mon pied a coulisse à vernier. 50 pas

 

Je referai la mesure avec un comparateur, plus précis....

Pour ton focus tu as une belle courbe en V ???

Share this post


Link to post
Share on other sites
Posted (edited)

Bon ,bien j ' y arrive pas !

 

ASIEAF.png

 

Alors 1ère chose ; j'ai ses 2erreurs

2ième chose ; pourquoi les données ne reste pas en mémoire , en effet j'ai donnée le nombre de pas maxi (157550) ,et dans option j'ai mis sauvegarder,

                       mais rien à faire ,quand je sort de kstars et que je relance mon essaie les donnée on disparu 

2ième chose : pourquoi rien ne fonctionne temps que j'appuie pas sur le bouton "interrompre".

 

Donc qui a une idée

 

Edited by ch_porchet

Share this post


Link to post
Share on other sites

Je ne connais pas du tout l'EAF mais je viens de jeter un coup d'oeil au code source.

L'erreur 5 ça veux dire: EAF_ERROR_MOVING,//focuser is moving

 

Le driver croit que le focuser est en cours de déplacement et c'est pour ça qu'il refuse de modifier reverse et max position.

C'est aussi pour ça que ça va mieux après Interrompre car il doit faire un reset de "focuser is moving"

Share this post


Link to post
Share on other sites

OK, merci, mais du coup, comment je fais ? 

Est-ce une erreur logiciel ou alors de mauvaise configuration ? 

Share this post


Link to post
Share on other sites

Commence par contrôler la version d'INDI que tu utilise. Dans un terminal entre indiserver sans paramètre ça va afficher la version. La dernière est 1.8.3.

 

Ensuite pour revenir aux valeurs par défaut du driver, ferme kstar et indiserver, va dans le répertoire ~/.indi  il doit y avoir deux fichiers "ASI EAF_config.xml" et "ASI EAF_config.xml.default" ou quelque chose de similaire. Efface les.

 

Pour tester le fonctionnement de base ouvre le "Panneau de contrôle INDI", a l'onglet du focuser clic Connecter, attend que les autres contrôles apparaissent.

Entre 100 dans le champ "Position absolue" et clic Définir.  Est-ce que le moteur bouge? est-ce que le champ de gauche passe à 100?

 

Share this post


Link to post
Share on other sites

@ch_porchet

c'est bizarre, j'ai pas le même panel que toi, es tu à jour?

j'ai la gestion du jeu ("rebond") en plus...

Share this post


Link to post
Share on other sites
Il y a 3 heures, pch a dit :

Dans un terminal entre indiserver sans paramètre ça va afficher la version. La dernière est 1.8.3.

 

 

Alors en effet ,j'ai pas la dernière ,j'ai celle la 1.7.9

je vais la mettre à jours pour voir.

 

Edited by ch_porchet

Share this post


Link to post
Share on other sites

Alors en effet ça l'air de fonctionner et, en effet, j'ai plus le même panel .

 

Merci les gars !!!!

je remarque quand même, que je reste une pive en informatique et que chaque fois c'est pour des petites combine !

Et le pire c'est que je vais me lancer dans l'ouverture du toit à distance de mon observatoire(enfin cabanon) un de ses jours, sa promet ;)

 

Edited by ch_porchet

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.