Jump to content

[RES] Problème de connexion avec RPI4


Recommended Posts

Autre souci. Avec mon RPI4, la connexion s'établit si un écran est connecté à ce dernier. Sinon, pas moyen, comme si l'adresse IP avait changé. J'ai pourtant fixé cette IP dans le fichier /etc/network/interfaces .

Une idée ?

 

Au fait comment fixer une adresse IP sur un RPI4 en liaison lien local uniquement SVP ? Dans le fichier interfaces ou autre ?

Edited by rmor51
Link to post
Share on other sites

Ca empire. J'ai configuré le RPI4 en hotspot et je me suis connecté depuis mon PC, un écran étant connecté au RPI4 pour le configurer.

Je reboote en retirant l'écran, je me connecte au hotspot, mais vncviewer ne trouve rien. Comme si encore une fois l'adresse avait changé. Pourtant en faisant un ping sur l'adresse, ça répond !

J'y perd mon latin !

Link to post
Share on other sites

Sur le RPI l’écran ne marche pas comme un ordi classique. si il ne détecte pas d’écran il ne vas faire n'importe quoi sur la résolution.

Il faut que tu paramètre ça dans le config.txt pour forcer une resolution ( voir tuto dans le github nafabox).

 

Si ton RPI fait le hotspot il ne peut pas changer d'adresse il aura obligatoirement l'adresse : xxx.xxx.xxx.1

Qu'appelle tu le lien local ?

Link to post
Share on other sites
profile_mask2.png

Robert M. <robert51master@gmail.com>

25 févr. 2021 15:01 (il y a 19 heures)
   

Le problème est le suivant. J'utilisais une TinkerBoard Asus + Nafabox pour le remote avec mon setup astro et ça fonctionnait et fonctionne toujours très bien. La liaison entre les deux se fait par un câble Ethernet en mode point à point (lien local uniquement dans l'onglet IPv4).

 
J'ai acquis un RPI4 pour remplacer la TB et profiter des ports USB. Impossible de faire la même chose qu'avec la TB, toujours avec Nafabox. Je m'explique.
 
Dans un premier temps, je branche un petit écran 1200*600 sur le RPI4 pour pouvoir le configurer en réseau  point à point  et liaison avec un câble Ethernet, comme avec la TB.
Je récupère l'adresse IP et je la mets en statique dans /etc/network/interfaces.Avec l'écran branché, ça fonctionne. J'éteins le RPI4, je retire le petit écran et là pas moyen de se connecter.
 
Pas grave je me dis, je vais essayé avec un hospot. Et bien le résultat est identique. Avec l'écran ça se connecte mais pas sans l'écran.
 
J'utilise vncviewer sur le PC pour me connecter.
 
Un membre du club trapu en OS linux, m'a dit que sans écran, le serveur X n'est pas lancé et que donc l'environnement est différent. Ce qu'il a fait, c'est d'exécuter un script qui lance un serveur X pour retrouver le même environnement et établir la liaison avec vnc.
 
 
 
Link to post
Share on other sites
Il y a 2 heures, rmor51 a dit :
profile_mask2.png

Robert M. <robert51master@gmail.com>

25 févr. 2021 15:01 (il y a 19 heures)
   

Le problème est le suivant. J'utilisais une TinkerBoard Asus + Nafabox pour le remote avec mon setup astro et ça fonctionnait et fonctionne toujours très bien. La liaison entre les deux se fait par un câble Ethernet en mode point à point (lien local uniquement dans l'onglet IPv4).

 
J'ai acquis un RPI4 pour remplacer la TB et profiter des ports USB. Impossible de faire la même chose qu'avec la TB, toujours avec Nafabox. Je m'explique.
 
Dans un premier temps, je branche un petit écran 1200*600 sur le RPI4 pour pouvoir le configurer en réseau  point à point  et liaison avec un câble Ethernet, comme avec la TB.
Je récupère l'adresse IP et je la mets en statique dans /etc/network/interfaces.Avec l'écran branché, ça fonctionne. J'éteins le RPI4, je retire le petit écran et là pas moyen de se connecter.
 
Pas grave je me dis, je vais essayé avec un hospot. Et bien le résultat est identique. Avec l'écran ça se connecte mais pas sans l'écran.
 
J'utilise vncviewer sur le PC pour me connecter.
 
Un membre du club trapu en OS linux, m'a dit que sans écran, le serveur X n'est pas lancé et que donc l'environnement est différent. Ce qu'il a fait, c'est d'exécuter un script qui lance un serveur X pour retrouver le même environnement et établir la liaison avec vnc.
 
2 heures plus tard. J'avais créé une sdcard avec une Ubuntu 20.04, puis passé les scripts Nafabox. Je viens de la tester. Aucun problème avec ce système. Connexion OK avec ou sans écran.
 
 
 

 

Link to post
Share on other sites

J'ai galéré comme toi pour utiliser le rpi4 avec un vnc viewer.

Je ne suis pas avec la nafabox

Je lance en ssh la connection...

Ensuite dans la commande je lance tightvncserver et j'ai une adresse xxx.xxx.xx :1

je colle cette adresse dans n'importe quel vnc .. Remina sur linux, bureau a distance sur pc et ça marche

Link to post
Share on other sites

J'ai refait une install from scratch à partir d'une Ubuntu Server 18.04 puis applications des scripts Nafabox. 

J'ai 2 soucis:

1- le login n'est pas automatique, bien qu'ayant modifié comme il se doit le fichier /etc/gdm3/custom.conf. Donc ça doit se passer ailleurs. En outre je n'ai pas d'entrée Groupes & Utilisateurs dans le centre de contrôle.

2- Souci avec les connexions filaires, qui existent bien dans le gestionnaire de connexion, mais qui n'apparaissent pas dans la liste de l'icône réseau de la barre de menu.

Et comme je voudrais plutôt passer par une liaison câble Ethernet, ça me manque.

Pour l'instant en hotspot ça fonctionne mais pas parfaitement.

 

Si vous avez des idées, elles sont les bienvenues.

 

Il y a 23 heures, astrojf a dit :

J'ai galéré comme toi pour utiliser le rpi4 avec un vnc viewer

Remplacé par Nomachine qui fonctionne très bien.

Link to post
Share on other sites

Je viens de passer les deux dernières soirées à tester mon setup en remote: Tout baigne !

1) les soucis de gestion des 2 caméras QHY, résolus grâce aux ports USB3 sûrement.

2) Connexion par câble Ethernet OK, sans aucune déconnexion, avec Nomachine.

3) la résolution écran qui va bien pour mon portable en 1360x768 est 1400x900.

 

Donc retour très positif.

 

Juste une question: comment peut-on améliorer les performances du RPI4 SVP?

 

14h environ de session sans souci avec la Nafabox. Je vais tester la connexion wifi, mais je suis de ceux qui estime que rien ne vaut un bon câble !

Merci à toute l'équipe de développement pour son immense travail, sa réactivité.

 

PS: un souci quand. J'ai un focuseur (fonctionne avec MyFocuserPro) qui se connecte en Bluetooth et qui utilise le même port que le GPS, a savoir ttyACM0.  Comment traiter ce problème ?

Link to post
Share on other sites

Bonjour Robert,

 

Concernant ton problème de périphérique ttyACM0:

 

Lorsque l'on branche plusieurs périphériques USB (qui créent un lien série pour discuter), ou encore Bluetooth (qui créent aussi un lien série) on se retrouve avec plusieurs périphériques /dev/ttyACMx (x=0, 1, 2...) et bien sûr le numéro dépend de l'ordre de connexion du périphérique ou de l'ordre de sa détection, donc souvent aléatoire entre 2 soirées...

 

Mais il y a une solution (ouf), c'est de faire créer automatiquement par l'OS des nom de périphériques ayant des noms FIXES et CHOISIS, et ce sont ces noms que l'on paramètre dans les drivers INDI de EKOS au lieu de /dev/tty/ACM0

 

Exemple,, j'ai un raspberry où est connecté un dongle USB Zwave et un Arduino. L'OS les détectes dans un certain ordre, les nomme ttyACM0 et ttyACM1, mais il crée aussi 2 périphériques nommés selon mon choix ttyACM_ZW (pour le wave) et ttyACM_AU (pour l'arduino)

i@mls-rdz ~ $ ls -l /dev/ttyA*

crw-rw---- 1 root dialout 166,  0 déc.  21 20:17 /dev/ttyACM0

crw-rw---- 1 root dialout 166,  1 mars   2 20:26 /dev/ttyACM1

lrwxrwxrwx 1 root root          7 déc.  21 20:17 /dev/ttyACM_AU -> ttyACM0

lrwxrwxrwx 1 root root          7 déc.  21 20:17 /dev/ttyACM_ZW -> ttyACM1

crw-rw---- 1 root dialout 204, 64 déc.  21 20:17 /dev/ttyAMA0

 

Pour cela on va utiliser le mécanisme "udev"

1) il faut que tu sois connecté sur ton RPI pour passer des lignes de commande (connexion SSH, ou via interface graphique et lancer une session "terminal")

 

2) il faut passer root --> sudo su -

 

3) il faut vérifier que le package "udev" est installé--> apt info udev

root@mls-rdz:~# apt list udev

En train de lister... Fait

udev/stable,now 241-7~deb10u5+rpi1 armhf  [installé]

 

3b) Si pas installé, l'installer

 apt-get install udev

 

4) On va creer un fichier nommé "99-perso.conf" dans le répertoire "/etc/udev/rules.d"

  qui va contenir une ligne par périphérique, du style:   

SUBSYSTEM=="tty", ATTRS{idVendor}=="0658", ATTRS{idProduct}=="0200", SYMLINK+="ttyACM_ZW", MODE="0666"

SUBSYSTEM=="tty", ATTRS{idVendor}=="2341", ATTRS{idProduct}=="0001", SYMLINK+="ttyACM_AU", MODE="0666"

  Les noms dans le paramètre "SYMLINK" tu pourras mettre ce que tu veux pour les distinguer

  Les valeurs  des paramètres ATTRS{idVendor} et  ATTRS{idProduct} il va falloir les déterminer pour chacun de tes périphériques.

 

5) Pour obtenir les IDs vendre et product, connecter ton premier périphérique, et une fois que /dev/ttyACM0 est créé on l'interroge avec la commande --> udevadm info --query all --name /dev/ttyACM0

Exemple chez moi (en gras les lignes où il y a les infos pertinentes):

 

root@mls-rdz:/etc/udev/rules.d# udevadm info --query all --name /dev/ttyACM0

P: /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/tty/ttyACM0

N: ttyACM0

L: 0

S: serial/by-path/platform-3f980000.usb-usb-0:1.3:1.0

S: ttyACM_AU

S: serial/by-id/usb-Arduino__www.arduino.cc__Arduino_Uno_7563331333335121E161-if00

E: DEVPATH=/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/tty/ttyACM0

E: DEVNAME=/dev/ttyACM0

E: MAJOR=166

E: MINOR=0

E: SUBSYSTEM=tty

E: USEC_INITIALIZED=11312014

E: ID_VENDOR=Arduino__www.arduino.cc_

E: ID_VENDOR_ENC=Arduino\x20\x28www.arduino.cc\x29

E: ID_VENDOR_ID=2341

E: ID_MODEL=Arduino_Uno

E: ID_MODEL_ENC=Arduino\x20Uno

E: ID_MODEL_ID=0001

E: ID_REVISION=0001

E: ID_SERIAL=Arduino__www.arduino.cc__Arduino_Uno_7563331333335121E161

E: ID_SERIAL_SHORT=7563331333335121E161

E: ID_TYPE=generic

E: ID_BUS=usb

E: ID_USB_INTERFACES=:020201:0a0000:

E: ID_USB_INTERFACE_NUM=00

E: ID_USB_DRIVER=cdc_acm

E: ID_USB_CLASS_FROM_DATABASE=Communications

E: ID_VENDOR_FROM_DATABASE=Arduino SA

E: ID_MODEL_FROM_DATABASE=Uno (CDC ACM)

E: ID_PATH=platform-3f980000.usb-usb-0:1.3:1.0

E: ID_PATH_TAG=platform-3f980000_usb-usb-0_1_3_1_0

E: DEVLINKS=/dev/serial/by-path/platform-3f980000.usb-usb-0:1.3:1.0 /dev/ttyACM_AU /dev/serial/by-id/usb-Arduino__www.arduino.cc__Arduino_Uno_7563331333335121E161-if00

E: TAGS=:systemd:

 

oot@mls-rdz:/etc/udev/rules.d# udevadm info --query all --name /dev/ttyACM1

P: /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/tty/ttyACM1

N: ttyACM1

L: 0

S: serial/by-id/usb-0658_0200-if00

S: serial/by-path/platform-3f980000.usb-usb-0:1.4:1.0

S: ttyACM_ZW

E: DEVPATH=/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/tty/ttyACM1

E: DEVNAME=/dev/ttyACM1

E: MAJOR=166

E: MINOR=1

E: SUBSYSTEM=tty

E: USEC_INITIALIZED=11316015

E: ID_VENDOR=0658

E: ID_VENDOR_ENC=0658

E: ID_VENDOR_ID=0658

E: ID_MODEL=0200

E: ID_MODEL_ENC=0200

E: ID_MODEL_ID=0200

E: ID_REVISION=0000

E: ID_SERIAL=0658_0200

E: ID_TYPE=generic

E: ID_BUS=usb

E: ID_USB_INTERFACES=:020201:0a0000:

E: ID_USB_INTERFACE_NUM=00

E: ID_USB_DRIVER=cdc_acm

E: ID_USB_CLASS_FROM_DATABASE=Communications

E: ID_VENDOR_FROM_DATABASE=Sigma Designs, Inc.

E: ID_MODEL_FROM_DATABASE=Aeotec Z-Stick Gen5 (ZW090) - UZB

E: ID_PATH=platform-3f980000.usb-usb-0:1.4:1.0

E: ID_PATH_TAG=platform-3f980000_usb-usb-0_1_4_1_0

E: DEVLINKS=/dev/serial/by-id/usb-0658_0200-if00 /dev/serial/by-path/platform-3f980000.usb-usb-0:1.4:1.0 /dev/ttyACM_ZW

E: TAGS=:systemd:

 

 6) Une fois que tu as créé le fichier au bon endroit, avec le bon contenu pour décrire tes périphériques, tu les déconnecte et tu lance les commandes suivantes pour que UDEV prenne en compte ton paramétrage:

      udevadm control --reload

note: si message d'erreur pour option ne reconnue, essayer avec

       udevadm control --reload-rules

Ensuitelancer la commande:

       udevadm trigger

Il ne reste plus qu'a reconnecter tes 2 périphériques et vérifier dans /dev si cela créé les périphériques voulus

note; avant de connecter tes périphérique tu peux lancer un "udevadm monitor" qui listera tous les événements futurs du driver udev 

 

Cordialement, Stéphane

Link to post
Share on other sites

Merci tout d'abord pour ta solution bien détaillée.  Mais l'informatique c'est parfois ... curieux.

J'ai récupéré le focuseur, le gps et le RPI4 pour tester tranquillement tout ça dans mon bureau atelier.

Je branche le tout et ... les 2 fonctionnent !! Reste plus qu'à retester sur le setup.

Link to post
Share on other sites
Posted (edited)

Vraiment très curieux l'informatique. Après mes tests positifs au bureau, j'ai remis le tout sur mon setup et patatras ça ne fonctionne pas. Donc je vais me rabattre sur la solution des règles UDEV.

CE que je trouve quand même curieux c'est que seul ACM0 est créé. Pas de ACM1 !

 

Je réfléchis. Le focuseur en Bluetooth se connecte sur RFCOMM0 ou 1 et le GPS sur ACM0 . Donc c'est sans doute la monture qui est connecté par la raquette  avec une liaison série qui provoque le conflit. Autre souci. Comment obtenir les infos vendor et model pour le focuseur ? La commande sur rfcomm0 ne les donne pas.

Edited by rmor51
Link to post
Share on other sites

J'ai fini par trouver une solution simple grâce à Kstars. Dans les paramètres Indi des matériels on peut pour certain, choisir le port de connexion. Maintenant j'ai le GPS sur ttyACM0 (par défaut fixé dans gpsd),  la monture sur ttyUSB0 et le focuseur sur rfcomm0. Et tout baigne. Merci pour votre contribution.

Link to post
Share on other sites
  • rmor51 changed the title to [RES] Problème de connexion avec RPI4

Content que le problème soit résolu.

 

Pour ce qui est du "udev" les infos que j'ai données servent à choisir le nom des périphériques créés pour éviter la confusion et le nomage aléatoire en fonction de l'ordre de détection, mais il faut effectivement, une fois le nom choisi aller le "coder" dans indi pour que le driver ouvre le bon périphérique.

 

Toutefois pour info, les périphériques rfcomm en bluetooth c'est different (pas plus simple ni plus compliqué, juste différent), voici quelques commandes utiles

 

1) vérifier si la commande "bluetoothctl" est installée, si ce n'est pas le cas installer le package "bluez" --> 

apt-get install bluez

 

2) lancer l'outil de gestion bluetooth --> 

sudo bluetoothctl

  dans la session de commande bluetooth on peut:

    detecter les périphériques via la commande "scan on"

    lister les périphériques via "devices"

    appairer un périphérique via "pair aa:bb:cc:dd:ee:ff" et "trust aa:b:cc:dd:ee:ff" avec aa:b:cc:dd:ee:ff l'adresse mac du périphérique voulu

   quitter l'utilitaire avec "quit"

 

  On peut aussi scanner les devices avec la commande suivante

sudo hcitool scan

 

3) une fois l'appairage bluetooth OK, on peut lier le périphérique à un device rfcomm avec la commande suivante:  

   

sudo rfcomm bind /dev/rfcomm0 aa:bb:cc:dd:ee:ff 1

 

La gestion des périphériques, c'est que du bonheur...

Link to post
Share on other sites
Il y a 11 heures, keymlinux a dit :

 

La gestion des périphériques, c'est que du bonheur...

Sauf que l'appairage s'effectuait sans problème avec les outils standards Bluetooth en 18.04.

Ce n'est plus le cas en 20.04, où il faut taper la commande bind. Mais même avec cela, l'appairage se fait mais le connexion échoue.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.