Jump to content
Zelytra

Probleme Resolution NoMachine

Recommended Posts

Salut a tous !

J'ai récemment à réussir à faire fonctionner mon NoMachine mais je rencontre un problème de résolution lorsque je lance la Raspberry Pi B3+ sans connexion à un écran... 

J'ai essayer de suivre ces étapes https://github.com/Patrick-81/NAFABox/blob/master/ConfigTinker/Resolution_rpi.md

Mais quand je sélectionne une résolution en hdmi_groupe=1 ou 2 il me met en résolution de environs 680x460 et je n'arrive pas à remédier ce problème.

 

Ce que j'aimerais faire c'est que qu'en ma Pi boot il prend une résolution par défaut de 1920x1080 ou autre pas loin de celle ci mais je n'y arrive pas  

Share this post


Link to post
Share on other sites

Bonjour, peut tu afficher le contenu du fichier" /boot/config.txt", par forcément en entier mais toutes les lignes qui concerne l'écran, histoire de faire une comparaison avec mon PI.

Autre renseignement, tu est sous quel os, et tu utilise quel logiciel pour te connecter au PI ?

Yves.

 

Share this post


Link to post
Share on other sites
Il y a 2 heures, Alarcon yves a dit :

Bonjour, peut tu afficher le contenu du fichier" /boot/config.txt", par forcément en entier mais toutes les lignes qui concerne l'écran, histoire de faire une comparaison avec mon PI.

Autre renseignement, tu est sous quel os, et tu utilise quel logiciel pour te connecter au PI ?

Yves.

 

Je suis sous Linux du coté de l'host et Windows du coté du controle

 

Et voici l'image du doc config (j'ai pris la partie que j'ai modifié par rapport au tuto20190430_201739.thumb.jpg.06c2cfba20ae13adde70e47213bbfedd.jpg

Share this post


Link to post
Share on other sites

Salut,

Ça marchera peut-être mieux en dé-commentant les lignes non ? 😁

Bon ciel !

Share this post


Link to post
Share on other sites

Oui, comme Floriant06, si tu enlève le "#" en débuts des lignes qui t'intéresses, ça vas surement mieux fonctionner.

Yves.

Share this post


Link to post
Share on other sites
il y a 15 minutes, Alarcon yves a dit :

Oui, comme Floriant06, si tu enlève le "#" en débuts des lignes qui t'intéresses, ça vas surement mieux fonctionner.

Yves.

Alors effectivement ça pourrait aider (mais sa ne marche toujours pas) je ne connaissait pas ce langage et surtout tous le document comporte des "#" ce que je ne comprenait pas non plus...

 

Mais du coups ça ne corrige pas mon problème

Share this post


Link to post
Share on other sites

Tu redémarre bien le pi sans la prise hdmi de branché, aprés avoir modifié le fichier ?

Yves.

 

Share this post


Link to post
Share on other sites
il y a 1 minute, Alarcon yves a dit :

Tu redémarre bien le pi sans la prise hdmi de branché, aprés avoir modifié le fichier ?

Yves.

 

Oui

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour, alors j'ai regardé sur mon pi3b+, effectivement le fichier config.txt, ne sert pas à grand chose chez moi, car j'utilise sur le pi le logiciel xtightvnc pour le contrôle à distance et celui-cii règle la configuration de l'écran directement quand le serveur se lance.

Xtightvnc :1 -desktop X -auth /home/pi/.Xauthority -geometry 1280x800 -depth 24 -rfbwait 120000 -rfbauth /home/pi/.vnc/passwd -rfbport 5901 -fp /usr/share/fonts/X11/misc/,/usr/share/fonts/X11/Type1/,/usr/share/fonts/X11/75dpi/,/usr/share/fonts/X11/100dpi/ -co /etc/X11/rgb

Dans mon cas le pi fonctionne en 1280x800

Maintenant je ne sais pas qu'elle serveur vous utilisez, mais aller plutôt voir du coté de sa configuration, si c'est vnc, faire la commande "sudo raspi-config" qui permet de paramétrer le serveur vnc.

Yves.

Edited by Alarcon yves

Share this post


Link to post
Share on other sites

J'utilise Nomachine pour me connecter à ma Pi mais même en réglant la résolution manuellement sur le logiciel ça ne force pas la résolution. Vaut mieux que je passe sous VNC ?  mais je ne trouve pas comment faire (je ne comprend pas le système de connexion en VNC quelle logiciel utilisé etc...)

Share this post


Link to post
Share on other sites

non non reste sur nomachine, en cherchant un peux j'ai trouvé cette page https://www.nomachine.com/fr/conseils-pour-la-configuration-de-votre-raspberry-pi-pour-accès-à-distance-via-nomachine

Qui précise bien que nomachine utilise le fichier /boot/config.txt

Alors pour nomachine il faut bien configurer le fichier /boot/config.txt comme suit

hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=32

 

redémarre et normalement tu devrait être en 1280x900 , si ça ne fonctionne pas, essai avec les valeurs suivantes pour test

hdmi_group=1
hdmi_mode=31

 

Yves

 

Share this post


Link to post
Share on other sites
Posted (edited)

Je viens d'essayer les deux options (en redémarrant bien sur) nada ça ne change rien

 

La résolution reste bloqué à 720x480)

Edited by Zelytra

Share this post


Link to post
Share on other sites

Bon après moultes recherches je n'ai pas trouver de solutions je vais donc passer sous VNC (même si je ne trouve pas de tuto pour apprendre a faire). Merci quand même pour l'aide

Share this post


Link to post
Share on other sites

Ok ! Du-coups après avoir retiré les lignes de code dans le fichier .configue qui essayait de forcer la taille de l'écran au démarage (mais qui ne marchait pas), j'ai enfin trouver la solutions.

J'ai donc acheter le "simulateur d’écran" et après la manip ça marche très bien !

 

Merci pour votre aide !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.