Jump to content
astrototho

A L'AIDE UTILISATEURS Mac !

Recommended Posts

Posted (edited)

Bonjour, 

Pour la première fois je fais plus de 250 image (345 exactement) et mon logiciel de pretraitement SIRIL ne fonctionne pas car MAC OS fixe une limite du nombre de fichiers ouverts en même temps. 

Savez vous comment remédier à ce problème ? 

Comment puis je modifier cette limite ? 

 

Merci d'avance pour votre réponse, 

Astrototoho

PS Il me semble que la limite est fixée à 256 fichiers

Edited by astrototho

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour,

je ne connais pas Siril, mais peut-etre peux tu faire deux images distinctes (avec la moitié des lights), et les additionner ensuite?

Edited by kjeanpaul

Share this post


Link to post
Share on other sites
il y a 1 minute, kjeanpaul a dit :

Bonjour,

je ne connais pas Siril, mais peut-etre peux tu faire deux images distinctes (avec la moitié des lights), et les additionner ensuite?

Pas mal l'idée

Mais ducoup ça m'oblige à tout faire en manuel est donc pas utiliser les scripts

Share this post


Link to post
Share on other sites
Posted (edited)
il y a 51 minutes, astrototho a dit :

Pas mal l'idée

Ah non, ca sera moins bon que de tout stacker d'un coup.

 

Si tu n'arrives pas a augmenter ta limite, converti tes fits en un seul SER (avec Siril par exemple) et tu n'auras plus de soucis.

Edited by lock042

Share this post


Link to post
Share on other sites

Bonjour,

je  ne connaissais pas cette limite, mais déjà j'ai traité environ 285 images sans problème avec Siril.

J'ai trouvé ça :

https://www.generation-nt.com/reponses/propos-nombre-fichier-ouvert-entraide-290039.html

Bon, ca date de ... 2004 !!

L'explication pour changer de limite est assez proche du grec ancien pour moi ...

Share this post


Link to post
Share on other sites

Bonjour,

 

C'est très simple ! (c'est une blague, rien n'est simple)

 

1) sur ton mac, commence par lancer un "Terminal" on va travailler en ligne de commande (déjà ici on perd normalement environ 60% des utilisateurs de mac qui ne savent pas que la ligne de commande cela existe...).

 

2) Tu peux lancer la commande "ulimit -a" pour listes les "limites" pour ton utilisateur (et le résultat devrait être 256)

   # ulimit -n

   256

 

3) Tu peux temporairement (dans la session du terminal) changer cette valeur, en la passant à 1024 par exemple, puis ensuite lancer Siril toujours dans la même session (si on la lance via son icône du bureau par exemple elle sera lancée dans une autre session qui reste limitée à 256 fichiers)

  # ulimit -n 1024

  # /Applications/Siril.app/Contents/MacOS/siril

 A partir d'ici tu devrais pouvoir verifier si ton problème viens bien e cette limiite

 Pour rendre la modification permanente il faut d'autre actions, toujours aussi simples...

 

EDIT: si tu n'est pas à l'aise avec les manip en ligne de commande, ou si l'usage des permissions "admin" (root) et les risque que cela implique en cas de cause manip t'effraient, ne fais pas l'étape 4

4) Tu dois créer le fichier "/Library/LaunchDaemons/limit.maxfiles.plist", ayant comme propriétaire utilisateur:groupe la valeur root:wheel, ayant les permissions rw-r--r--  (644) et ayant le contenu suivant:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>Label</key>

<string>limit.maxfiles</string>

<key>ProgramArguments</key>

<array>

<string>launchctl</string>

<string>limit</string>

<string>maxfiles</string>

<string>64000</string>

<string>524288</string>

</array>

<key>RunAtLoad</key>

<true/>

<key>ServiceIPC</key>

<false/>

</dict>

</plist>

  A toi de choisir les 2 valeurs limites, ici mes choix 64000 et 524288  (la 1ere c'est la limite soft, le 2eme la limite hard)

  IMPORTANT: pour faire cela tu devrais être ADMINISTRATEUR, enfin être "root" comme vous linux, et là attention, une fausse manip et cela peut être le drame !. Tu peux depuis ton compte utilisateur devenir root via la commande "sudo".

  Une fois le fichier créé avec le bon contenu et les bons droits, pour le faire prendre en compte par le système c'est la commande suivante en ligne de commande:

   # sudo launchctl load -w /Library/LaunchDaemons/limit.maxfiles.plist

 

Et là, si tu fermes ta fenêtre Terminal et tu en ouvres une autre, la commande "ulimit -n" devrait te répondre la valeur que tu a choisi (64000 pour moi)

De même la commande "launchctl limit maxfiles" doit te donner les 2 limites (soft et hard) choisies

 

Cordialement

 

Share this post


Link to post
Share on other sites

Merci beaucoup Keymlinux

Je vais déjà m'arrêter à l'étape 3 et puis on verra pour la suite.... 

Share this post


Link to post
Share on other sites

La conversion en .SER ne change malheureusement rien.

OSX est configuré pour ne pouvoir ouvrir que 256 fichiers simultanément.

On trouve des tutoriels qui permettent d'augmenter cette limite (recherche avec : increas open files limit osx).

 

https://gist.github.com/tombigel/d503800a282fcadbee14b537735d202c

 

Je ne sais plus lequel j'ai utilisé mais maintenant j'ai ca sur ma console

 

 

Capture d’écran 2020-01-01 à 19.48.16.png

Share this post


Link to post
Share on other sites
il y a 5 minutes, mbnb24 a dit :

La conversion en .SER ne change malheureusement rien.

Pas d'accord. Car on ne se retrouve qu'avec un seul fichier. 

Share this post


Link to post
Share on other sites

J'avais essayé à l'époque et le plantage était le même. Es tu sur que Siril n'essaye pas d'ouvrir les images une par une ?

Le seul moyen de régler ce plantage a été de monter la limite de fichiers ouvrables par OSX

 

Share this post


Link to post
Share on other sites

Après, plu son monte le nombre de fichiers à stacker, plus il faut de place disque et de ram (en sachant qu'un ssd travaille vite quand il a beaucoup d'espace vide et ralentit franchement lorsqu'il est presque plein

Share this post


Link to post
Share on other sites
Il y a 2 heures, keymlinux a dit :

lancer Siril toujours dans la même session (si on la lance via son icône du bureau par exemple elle sera lancée dans une autre session qui reste limitée à 256 fichiers)

  # ulimit -n 1024

  # /Applications/Siril.app/Contents/MacOS/siril

 Juste je comprends pas comment ouvrir siril.

Si je vais dans Applications/Siril.app/Contents/MacOS/siril  , le fichier s'ouvre sur TextEdit et il y a juste des lignes de commandes ??????

Share this post


Link to post
Share on other sites
il y a 48 minutes, mbnb24 a dit :

J'avais essayé à l'époque et le plantage était le même. Es tu sur que Siril n'essaye pas d'ouvrir les images une par une ?

Sûr et certain

Share this post


Link to post
Share on other sites
Il y a 3 heures, keymlinux a dit :

C'est très simple ! (c'est une blague, rien n'est simple)

 

Effectivement rien n'est simple !! Surtout cette manip ! :b:

 

Share this post


Link to post
Share on other sites
Il y a 2 heures, astrototho a dit :

 Juste je comprends pas comment ouvrir siril.

Si je vais dans Applications/Siril.app/Contents/MacOS/siril  , le fichier s'ouvre sur TextEdit et il y a juste des lignes de commandes ??????

 

il ne faut pas aller dans le répertoire de Siril , depuis le terminal il faut juste lancer la commande "ulimit -n 2048" pour augmenter temporairement le nombre max de fichiers ouverts pour la session puis la commande "/Applications/Siril.app/Contents/MacOS/siril"

Bien sûr il faut adapter la partie "Siril.app" si tu a installé siril sous un autre nom, avec par exemple un numéro de version comme "Siril.0.9.11.app". Si cela ne lance pas siril mais ouvre le script dans un éditeur tu peux aussi essayer la commande suivante: "/bin/sh /Applications/Siril.app/Contents/MacOS/siril"

 

Share this post


Link to post
Share on other sites

Sous "terminal" j'ai lancé les commandes (après mon nom d'utilisateur)

ulimit-a : command not found

ulimit-n  :  itou

ulimit tout seul : réponse  unlimited  ( ce qui doit expliquer que j'ai pu, de mémoire , traiter environ 285 images ).

Mon iMac est sous macOS Mojave version 10.14.8

Ma manip est elle bonne ?

Share this post


Link to post
Share on other sites

Si tu regardes bien ce qui est écrit, il y'a un espace entre ulimit et le tiret

Share this post


Link to post
Share on other sites

Mince !! Effectivement en mettant un espace j'obtiens (entr'autre) :

open files (-n) : 256

Je me demande si les 285 images n'avaient été traitées avec Pixinsight ... Ca peut jouer ? Ou j'ai une très mauvaise mémoire ....

Share this post


Link to post
Share on other sites
il y a 6 minutes, astrototho a dit :

Je vais réessayer ce matin

Sinon la conversion en SER devrait résoudre ton problème et de façon moins pénible si tu n'y arrives pas.

Share this post


Link to post
Share on other sites
Il y a 22 heures, keymlinux a dit :

ayant comme propriétaire utilisateur:groupe la valeur root:wheel, ayant les permissions rw-r--r--  (644)

comment je fais ça ????

deja, pour créer le fichier plist j'ai copier/coller un fichier plist deja existant que j'ai renommé comme tu l'a écrit.

Puis je l'ai ouvert (avec TextEdit) et copier/coller les lignes de codes que tu m'a marqué.

Share this post


Link to post
Share on other sites

Pour changer les droits lecture/écriture

  #    sudo chmod   644   /Library/LaunchDaemons/limit.maxfiles.plist

 c'est aussi équivalent à 

#    sudo chmod   u=rw,g=r,o=r   /Library/LaunchDaemons/limit.maxfiles.plist

  ce qui signifie: le User propriétaire a un droit en lecture (Read) et écriture (Write), le Groupe propriétaire a un droit de lecture (R) seulement, et les autres (Other) ont un droit de lecture (R) seulement

 

Pour changer le propriétaire user:group

  #   sudo  chown   root:wheel   /Library/LaunchDaemons/limit.maxfiles.plist

 

note: chown = change owner = changer propriétaire  (les commandes unix c'est pas si compliqué, la plupart sont des abréviations des actions voulues énoncées en anglais...) . Bon d'accord, après 25 ans passées à taper des commandes unix c'est plus facile 🙂 

 

Cordialement

Share this post


Link to post
Share on other sites

Le risque principal en étant "root" c'est la fausse manip qui te fais modifier ou supprimer un fichier système VITAL, et là le mac reboot et bloque au démarrage --> cela oblige a passer en mode recovery pour réinstaller le système d'exploitation (on est sur mac, cette partie reste facile et conviviale, on reste sous un environnement graphique, pas de ligne de commande) et après le plus important c'est l'étape où il faut restaurer ses données (où tout ré-installer si pas de sauvegardes !!!). (donc le risque c'est de perdre ses données et ses réglages !!)

Mais en utilisateur averti tu fais des sauvegarde régulièrement... 😉 

Je t'invite à utiliser l'outil TimeMachine fourni en standard sur Mac et qui permet de faire des sauvegarde régulières, soit sur un disque externe (que le mac formate au bon format pour cet usage dédié), soit sur une TimeCapsule (sauvegarde réseau via le wifi ou en réseau filaire) , soit sur un NAS Synology qui se fait passer pour une  TimeCapsule)

Share this post


Link to post
Share on other sites
Le ‎01‎/‎01‎/‎2020 à 18:01, keymlinux a dit :

"/Library/LaunchDaemons/limit.maxfiles.plist

 

Je viens de regarder le fichier "Préférences " de mon Mac.

Dans les fichiers " .plist " il y a un fichier "siril.plist "  (c'est anecdotique !! ) mais aucun ne commence par  / .

 

C'est normal ?

Share this post


Link to post
Share on other sites

Bonsoir,

 

En fait aucun nom de fichier ou de répertoire ne contient "/", c'est un séparateur

"/" c'est la racine (root en anglais), "/Library" c'est le répertoire Library à partir de la racine

"/Library/LaunchDaemons" c'est le sous répertoire "LaunchDaemons" du répertoire principal "Library" à partir de la racine.

Le nom du fichier qui nous intéresse dans ces répertoires et sous répertoires c'est "limit.maxfiles.plist"

 

Donc oui, c'est normal de lister des fichiers qui ne contiennent pas le "/". Les "/" c'est lorsque l'on souhaite faire apparaitre le nom des fichiers avec leur chemin d'accès complet

Share this post


Link to post
Share on other sites
Posted (edited)
il y a 39 minutes, astrototho a dit :

Heureusement qu'on a des connaisseurs ici 😉

 

Oui !!

J'hésite quand même à faire la manip ... Je déteste ne pas comprendre ce que je fais !!

Sinon il me faudra essayer de transformer mes images en  ser , mais là les scripts de Colmic ne fonctionneront plus ..:cry:

Bon, vu le temps ici en ce moment, je ne suis pas prêt d'avoir plus de 250 images à traiter ....

Edited by michelsonia

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.