Jump to content

pb connexion QHY 5III462C (Ekos et FireCapture)


Recommended Posts

Bonjour à tous,

 

J'ai des soucis pour faire fonctionner ma caméra QHY 5III462C.

J'utilise la suite Easy Astro Box donc équivalent à la NafaBox.

 

Tout d'abord j'ai essayé de la faire fonctionner avec les logiciels présents (FireCapture, Kstars-Ekos, ...). Aucune détection de la caméra. Pour Ekos je met QHY CCD dans le profil pour CCD ou Guider.
Elle fonctionne sur windows avec firecapture après avoir mis à jour les drivers avec un installateur tout en un de QHY. https://www.qhyccd.com/download.html

 

J'ai voulu faire la même chose sur l'easy astro box. Voici le lien pour les différentes versions des drivers pour les différentes plateformes https://www.qhyccd.com/html/test_version/
J'ai essayé avec les sdk pour RPI34 (la version "normale" et la version debuginfo). Par ailleurs j'ai cru comprendre qu'il fallait d'abord installer la debuginfo pour ensuite installer la normale ?? J'ai essayé mais j'ai toujours le même problème à savoir :

Lorsque j 'exécute l'installateur "sudo ./install.sh" après avoir fait chmod +x ,pour le rendre exécutable au cas où, et là j'ai un message d'erreur pour trois fichiers.

 

ldconfig : Le fichier /usr/lib/libsbig.so est tronqué


J'ai essayé avec sudo sh ./install.sh et là le problème est que je n'ai pas les permissions d'écrire dans le dossier usr.
J'ai modifié les permissions du dossier /usr/ et de ses sous-dossiers. Puis rebelote avec le message d'erreur des fichiers tronqués.

 

Je pense à une mauvaise installation/modification qui aurait laissé des traces dans ces 3 fichiers tronqués que l'install.sh essaie de modifier.

 

Comment je peux réparer ça ?
J'ai peut-être oublié de tester quelque chose avant d'installer des drivers.

Tout début d'idée sera utile.


Merci.

 

P.S. : je débute sur Linux.

Link to post
Share on other sites

Je vais essayé. Il me semble avoir essayé ce site mais je pense avoir pris une version plus récente que la 20.06.26.

Je suppose que je dois prendre la version arm 32 bits. Par contre c'est quoi la différence entre la version "normale" et la version "debug"

 

J'utilise la fonction  "tar" comme l'archive est un .tgz

 

Merci pour ta réponse.

Link to post
Share on other sites

Ça  ne fonctionne toujours pas. Essayé sur FireCapture et Ekos de toute manière dès que je sélectionne le driver qhy ccd et que je lance le profil caméra branché ou non il crash ( fenêtre affichant le Driver INDi a crashé)..

 

Je suppose que Firecapture sur linux, raspberry utilise les librairies d'indi pour gérer les caméras qhy.

Link to post
Share on other sites

Le site que je te propose est le même que toi, c'est  le site de qhy.

 

Un raspberry pi c'est du 64 bit et pas du 32 bits.

 

La version que je t'ai indiqué est celle qui est recommandée par qhy sur leur page.

 

Si tu as installé une version 32 bits c'est  normal que le driver crash quand tu essaye de le lancer

Edited by philou31
Link to post
Share on other sites

1. Laisse tomber la version débug

2. Télécharge la version 64 bits

3. Est-ce que la commande tar -zxvf genere des erreurs ?

4. Avant de faire un install tape les commandes 

sudo ./uninstall.sh ou sudo ./distclean.sh

 

Si les fichiers ne sont pas exécutables fais un chmod +x avant

5. Relance ton install

 

Edited by philou31
Link to post
Share on other sites

Bon finalement j'ai quand même essayé la version 64 bits, mais ça ne fonctionne toujours pas, INDI crash toujours et FireCapture ne trouve pas de caméra.

J'ai vérifié ma version, je suis bien en 32 bits (armv7l).

 

J'ai toujours les 3 messages (chacun pour une libsbig différente) qui s'affiche : "ldconfig : Le fichier /usr/lib/libsbig.so est tronqué."

 

Ce n'est peut être pas un problème, ce n'est pas affiché en tant que message d'erreur.

J'ai regardé quelques dossiers systèmes et je retrouve bien des fichiers présents dans l'archive (SDK téléchargé), donc l'installation doit bien se faire.

 

Link to post
Share on other sites

J'ai un Pi 4 4GB. Mais la distribution Easy Astro Box est bien en 32 bits selon la commande uname -a.

Je vais peut être passer a un autre système faut que je cherche ce qui fonctionne.

 

Dommage il y avait un truc bien pratique c'est l'activation du hotspot wifi au démarrage pour pouvoir se connecter avec vnc viewver. En nomade quand on a qu'un écran, pc ou tablette, c'est bien utile d'être sûr de pouvoir se connecter dessus.

 

Link to post
Share on other sites

Il y a exactement la même question sur le forum easy astro box avec une réponse de l'administrateur qui dit que EAB a un pb avec cette lib et qu'ils doivent faire une maj.

 

Donc tu as ta réponse depuis 3 jours

 

Edited by philou31
Link to post
Share on other sites

Oui c'est moi qui ai posé la question ;)

 

Je cherchais différents sons de cloche. Car en fouillant sur les forums, notamment INDIlib on constate rapidement que même avec des versions censées être fonctionnelles il y a toujours une manip qui peut être faite dans un ou deux fichiers.

 

Mais oui je vais patienter. Et en attendant je vais tester avec le nouveau Ubuntu 20.04 desktop pour raspberry.

 

Link to post
Share on other sites

Donc finalement ça a fonctionné.

 

Voici ce que j'ai fait :

     Sans utiliser l'utilitaire de mise à jour de l'easy astro box j'ai tapé les commandes suivantes:

sudo apt update
sudo apt upgrade

 

     Puis j'ai suivi les instructions pour installer les librairies INDi avec les drivers tiers (QHY,ZWO,...) sur la page d'INDI pour Raspberry : 

 

Voici les commandes écrites sur cette page :
-------------------------------------

Stable Release

INDI Library is available for Raspbian Buster. To install stable INDI Library, run the following commands:

wget -O -  | sudo apt-key add -
sudo su -c "echo 'deb  buster main' > /etc/apt/sources.list.d/astroberry.list"
sudo apt update

After update is complete, you can install INDI and optionally Ekos :

     1. To Install INDI Library including all 3rd party drivers:

    sudo apt install indi-full gsc

 

    2. To install latest Ekos:

    sudo apt install indi-full kstars-bleeding

    3. To install only INDI Library with basic drivers:

    sudo apt install libindi1 indi-bin

 

Common Errors :

If you receive an error about some package trying to overwrite another, try this:

sudo apt-get -o Dpkg::Options::="--force-overwrite" -f install

----------------------------------


Donc, pour ma part j'ai lancé les 3 lignes de commandes puis l'option 1 pour installer seulement toutes les librairies. Je n'ai pas eu de message d'erreur à l'installation, donc pas besoin d'utiliser la commande décrite en cas d'erreur.

 

Après connexion de la caméra dans EKOS voici les informations depuis l'INDI control panel sous "general info" :

driver info :
          Name: QHY CCD
          Exec : indi_qhy_ccd
          Version : 2.7
          Interface : 22

SDK version : 20.8.26

 

Si j'installe par moi même le bon SDK de QHY, son driver dans EKOS crash à chaque fois.

Par contre pour FireCapture ça ne fonctionne toujours pas. J'ai fait du planétaire dans le froid, dehors avec mon PC, tant pis pour moi. ^_^.

Mais je ne perds pas espoir de trouver une solution.


Je note tout ce que je fais quand ça fonctionne, c'est la base à mon avis avec des systèmes comme LINUX wink lorsqu'on débute.

 

J'espère que ça pourra aider d'autres personnes qui ont des soucis de drivers pour d'autres équipements.

Link to post
Share on other sites
  • 1 month later...

Alors pour Firecapture, malheureusement il n'utilise pas les lib de indi. Les lib qhy+zwo sont inclus dans le soft et ne peuvent pas être mis à jour. Du coup si les versions qu'ils ont mis sont trop vielle et ne supporte pas ta caméra bas ça ne marchera pas temps que le soft n'est pas mis à jour.

 

Je peut te conseillé Oacapture qui est opensource ( on a choisi celui là et pas firecapture dans la NAFABox car on voulais un soft OpenSource).  Dans le git de la NAFABox tu trouvera un script pour l'installer. Tu peut l'utiliser ou juste t'en inspirer pour installer Oacapture sur ta machine ( c'est ça qui est cool dans l'OpenSource ! )

 

Sous Windows Firecapture utilise les sdk donc tu peut les mettre a jour car il ne sont pas inclus dans le soft.

 

Attention les scripts NAFABox sont adapté au système Ubuntu (sur RPI ou non) et donc ne marcheront par sur Raspbian (le système de l'EasyAstroBox). Mais y a pas beaucoup de chose à changer pour que ça marche !

 

Hésite pas si t'as des questions !

Link to post
Share on other sites

Bonjour dragonlost,

 

Merci pour tes suggestions. Oui tout viens d'une mise à jour des librairies et des liens vers celles-ci. J'avais déjà fait pas mal fait de manip mais sans succès.

J'ai trouvé ce sujet sur le groupe firecapture : https://groups.io/g/firecapture/topic/69440028?p=Created,,,20,1,0,0::recentpostdate,,,20,2,0,0&allview=1

 

J'ai réussi à la faire fonctionner avec la beta de la version 2.7.

Maintenant je dois essayer les manips pour la faire fonctionner sur la 2.6, car je trouve que ça lag un peu trop.

Link to post
Share on other sites

Nonobstant faire du planétaire sur un RPI est un peu une gageure.

 

Quand je vois que je suis déjà limite avec mon PC 4 coeurs à 2.8Ghz pour la capture à 2 ms d'expo et avoir le max de fps avec du ROI !

 

Link to post
Share on other sites

Oui sur un PI4 je me vois mal monté au dessus de 60fps. Pour l'instant mes seul tes sont sur une qhy5l-IIc en 25fps via usb2.0 pleine tram ce qui est déjà pas mal et le max que peut fournir le port usb2 de cette cam. J'ai pas de cam en usb3.0 pour faire des tests plus en détail !

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.