Jump to content

Latence liaison wifi avec Vonet


Recommended Posts

Pour améliorer la liaison wifi avec mon RPI4, j'utilise un répéteur Vonet VAP11G-300.

la liaison est bien meilleure, plus puissante. Mais j'ai pas mal de latence entre une action souris à  l'écran et sa réalisation. Le curseur devient soir un gros X ou une petite croix, et je dois attendre le retour du curseur habituel.

D'ou cela peut-il provenir ?

Link to comment
Share on other sites

Il faut que je mette en route. Je teste et j'envoie le résultat.

Voilà le résultat. La première adresse est celle du hotspot Stellarmate en direct, la deuxième en passant par le répéteur Vonet.

 

stellarmate@stellarmate:~ $ ping 10.250.250.1
PING 10.250.250.1 (10.250.250.1) 56(84) bytes of data.
64 bytes from 10.250.250.1: icmp_seq=1 ttl=64 time=0.098 ms
64 bytes from 10.250.250.1: icmp_seq=2 ttl=64 time=0.123 ms
64 bytes from 10.250.250.1: icmp_seq=3 ttl=64 time=0.070 ms
64 bytes from 10.250.250.1: icmp_seq=4 ttl=64 time=0.077 ms
64 bytes from 10.250.250.1: icmp_seq=5 ttl=64 time=0.068 ms
64 bytes from 10.250.250.1: icmp_seq=6 ttl=64 time=0.130 ms
64 bytes from 10.250.250.1: icmp_seq=7 ttl=64 time=0.068 ms
^C
--- 10.250.250.1 ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 265ms
rtt min/avg/max/mdev = 0.068/0.090/0.130/0.026 ms
stellarmate@stellarmate:~ $ ping 10.250.250.249
PING 10.250.250.249 (10.250.250.249) 56(84) bytes of data.
64 bytes from 10.250.250.249: icmp_seq=1 ttl=64 time=9.87 ms
64 bytes from 10.250.250.249: icmp_seq=2 ttl=64 time=5.68 ms
64 bytes from 10.250.250.249: icmp_seq=3 ttl=64 time=4.62 ms
64 bytes from 10.250.250.249: icmp_seq=4 ttl=64 time=4.81 ms
64 bytes from 10.250.250.249: icmp_seq=5 ttl=64 time=10.6 ms
64 bytes from 10.250.250.249: icmp_seq=6 ttl=64 time=9.30 ms
64 bytes from 10.250.250.249: icmp_seq=7 ttl=64 time=7.48 ms
64 bytes from 10.250.250.249: icmp_seq=8 ttl=64 time=6.48 ms
^C
--- 10.250.250.249 ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 19ms
rtt min/avg/max/mdev = 4.622/7.351/10.572/2.180 ms

 

Edited by rmor51
Link to comment
Share on other sites

Question subsidiaire: Pour l'instant le Vonet est installé comme répéteur wifi. Dans la doc sont exposées, 3 méthodes de connexion: Répéteur, wifi bridge et wifi AP. J'avoue que quelques explications sur les 2 dernières ne seraient pas de trop. Merci.

Link to comment
Share on other sites

Le stellarmate c'est ton RPI4? Si oui tu n'as pas lancé les ping depuis le bon endroit. Il faut faire les ping à partir du PC qui te sert à prendre contrôle du PI mais sans te connecter au RPI. 

Le mode bridge sert a diffuser une connexion filaire en Wifi. Un peut comme une clef USB-Wifi, là ça serai Ethernet-Wifi. Le mode Wifi-AP permet la mise en place de hotspot ou de connexion adhoc. 

Link to comment
Share on other sites

J'ai mis en route le RPI4 avec son répéteur,  puis je me suis connecté au Wi-Fi du répéteur depuis mon PC et j'ai effectué les pings.

Comme faire le ping si on n'est pas connecté ?

 

Entre répéteur, bridge et AP, quelle est la meilleure solution ?

Edited by rmor51
Link to comment
Share on other sites

Qui est ce qui s'appel stellarmate? Tu n'as pas pris le contrôle à distance du RPI avant de faire le ping?  Si le ping a bien été tapé depuis la console du PC qui sert a prendre le contrôle à distance du RPI, avec un ping moyen de 7ms, tes problèmes de latences ne viennent pas de ton réseau. Il faut évidement que tout le monde soit connecté sur le même réseau comme d'habitude. Mais il ne faut pas prendre le contrôle à distance du RPI4, sinon ça reviendrai a faire le ping depuis le RPI4. 

Au pire, depuis la même console ping l'IP du RPI4 puis celle du PC qui te sert à prend le contrôle à distance.

Link to comment
Share on other sites

OK pigé ! H'aurais dû y penser moi-même.  Je reviens !

robert@PORTEGE-R930:~$ ping 10.250.250.249
PING 10.250.250.249 (10.250.250.249) 56(84) bytes of data.
64 octets de 10.250.250.249 : icmp_seq=1 ttl=64 temps=0.072 ms
64 octets de 10.250.250.249 : icmp_seq=2 ttl=64 temps=0.066 ms
64 octets de 10.250.250.249 : icmp_seq=3 ttl=64 temps=0.064 ms
64 octets de 10.250.250.249 : icmp_seq=4 ttl=64 temps=0.057 ms
64 octets de 10.250.250.249 : icmp_seq=5 ttl=64 temps=0.071 ms
64 octets de 10.250.250.249 : icmp_seq=6 ttl=64 temps=0.055 ms
^C
--- statistiques ping 10.250.250.249 ---
6 paquets transmis, 6 reçus, 0 % paquets perdus, temps 5119 ms
rtt min/avg/max/mdev = 0.055/0.064/0.072/0.006 ms
robert@PORTEGE-R930:~$ ping 10.250.250.1
PING 10.250.250.1 (10.250.250.1) 56(84) bytes of data.
64 octets de 10.250.250.1 : icmp_seq=1 ttl=64 temps=61.6 ms
64 octets de 10.250.250.1 : icmp_seq=2 ttl=64 temps=4.69 ms
64 octets de 10.250.250.1 : icmp_seq=3 ttl=64 temps=4.93 ms
64 octets de 10.250.250.1 : icmp_seq=4 ttl=64 temps=5.37 ms
64 octets de 10.250.250.1 : icmp_seq=5 ttl=64 temps=5.46 ms
64 octets de 10.250.250.1 : icmp_seq=6 ttl=64 temps=2.43 ms
64 octets de 10.250.250.1 : icmp_seq=7 ttl=64 temps=2.02 ms
^C64 octets de 10.250.250.1 : icmp_seq=8 ttl=64 temps=5.10 ms
64 octets de 10.250.250.1 : icmp_seq=9 ttl=64 temps=4.09 ms
^C
--- statistiques ping 10.250.250.1 ---
9 paquets transmis, 9 reçus, 0 % paquets perdus, temps 8012 ms
rtt min/avg/max/mdev = 2.017/10.632/61.609/18.061 ms

249 c'est en passant par le répéteur Vonet, 1 par le hotspot  du RPI4

Link to comment
Share on other sites

il y a une heure, rmor51 a dit :

Entre répéteur, bridge et AP, quelle est la meilleure solution ?

Chaque mode répond à des besoins différents. 

 

Le résultat du ping correct. J'obtiens des résultats comparable avec mon NUC en Wifi et avec la prise de contrôle à distance de Windows c'est super fluide.  Je ne pense pas ton problème vienne du réseau. Tu utilise quoi pour la prise de contrôle a distance?

 

Edited by Cedric02700
Link to comment
Share on other sites

Vu les délais de latence mesurés, ça devrai être fluide. 

Le Vonet est a côté du RPI? Si oui, il serai peut être intéressant de tenter en mode bridge en le reliant en ethernet au RPI. 

Tu utilise quoi pour prendre le contrôle à distance? VNC ? 

Edited by Cedric02700
Link to comment
Share on other sites

Je suis tombé par hasard sur ce qui suit. Par défaut, je suis en plein écran. Si je réduis un peu la taille de la fenêtre,  la latence semble disparaître. C'est flagrant. Je passe d'un onglet à l'autre presque instantanément.

Link to comment
Share on other sites

attention en branchant le vonet sur les port USB du RPI c'est pas des ports de puissance tu risque de sous alimenter ton vonet ou maltraiter le sport usb de ton PI.
Le mode répéteur utilise les wifi du rpi puis le répète plus fort. le mode bridge ce sert du port Ethernet puis émet un réseaux wifi a partir de celui ci (ne pas utiliser quand le hotspot de ton rpi est activer); Le mode AP c'est pour transformer le vonet en routeur il émet donc son propre réseaux wifi et tout les autres se connecte dessus.

 

Link to comment
Share on other sites

Je l'ai alimenté en 12V, libérant ainsi un port USB du RPI. 

Alimenté par un port USB ne semblait pas poser de probléme. 

Les autres branchements sont la monture, les 2 caméras,  la RAF et un GPS. Sachant que la monture et la RAF sont alimentées en 12V.

Link to comment
Share on other sites

  • 2 weeks later...
Le 25/01/2022 à 09:43, rmor51 a dit :

Je l'ai alimenté en 12V, libérant ainsi un port USB du RPI. 

Alimenté par un port USB ne semblait pas poser de probléme. 

Les autres branchements sont la monture, les 2 caméras,  la RAF et un GPS. Sachant que la monture et la RAF sont alimentées en 12V.

pas de changement sur la latence du coup ?

 

Edited by dragonlost
Link to comment
Share on other sites

Non. En fait, par hasard, j'ai quitté le mode d'affichage maximum de la fenêtre, la latence disparaît !!!!! J'ai agrandi la fenêtre au max,  sans passer en mode maximum.

Link to comment
Share on other sites

Bonjour,

J'ai quelques questions à vous poser ayant essayé le tplink nano qui n'a plus de portée avec le froid, actuellement j'utilise le hotspot du rpi4.

Le Vonet resiste t-il au froid ?

De combien de mètres est sa portée ~ ?

 

Merci d'avance

Link to comment
Share on other sites

Le Vonet a passé quelques nuit dehors, mais pas en dessous de zéro. La portée théorique est de 80-100m sans obstacle.

Pour te donner une idée. Mon setup étant devant la maison au sud, je capte très bien depuis le deuxième niveau de la maison, des combles aménagées. 

Link to comment
Share on other sites

Il y a 5 heures, rmor51 a dit :

Le Vonet a passé quelques nuit dehors, mais pas en dessous de zéro. La portée théorique est de 80-100m sans obstacle.

Pour te donner une idée. Mon setup étant devant la maison au sud, je capte très bien depuis le deuxième niveau de la maison, des combles aménagées. 

Merci ! Du coup ça me tente bien...

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.