Webastro
La communauté de l'astronomie


M
E
N
U


Précédent   Forums d'astronomie Webastro > Le coin des observateurs > Le matériel > Les bricoleurs
Mot de passe oublié? S'inscrire

Les bricoleurs Pour construire soi-même un accessoire utile sans peine.

Astro
Quizz
Jouer
Réponse
 
Outils de la discussion Modes d'affichage
Vieux 16/04/2017, 15h34   #276
Greg34
AstroGeek
Supernova
 
Avatar de Greg34
 
Date d'inscription: janvier 2015
Localisation: Hérault
Messages: 475
Par défaut

Hello !

Je suis encore sur la bidouille

J'ai progressé un peu...j'explique:
J'ai un kali linux monté en virtuel, dessus j'y ai installé un serveur NFS.
Sur la caméra via telnet (port23), je lance ces commandes:
Dans le dossier tmp (autorisé en écriture):
mkdir nfs
mount -t nfs -o nolock 192.168.1.105:/tftpboot /tmp/nfs
ps (pour afficher la liste des processus)
kill 728 (le pid de l'application 'Sofia')
cd /tmp/nfs
Et là, j'ai accès à l'appli via le partage ...
chmod 777 Sofia
./Sofia 127.0.0.1 9578 1 (pour le lancer)

Rien de concret pour le moment, mais c'est déjà un peu plus causant d'autant plus que je peux maintenant copier directement les fichiers de la cam directement dans linux en faisant un simple 'cp' dans le partage

Et tout ça, sans prendre de risques de bricker la caméra !
__________________
Sw150/750-AZEQ6/lulu guide 50mm.Cam de guidage GCMOS01200KPB.
MPCC Mark III-EOS 1000D défiltré partiel par mes gros doigts + Astronomik CLS CCD EOS Clip.
Mes tofs au sw150/750 & divers:http://astrogpu.free.fr/
Greg34 est déconnecté   Réponse avec citation
Vieux 16/04/2017, 15h53   #277
denclout
Membre
Géante rouge
 
Avatar de denclout
 
Date d'inscription: février 2017
Messages: 53
Par défaut

Bonjour,

Super Greg34, je mis connais pas trop en Linux, mais tu sembles le maitriser parfaitement. Pour ma part, j'ai fait une refonte de mon site Web et je travaille et teste mon projet.

http://dc57.ddns.net/

Bye! Merci pour ton retour!
denclout est déconnecté   Réponse avec citation
Vieux 29/04/2017, 13h28   #278
Greg34
AstroGeek
Supernova
 
Avatar de Greg34
 
Date d'inscription: janvier 2015
Localisation: Hérault
Messages: 475
Par défaut

Histoire de donner un peu d'espoir ...

Vu que je suis un testard, je lâche rien !



Pour bidouiller ces caméras en profondeur, il réécrire le firmware car celui est par défaut bridé par le constructeur ou passer par une série de manipulations que j'explique ci-dessous.

Concernant mon chipset, j'ai du télécharger les SDK suivant:
- Hi3518E_V100R001C01SPC081
- Hi3518E_V200R001C01SPC001
- J'en télécharge encore d'autres en ce moment...

Je me suis aperçu que tout était configurable et qu'on pouvait aussi travailler avec des RAW.

De mon coté, j'exécute Pq Tools avec un partage NFS entre la cam et un serveur virtuel linux.
Le problème pour le moment, c'est que le template xml livré avec le soft ne référence pas tous les offsets mémoire qui permettent de modifier certains paramètres comme l'exposition ...

Ce type de modifications restent volatiles mais permettent de visualiser en live les changements apportés.


Si ça peut en mettre quelques uns sur une piste
__________________
Sw150/750-AZEQ6/lulu guide 50mm.Cam de guidage GCMOS01200KPB.
MPCC Mark III-EOS 1000D défiltré partiel par mes gros doigts + Astronomik CLS CCD EOS Clip.
Mes tofs au sw150/750 & divers:http://astrogpu.free.fr/
Greg34 est déconnecté   Réponse avec citation
Vieux 03/05/2017, 23h13   #279
Greg34
AstroGeek
Supernova
 
Avatar de Greg34
 
Date d'inscription: janvier 2015
Localisation: Hérault
Messages: 475
Par défaut

Bonsoir,

Je profite un peu de mes congés pour remettre la main dans le cambouis...
(Je sais pas si le sujet intéresse encore du monde car j'ai l'impression de faire un monologue :=) )

Ca y est ! j'ai réussi à bloquer ma cam suite à une tentative de flashage foiré!
Et pour bien faire les choses tellement je m'en étais donner à cœur joie, j'ai complètement effacé la rom suite à une mauvaise manip. (il était tard ).

Bref, perdu pour perdu je me documente...
(Histoire de faire court)
Je dessoude le SPI fautif (dans mon cas, un MX25L6433F qui affiche MX25L6406E ).
Je sors un arduino (à tout faire) et je le configure en programmateur SPI et je réinjecte la 1ère partition à l'offset 0 (celle qui sert au boot appelé aussi uBoot) car j'avais fait une sauvegarde des blocs mémoires via tftp avant de faire le bourrin.
Je fais un montage horrible pour refaire communiquer la carte mère avec le SPI...
Et bingo, ça marche du tonnerre ! j'ai retrouvé uBoot et la communication Ethernet !
Pour le moment, j'arrive pas à jouer avec les images à flasher de démo fournies avec le SDK car le SPI d'origine est donné pour 8MB
Je vais commander 2/3 SPI pour gonfler le SPI de base afin de pré-programmer des firmwares de base.

Quelques photos (pas de CP vu le ciel pourri xD).

Le SPI sur la cam:


L'arduino en mode prog d'eprom avec le SPI sur une platine de montage:


La bidouille pour rétablir la communication avec le SPI:


Et la vue d'ensemble du bricolage avec un fdti pour la com série avec le PC & la carte:


La suite quand j'aurais reçu de chine les composants...
Pour le moment, j'ai pas avancé...juste compris un peu plus comment ces petites caméras fonctionnaient.

Pour finir, j'avais fait des films et une tentative de stack avec cette cam à base d'IMX255 mais sans travailler avec des RAW, ça perd un peu au niveau rendu ...
Pour 24€+un adaptateur M12 à 16€, ça peut déjà faire une caméra pour le lunaire lowcost à 25 fps.


Pour le moment, ça m'a couté que 24€ avec les fdp...je suis toujours dans le budget d'une potentielle 'AllSky'
__________________
Sw150/750-AZEQ6/lulu guide 50mm.Cam de guidage GCMOS01200KPB.
MPCC Mark III-EOS 1000D défiltré partiel par mes gros doigts + Astronomik CLS CCD EOS Clip.
Mes tofs au sw150/750 & divers:http://astrogpu.free.fr/

Dernière modification par Greg34 ; 03/05/2017 à 23h17
Greg34 est déconnecté   Réponse avec citation
Vieux 03/05/2017, 23h35   #280
provista
Membre
Supergéante rouge
 
Avatar de provista
 
Date d'inscription: août 2009
Localisation: 63.Puy de dôme
Messages: 176
Par défaut

Sisi,
C'est très intéressant,
N'ayant pas les compétences pour aider, je suis quand même avec intérêt ce projet
Bonnes bidouilles 👍
provista est déconnecté   Réponse avec citation
Vieux 04/05/2017, 00h43   #281
Discret68
Membre
Supernova
 
Avatar de Discret68
 
Date d'inscription: mars 2012
Localisation: Aux environs de Colmar (68)
Messages: 678
Par défaut

Citation:
Envoyé par Greg34 Voir le message
Bonsoir,

Je profite un peu de mes congés pour remettre la main dans le cambouis...
(Je sais pas si le sujet intéresse encore du monde car j'ai l'impression de faire un monologue :=) )
Rassures toi, tu as l'impression d'être dans une situation de monologue mais tu as tout un public qui suit de près ce que tu fais, dans un silence respectueux. A part te dire "Vas-y mon gars, fonce et pond nous la allsky du 3ème millénaire pour une poignée d'euros", je ne sais pas trop quoi te dire sur le domaine sur lequel tu phosphore
C'est vraiment pas mon domaine de compétence, et encore si je peux prétendre en avoir un !
__________________
Newton TS ONTC 1212 300 f/d 4 avec FLI PDF et correcteur GPU 2"- Monture 10Micron GM2000HPS - CCD Moravian G2-8300 avec RAF externe. En // : APO TS 80/480 avec focuser 3" et correcteur 3" - CCD QHY10. Plus un Sony A7S en cours de montage !
Mon site internet : http://astrowick.fr/
Discret68 est déconnecté   Réponse avec citation
Vieux 04/05/2017, 01h45   #282
BGI
Membre
Trou noir
 
Date d'inscription: mai 2006
Localisation: Léognan (là où il y a le Pessac-Léognan)
Messages: 925
Par défaut

+1 !!

Bravo !!
__________________
Du jeudi 21 au dimanche 24 septembre 2017, tous aux RAAGSO n'oeuf à Ambeyrac!!!http://www.raagso.fr
BGI est déconnecté   Réponse avec citation
Vieux 04/05/2017, 08h01   #283
gehelem
Membre
Supernova
 
Avatar de gehelem
 
Date d'inscription: septembre 2016
Localisation: Rambouillet (78)
Messages: 405
Par défaut

Je confirme: ton monologue fait salle pleine !
gehelem est déconnecté   Réponse avec citation
Vieux 04/05/2017, 09h40   #284
dagar
Membre
Supergéante rouge
 
Date d'inscription: décembre 2011
Localisation: A l'Est de Tours, Indre et Loire
Messages: 297
Par défaut

Bonjour
On est tous avec toi, désolé de ne pas pouvoir t'aider mais tu sembles être le seul à maîtriser le sujet
Bon courage
__________________
TS 254 F4 - TS 102F5.1 - C8 - 10Micron GM1000 HPS (Poste fixe) - Atik 383l+ mono - autoguidage: DO Lodestar x2
dagar est déconnecté   Réponse avec citation
Vieux 04/05/2017, 11h04   #285
BGI
Membre
Trou noir
 
Date d'inscription: mai 2006
Localisation: Léognan (là où il y a le Pessac-Léognan)
Messages: 925
Par défaut

Oui, pour te rassurer, regarde les stats sur la colonne de droite de la page d'accueil: 28824 vues, 283 réponses, 12 pages !!!
Record absolu de la page #1 du forum Bricolage !!!
__________________
Du jeudi 21 au dimanche 24 septembre 2017, tous aux RAAGSO n'oeuf à Ambeyrac!!!http://www.raagso.fr
BGI est déconnecté   Réponse avec citation
Vieux 04/05/2017, 12h51   #286
Greg34
AstroGeek
Supernova
 
Avatar de Greg34
 
Date d'inscription: janvier 2015
Localisation: Hérault
Messages: 475
Par défaut

Astroghost-Francois a ouvert un bon sujet et à cause de (ou grace à) lui, je passe un temps fou à essayer de bidouiller une cam

Après faut pas croire, je suis loin d'être bon...j'apprends vite et ce que je fais est à la portée de tout le monde.

Histoire d'être plus pointu et d'être mieux équipé, j'ai fait cette commande aujourd'hui pour moins de 10€:

mx25l12835fm2i-10g 0.89x4
https://www.aliexpress.com/item/10PC...a-df1fab6c77e3

socket à tester 1.03x1
https://www.aliexpress.com/item/SOP8...5-4020d725205d

socket à souder 0.80x1
https://www.aliexpress.com/item/Free...5-4020d725205d

programmateur usb 2.17x1
https://www.aliexpress.com/item/1pcs...d-2e704550a656

Je me suis aperçu en fait que le MX25L6406E malgré son datasheet fait bien 8MB...du coup, je passe sur le mx25l12835f qui malgré sa dénomination de 128 est à 16Mo.
En théorie, il devrait être équivalent en terme de fréquence et de tension.

En attendant de recevoir cette petite commande, je vais apprendre à créer un environnement pour pour faire du 'cross compiling' avec le SDK de manière à intégrer les bons drivers avec le firmware.
Ca m'évitera d'avoir des erreurs du genre 'Bad CRC!' 'Wrong Magic..' et j'en passe

Merci d'avoir répondu au sujet ! J'me sens moins seul !
__________________
Sw150/750-AZEQ6/lulu guide 50mm.Cam de guidage GCMOS01200KPB.
MPCC Mark III-EOS 1000D défiltré partiel par mes gros doigts + Astronomik CLS CCD EOS Clip.
Mes tofs au sw150/750 & divers:http://astrogpu.free.fr/
Greg34 est déconnecté   Réponse avec citation
Vieux 04/05/2017, 15h02   #287
Xili
Membre
Supernova
 
Avatar de Xili
 
Date d'inscription: janvier 2013
Localisation: Vaucluse / Paris
Messages: 419
Par défaut

Pareil, je n'y connais rien non plus à ces histoires de micro-programmes, mais j'attends moi aussi avec impatience la camera parfaite que tu vas nous débloquer
__________________
Orion 254/1200 + correcteur GPU 4 lentilles, Orion 80ED, Canon 300mm F4 L IS, Atlas EQ-G go-to modifiée courroies, Canon 500D, QHY5L-IIc, Powermate Televue 2.5x et 5x
Mon site à moi: http://romainlucchesi.com
Xili est déconnecté   Réponse avec citation
Vieux 04/05/2017, 15h30   #288
CecilKris
Membre
Trou noir
 
Avatar de CecilKris
 
Date d'inscription: mai 2016
Localisation: Campagne profonde des Combrailles, ADSL depuis 2016, c'est pour dire !
Messages: 777
Par défaut

Quand tu maitriseras bien le truc, penses à nous faire une CMOS 24x36 12Mpix mono pour 500€ max !

Merci par avance !
__________________
Cecil, C11edge EQ8. .... Kris, Triplet Apo 102/560mm Azeq6 A7s.

ATIK383 + Roue à filtre 2" + Diviseur Optique Low Profile à vendre !
CecilKris est déconnecté   Réponse avec citation
Vieux 04/05/2017, 23h01   #289
Greg34
AstroGeek
Supernova
 
Avatar de Greg34
 
Date d'inscription: janvier 2015
Localisation: Hérault
Messages: 475
Par défaut

Faudrait déjà que j'arrive à changer l'exposition d'une petite cam déjà

Bon déjà, j'ai réussi à réinjecté un linux dans le SPI.
Ci dessous le log (avec un problème) mais déjà ça lance
Code:
U-Boot 2010.06-svn (May 12 2015 - 16:55:46)

DRAM:  256 MiB
Check spi flash controller v350... Found
Spi(cs1) ID: 0xC2 0x20 0x17 0xC2 0x20 0x17
Spi(cs1): Block:64KB Chip:8MB Name:"MX25L6406E"
envcrc 0xb44bde27
ENV_SIZE = 0xfffc
In:    serial
Out:   serial
Err:   serial
Press Ctrl+C to stop autoboot
8192 KiB hi_sfc at 0:0 is now current device

## Booting kernel from Legacy Image at 82000000 ...
   Image Name:   Linux-3.0.8
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2890856 Bytes = 2.8 MiB
   Load Address: 80008000
   Entry Point:  80008000


load=0x80008000,_bss_end=80829828,image_end=802c9c68,boot_sp=807c7168
   Loading Kernel Image ... OK
OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
Linux version 3.0.8 (pub@BVT-SDK-SERVER3) (gcc version 4.4.1 (Hisilicon_v100(gcc4.4-290+uclibc_0.9.32.1+eabi+linuxpthread)) ) #1 Tue Mar 11 17:36:34 HKT 2014
CPU: ARM926EJ-S [41069265] revision 5 (ARMv5TEJ), cr=00053177
CPU: VIVT data cache, VIVT instruction cache
Machine: hi3518
Ignoring unrecognised tag 0x54410010
Memory policy: ECC disabled, Data cache writeback
AXI bus clock 200000000.
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
Kernel command line: mem=64M console=ttyAMA0,115200 root=/dev/mtdblock2 rootfstype=squashfs init=/usr mtdparts=hi_sfc:256K(boot),3M(kernel),3M(romfs),1M(user)
PID hash table entries: 256 (order: -2, 1024 bytes)
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 64MB = 64MB total
Memory: 59472k/59472k available, 6064k reserved, 0K highmem
Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
    DMA     : 0xffc00000 - 0xffe00000   (   2 MB)
    vmalloc : 0xc4800000 - 0xfe000000   ( 920 MB)
    lowmem  : 0xc0000000 - 0xc4000000   (  64 MB)
    modules : 0xbf000000 - 0xc0000000   (  16 MB)
      .init : 0xc0008000 - 0xc0029000   ( 132 kB)
      .text : 0xc0029000 - 0xc0513000   (5032 kB)
      .data : 0xc0514000 - 0xc0537fa0   ( 144 kB)
       .bss : 0xc0537fc4 - 0xc0555240   ( 117 kB)
SLUB: Genslabs=13, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
NR_IRQS:32 nr_irqs:32 32
sched_clock: 32 bits at 100MHz, resolution 10ns, wraps every 42949ms
Console: colour dummy device 80x30
Calibrating delay loop... 218.72 BogoMIPS (lpj=1093632)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
NET: Registered protocol family 16
Serial: AMBA PL011 UART driver
uart:0: ttyAMA0 at MMIO 0x20080000 (irq = 5) is a PL011 rev2
console [ttyAMA0] enabled
uart:1: ttyAMA1 at MMIO 0x20090000 (irq = 5) is a PL011 rev2
bio: create slab <bio-0> at 0
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
cfg80211: Calling CRDA to update world regulatory domain
Switching to clocksource timer1
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
UDP hash table entries: 256 (order: 0, 4096 bytes)
UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
NET: Registered protocol family 1
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
NetWinder Floating Point Emulator V0.97 (double precision)
VFS: Disk quotas dquot_6.5.2
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
JFFS2 version 2.2. (NAND) © 2001-2006 Red Hat, Inc.
fuse init (API version 7.16)
msgmni has been set to 116
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
io scheduler noop registered
io scheduler deadline registered (default)
io scheduler cfq registered
brd: module loaded
loop: module loaded
Spi id table Version 1.22
Spi(cs1) ID: 0xC2 0x20 0x17 0xC2 0x20 0x17
SPI FLASH start_up_mode is 3 Bytes
Spi(cs1):
Block:64KB
Chip:8MB
Name:"MX25L6406E"
spi size: 8MB
chip num: 1
4 cmdlinepart partitions found on MTD device hi_sfc
Creating 4 MTD partitions on "hi_sfc":
0x000000000000-0x000000040000 : "boot"
0x000000040000-0x000000340000 : "kernel"
0x000000340000-0x000000640000 : "romfs"
0x000000640000-0x000000740000 : "user"
Fixed MDIO Bus: probed
himii: probed
usbcore: registered new interface driver rt2500usb
usbcore: registered new interface driver rt73usb
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
hiusb-ehci hiusb-ehci.0: HIUSB EHCI
hiusb-ehci hiusb-ehci.0: new USB bus registered, assigned bus number 1
hiusb-ehci hiusb-ehci.0: irq 15, io mem 0x100b0000
hiusb-ehci hiusb-ehci.0: USB 0.0 started, EHCI 1.00
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
hiusb-ohci hiusb-ohci.0: HIUSB OHCI
hiusb-ohci hiusb-ohci.0: new USB bus registered, assigned bus number 2
hiusb-ohci hiusb-ohci.0: irq 16, io mem 0x100a0000
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 1 port detected
usbcore: registered new interface driver cdc_acm
cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
usbcore: registered new interface driver cdc_wdm
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usbcore: registered new interface driver ums-alauda
usbcore: registered new interface driver ums-datafab
usbcore: registered new interface driver ums-freecom
usbcore: registered new interface driver ums-isd200
usbcore: registered new interface driver ums-jumpshot
usbcore: registered new interface driver ums-sddr09
usbcore: registered new interface driver ums-sddr55
usbcore: registered new interface driver mdc800
mdc800: v0.7.5 (30/10/2000):USB Driver for Mustek MDC800 Digital Camera
mousedev: PS/2 mouse device common for all mice
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
TCP cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 10
NET: Registered protocol family 17
NET: Registered protocol family 15
lib80211: common routines for IEEE802.11 drivers
Registering the dns_resolver key type
registered taskstats version 1
drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
▒VFS: Cannot open root device "mtdblock2" or unknown-block(31,2)
Please append a correct "root=" boot option; here are the available partitions:
1f00             256 mtdblock0  (driver?)
1f01            3072 mtdblock1  (driver?)
1f02            3072 mtdblock2  (driver?)
1f03            1024 mtdblock3  (driver?)
f000             256 romblock0  (driver?)
f001            3072 romblock1  (driver?)
f002            3072 romblock2  (driver?)
f003            1024 romblock3  (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,2)
Backtrace:
[<c0033ff4>] (dump_backtrace+0x0/0x10c) from [<c0403c78>] (dump_stack+0x18/0x1c)
 r6:c0538040 r5:c05382b0 r4:c05382b0 r3:0000000a
[<c0403c60>] (dump_stack+0x0/0x1c) from [<c0403ce0>] (panic+0x64/0x190)
[<c0403c7c>] (panic+0x0/0x190) from [<c0008ef8>] (mount_block_root+0x174/0x228)
 r3:00000001 r2:00000000 r1:c3827f58 r0:c04b5790
 r7:c04b56e0
[<c0008d84>] (mount_block_root+0x0/0x228) from [<c0009050>] (mount_root+0xa4/0xc8)
[<c0008fac>] (mount_root+0x0/0xc8) from [<c00091e0>] (prepare_namespace+0x16c/0x1c4)
 r5:c0024679 r4:c0538040
[<c0009074>] (prepare_namespace+0x0/0x1c4) from [<c0008458>] (kernel_init+0xe8/0x11c)
 r5:c0023c40 r4:c0023c40
[<c0008370>] (kernel_init+0x0/0x11c) from [<c00450a8>] (do_exit+0x0/0x700)
 r5:c0008370 r4:00000000
S'il y a un master linux dans les parages qu'il n'hésite pas à poster.

Avant, avec ma caméra d'usine, j'avais pas accès aux logs maintenant oui
__________________
Sw150/750-AZEQ6/lulu guide 50mm.Cam de guidage GCMOS01200KPB.
MPCC Mark III-EOS 1000D défiltré partiel par mes gros doigts + Astronomik CLS CCD EOS Clip.
Mes tofs au sw150/750 & divers:http://astrogpu.free.fr/
Greg34 est déconnecté   Réponse avec citation
Vieux 05/05/2017, 12h27   #290
GR PALMOS 34
Membre
Protoetoile
 
Date d'inscription: mars 2017
Messages: 2
Par défaut

Bonjour,
je fais partie des " milliers " de fans qui te soutiennent dans tes expérimentations..
je n ais pas de compétences en Linux
si tu as besoin d aides je suis sur Montpellier
mon allsky est fonctionnelle depuis 9 mois et elle attends quelques améliorations....
GR PALMOS 34 est déconnecté   Réponse avec citation
Vieux 05/05/2017, 15h17   #291
denclout
Membre
Géante rouge
 
Avatar de denclout
 
Date d'inscription: février 2017
Messages: 53
Par défaut

Bonjour à tous,

Malgré mon silence, je visite régulièrement le forum.
Je bidouille moi aussi...

Ne lâche pas Greg34 !

Bye!
denclout est déconnecté   Réponse avec citation
Vieux 05/05/2017, 22h20   #292
Greg34
AstroGeek
Supernova
 
Avatar de Greg34
 
Date d'inscription: janvier 2015
Localisation: Hérault
Messages: 475
Par défaut

J'lache rien, j'attends mes pièces !
Me tarde de tester avec le nouvel SPI à 16M...

J'ai mis une vidéo sur youtube de la cam (quand elle marchait encore) au foyer du 150/750 + une barlow X2.
J'ai un sale reflet au centre peut être dû à l'IR ?
(c'était du vite fait à l'arrache mais je voulais en garder un souvenir au cas ou ).

YouTube Video
ERROR: Si vous lisez ce texte, YouTube est hors-ligne ou vous n'avez pas installe Flash
__________________
Sw150/750-AZEQ6/lulu guide 50mm.Cam de guidage GCMOS01200KPB.
MPCC Mark III-EOS 1000D défiltré partiel par mes gros doigts + Astronomik CLS CCD EOS Clip.
Mes tofs au sw150/750 & divers:http://astrogpu.free.fr/
Greg34 est déconnecté   Réponse avec citation
Vieux 07/05/2017, 14h57   #293
Greg34
AstroGeek
Supernova
 
Avatar de Greg34
 
Date d'inscription: janvier 2015
Localisation: Hérault
Messages: 475
Par défaut

En attendant le SPI de 16M je m'amuse avec celle de 8Mb...
J'ai réussi à réinjecter tout le firmware d'origine et ça remarche nickel
Du coup, je joue avec une partition afin de libérer la com avec des outils de débug.
Je peux la planter et la réécrire à volonté sans reprogrammer le SPI.

Déjà le log affiche du bon !
Code:
killall: ittb_stream: no process killed
killall: ittb_control: no process killed
# pqtools:begin to run
port is : 4321
bind ok!
pqtools:server(port:4321)begin to listen
pqtools:Waiting for connection from client!
--------------welcome to HI_HAL_ISP_GetISPRegAttr----------------
======================the chipid is :0x0
s32Port is 2333
bind ok!
the begin of accept
the file is configs/imx138_720p_line.ini
sensor_type: imx138
mode:0
dllfile:libs/libsns_imx138.so
/**********vi_dev************/
input_mod:2
work_mod:0
combine_mode:0
comp_mode:0
clock_edge:1
mask_0:fff00000
mask_1:0
scan_mode:1
data_seq:2
vsync:1
vsyncneg:0
hsync:0
hsyncneg:0
vsyncvalid:1
vsyncvalidneg:0
timingblank_hsynchfb:0
timingblank_hsyncact:1280
timingblank_hsynchbb:0
timingblank_vsyncvfb:0
timingblank_vsyncvact:720
timingblank_vsyncvbb:0
timingblank_vsyncvbfb:0
timingblank_vsyncvbact:0
timingblank_vsyncvbbb:0
fixcode:0
fieldpolar:0
datapath:1
inputdatatype:1
timingblank_vsyncvbbb:0
/**********vi_chn************/
caprect_x:0
caprect_Y:0
caprect_width:1280
caprect_height:720
destsize_width:1280
destsize_height:720
capsel:2
pixformat:19
srcframerate:-1
framerate:-1
/**********vpss_group************/
vpss_pixfmt:19
vpss_dren:0
vpss_dben:0
vpss_ieen:1
vpss_nren:1
vpss_histen:1
vpss_diemode:0
/**********vpss_chn************/
vpss_w:1280
vpss_h:720
/**********isp_image************/
isp_w:1280
isp_h:720
isp_framerate:30
isp_bayer:2
/**********isp_timing************/
isp_wndmode:3
isp_horwndstart:68
isp_horwndlength:1280
isp_verwndstart:20
isp_verwndlength:720
/**********venc************/
rcmode:1
gop:30
stattime:1
vifrmrate:30
targetfrmrate:30
BitRate:4096
FluctuateLevel:1
/**********bind************/
videv:0
vichn:0
vpssgrp:0
vpsschn:0
vencgrp:0
vencchn:0
vodev:0
vochn:0
visnapchn:0
vpsssnapgrp:0
vpsssnapchn:1
vencsnapgrp:1
vencsnapchn:1
/**********vbcnt************/
VbCnt:9
[libmtran version: v0.0.1.0build2014_02_11_S]
HI_MT_Init the mbuf 0's chnid:11
num:0  i:1 Mbuf Init cfg chnid 11 , max connect num 1, bufsize 921600
 libmbuf version: v0.0.1.0build2014_02_11_S
MBUF_Init vschn 11 , mbuf chn 0, buf_size:921600, buf_discard_threshold:1024
vschn 11 (mbufchn 0) user 0: pheader 413e4008 header size 40
pheader 413e4048
init the mbuf success
open data_flag file error
: No such file or directory
MTRANS Init:conn num=1 minport-maxport=5000-6000,pack len=300.
Start HI_VOD_Init.vod Successed.
http Live svr Init ok.
Start MediaTrans.http_streamsvr Successed.
lib file = libs/libsns_imx138.so

[]-<Ittb_VI_Start>(378)Isp init failed!

[]-<Ittb_InitVideo>(390)Ittb_VI_Start failed

[]-<InitFun>(2115)Ittb_InitVideo ERR
http Live DeInit ok ...<MT>Stop MediaTrans.http_streamsvr Successed.
<MT>MediaTrans deinit.
the MT have stop the http server.repeate

[]-<main>(2269)Init fun ERR
--------------welcome to HI_HAL_ISP_GetISPRegAttr----------------
--------------welcome to HI_HAL_ISP_GetISPRegAttr----------------
--------------welcome to HI_HAL_ISP_GetISPRegAttr----------------
--------------welcome to HI_HAL_ISP_GetISPRegAttr----------------
--------------welcome to HI_HAL_ISP_GetISPRegAttr----------------
--------------welcome to HI_HAL_ISP_GetISPRegAttr----------------
--------------welcome to HI_HAL_ISP_GetISPRegAttr----------------
--------------welcome to HI_HAL_ISP_GetISPRegAttr----------------
--------------welcome to HI_HAL_ISP_GetISPRegAttr----------------

[]-<HI_SERVER_START>(2841)Not Init ISP!
J'ai encore des problèmes de drivers mais j'bosse dessus !
__________________
Sw150/750-AZEQ6/lulu guide 50mm.Cam de guidage GCMOS01200KPB.
MPCC Mark III-EOS 1000D défiltré partiel par mes gros doigts + Astronomik CLS CCD EOS Clip.
Mes tofs au sw150/750 & divers:http://astrogpu.free.fr/
Greg34 est déconnecté   Réponse avec citation
Vieux Hier, 11h57   #294
bemo
Membre
Protoetoile
 
Date d'inscription: février 2015
Messages: 6
Par défaut

Bonjour, un peu plus haut dans le forum il est question de cette cam https://fr.aliexpress.com/item/1-3MP-1-0MP-POE-Dome-IP-Camera-960P-720P-Waterproof-Super-Low-0-0001Lux-Day/32550636905.html, est ce la version 2mp ou la 1mp que vous conseillez pour un AllSky ?
Et faut il prévoir beaucoup d'espace de stockage ? Par exemple avec les fréquences que mentionne Cédric combien de stockage accumule t on sur 1 journée ? 1 mois ? etc...
Et si l'on monte au dessus des 2mp, je suppose que l'on va aussi augmenter le stockage en proportion ? En gros quelle taille de capteur conseillez vous pour une AllSky efficace et qui reste abordable ? 70 euros me paraissant correct...
Merci....
Bernard
bemo est déconnecté   Réponse avec citation
Vieux Hier, 20h59   #295
pierrealexandre77
Membre
Géante rouge
 
Date d'inscription: novembre 2009
Messages: 61
Par défaut

Mais c est quoi ces geeks de dingue??? ��

J adore !! Excellent travail, ça me donne plein d idées pour la suite.
pierrealexandre77 est déconnecté   Réponse avec citation
Réponse

Outils de la discussion
Modes d'affichage

Règles de messages
Vous ne pouvez pas créer de nouvelles discussions
Vous ne pouvez pas envoyer des réponses
Vous ne pouvez pas envoyer des pièces jointes
Vous ne pouvez pas modifier vos messages

Les balises BB sont activées : oui
Les smileys sont activés : oui
La balise [IMG] est activée : oui
Le code HTML peut être employé : non

Navigation rapide


Fuseau horaire GMT +2. Il est actuellement 05h32.