Jump to content

Problèmes de scripts sous macOS


Recommended Posts

Bonjour,

 

On ne doit pas être nombreux à utiliser Siril sous macOS mais comme je fais tous mes traitements de photo sous Mac avec Lightroom et Photoshop, je trouve que ça fait sens d'utiliser Siril sur la même machine, donc merci pour la version macOS de Siril 1.02 ! Tout marche relativement bien sous High Sierra et Mojave (j'ai plusieurs machines).

 

Par contre les scripts installés par défaut sur la version Mac de Siril sont en anglais et le nom des dossiers que l'ont doit créer sont différents des scripts français téléchargeables sur la page des scripts : il faut faire un dossier biases au lieu de offsets, lights au lieu de brutes, etc... du coup, c'est très pénible de passer d'un script à l'autre, sachant que les scripts sans Flats ou sans DOF n'existent pas dans la version anglaise. Du coup, j'ai voulu remplacer les scripts anglais par les français et après vérification que le répertoire des scripts les ont bien pris en compte, plus rien ne fonctionne ! Les scripts français semblent incompatibles avec Siril 1.02 sous Mac. J'ai donc réinstallé les scripts anglais...

Link to comment
Share on other sites

Je crois que les scripts français sont disponibles quand on passe siril en français.

 

Si les scripts français (fournis dans l'installation) ne fonctionnent pas sur mac, il faut qu'on les corrige, ce n'est pas normal. Quelle est l'erreur ?

Link to comment
Share on other sites

1 hour ago, vinvin said:

Je crois que les scripts français sont disponibles quand on passe siril en français.

Il me semble que les scripts francais ne s'installent que sur la version Windows et que si on selectionne Francais pendant l'install.

Sur Mac, je crois que c'est le bazar quand on prepare le bundle (et qu'Appple decide d'un jour a l'autre que ce qui passait la veille est absolument ignominieux le lendemain) et que donc, on s'est abstenu de faire encore plus complique (pour nous, et quand je dis "nous" je veux dire @lock042).

 

Par contre, oui, y a pas de raison évidente que les scripts français existants ne soient pas compatibles avec la 1.0.2.

Link to comment
Share on other sites

Posted (edited)

Les script sous mac ne sont qu'en anglais. Pour avoir les français il faut les télécharger sur notre wiki.

 

Si tu as changé les scripts dans le bundle alors c'est normal que plus rien ne marche car l'application est signée. Il ne faut donc pas changer les scripts originaux mais en faire d'autres dans un dossier extérieur au bundle et le dire dans les préférences de siril.

Edited by lock042
  • J'aime 2
Link to comment
Share on other sites

Le 05/06/2022 à 14:35, lock042 a dit :

Si tu as changé les scripts dans le bundle alors c'est normal que plus rien ne marche car l'application est signée. Il ne faut donc pas changer les scripts originaux mais en faire d'autres dans un dossier extérieur au bundle et le dire dans les préférences de siril.

 

Ah oui OK c'est juste, merci ! Je vais faire ça.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.