Jump to content

m27trognondepomme

Membre
  • Posts

    889
  • Joined

  • Last visited

  • Days Won

    7

Everything posted by m27trognondepomme

  1. il suffit de décocher le mode multi-session : ou bien de faire un projet avec des noms différents (en indiquant le temps de pose) :
  2. @MatEX un like particulier pour la dernière image (calcium) dont la texture du soleil me semble mieux résolu. bonne continuation dans l'imagerie solaire
  3. Je pense que tu n'utilises pas la dernière version 1.14.2 .
  4. Bravo pour ce soleil ça fait du bien de voir de nouveau des images de tâches solaires. Je n'ai pas pu sortir ma lunette depuis le 31 décembre.
  5. @dob250, @Jean Louis et @Elgood : Merci pour vos commentaires et like
  6. Avec un peu de retard, je poste ces images du soleil du 30 décembre. Cet après-midi là, j'ai sorti le la lunette et le daystar sans grande conviction au vu d'un soleil encore bien bas. J'ai été agréable surpris par la faible turbulence. Du coup, j'ai enchainé en lumière blanche ( continuum). Ça s'est moins bien passé en k-Line . En premier, les images prises en Ha : les images en lumière blanche (filtre Continuum) et une K-Line en peu plus flou
  7. @keymlinux j'ai trouvé ce lien https://developer.blender.org/T66986 En regardant le patch, j'ai l'impression qu'il faut autoriser : com.apple.security.cs.allow-unsigned-executable-memory pour python2.7
  8. Meilleurs vœux 2022 à tous je commence par une petite animation des tâches AR2916 faite hier matin:
  9. @rmor51 je ne sais pas quoi te dire pour t'aider. Sur ma VM, LXUBUNTU 20.4, je n'ai rien fait de spécial: cloner le dépot pyGapM27, lancer GIMP, configurer les dossiers , puis redémarrer GIMP. sur les copies d'écran, j'ai l'impression que tu pointais sur un vieux répertoire pyGapM27 car le menu "xx Aides xx" n'existe plus depuis belle lurette.
  10. Belle après-midi, j'ai pu sortir le Daystar. une première image de AR2916 , d'autres suivront mais je n'ai pas le temps de les traiter , il prévoit une nuit clair
  11. je viens de tester sous ubuntu en VM . Le fichier "Tools_Moveto.py" existe bien. et la fonction apparait dans le menu ( voir copie d'écran) lubuntu@lubuntu:~$ git clone https://gitlab.com/free-astro/pygap-m27.git Cloning into 'pygap-m27'... remote: Enumerating objects: 2146, done. remote: Total 2146 (delta 0), reused 0 (delta 0), pack-reused 2146 Receiving objects: 100% (2146/2146), 1.54 MiB | 4.93 MiB/s, done. Resolving deltas: 100% (1581/1581), done. lubuntu@lubuntu:~$ ls pygap-m27/ data i18n lib note.txt pythonfu gimp2 intf_gimp2.pyx LICENSE pyGapM27.py README.md lubuntu@lubuntu:~$ ls -l pygap-m27/pythonfu/ total 388 -rwxrwxr-x 1 lubuntu lubuntu 4215 déc. 30 12:30 Color_Accentuation1.py -rwxrwxr-x 1 lubuntu lubuntu 4437 déc. 30 12:30 Color_Accentuation2.py -rwxrwxr-x 1 lubuntu lubuntu 4657 déc. 30 12:30 Color_Accentuation3.py ..... -rwxrwxr-x 1 lubuntu lubuntu 4206 déc. 30 12:30 Tools_LayerDivideFlat2.py -rwxrwxr-x 1 lubuntu lubuntu 2739 déc. 30 12:30 Tools_MaskLayer.py -rwxrwxr-x 1 lubuntu lubuntu 2407 déc. 30 12:30 Tools_MergeAll.py -rwxrwxr-x 1 lubuntu lubuntu 2945 déc. 30 12:30 Tools_MergeChannels.py -rwxrwxr-x 1 lubuntu lubuntu 5408 déc. 30 12:30 Tools_Moveto.py -rwxrwxr-x 1 lubuntu lubuntu 3184 déc. 30 12:30 Tools_SplitChannels2.py -rwxrwxr-x 1 lubuntu lubuntu 3073 déc. 30 12:30 Tools_StackLayers.py lubuntu@lubuntu:~$ J'ai lancé GIMP et mis les configurations des chemins des scripts : J'ai relancé GIMP et la fonction "MoveTo" (Déplacer) apparait bien dans le menu :
  12. il faudrait peut-être modifier le fichier ...\ GIMP 2\lib\gimp\2.0\interpreters\pygimp.interp python=C:\Program Files\GIMP 2\bin\pythonw.exe python2=C:\Program Files\GIMP 2\bin\pythonw.exe /usr/bin/python=C:\Program Files\GIMP 2\bin\pythonw.exe :Python:E::py::python: en mettant les chemins du python3 . ça devient un peu compliqué *** mise à jour *** j'ai fait le test sous windows python=C:\awin\Python\python-3.10.1-64\pythonw.exe python2=C:\awin\Python\python-3.10.1-64\pythonw.exe /usr/bin/python=C:\awin\Python\python-3.10.1-64\pythonw.exe :Python:E::py::python: ça fonctionne le changement de python
  13. @rmor51 peux vérifier si le fichier "pythonfu/Tools_Moveto.py" existe et que les droits en écriture sont -rwxr-xr-x . peux-tu faire dans le dossier pygapm27 : touch *.py */*.py */*scm et relancer GIMP si tu n'as pas le fichier, récupère la dernière version en faisant : git clone https://gitlab.com/free-astro/pygap-m27.git @rmor51 quelle est ta version de ubuntu pour que je puisse faire le test dans un VM ?
  14. je pense que c'est normal car @keymlinux a modifié le fichier "/Applications/Gimp.app/Contents/Resources/lib/python2.7/ctypes/__init__.py". J'attends son retour avec le test en python3. Ce n'est vraiment pas simple de faire une mise au point sans MacOS.
  15. Pour info, J'ai fait un test sur archlinux avec python 2.7.18 , ça marche sans problème.
  16. @keymlinux pourrais-tu faire récupérer la version de la branche dev/macos-py3 sous gitlab . j'ai modifié les entêtes pour appeler python3. ça va me permettre de savoir si le problème est du côté de la version de python.
  17. mince , je ne gère pas pas le chargement de librairie sur MacOS ( TODO) if faudrait tester dans libgimp2.py (ligne:17) if platform == "linux" or platform == "linux2" or platform == "darwin":
  18. as-tu quelle chose dans le fichier $HOME/pyGapM27_stdout.txt ? oups, ça s'est croisé nos réponses c'est pas cool comme erreur . ç'a l'air lié au python 2.7 sur MacOS car sur Windows, je n'ai pas le problème. Je vais creuser le problème. Je reviens vers vous si j'ai une solution.
  19. Pour info sur Archlinux ou ubuntu: il n'y a plus le support 2.7 par défaut mais python3. Mes scripts s'interface en direct aux librairie libgimp-2.0 et libgegl-0.4 en attendant GIMP3. Du coup, je suis compatible python2 et python3
  20. les droits des fichiers python sont bien en execution : -rwxr-xr-x ? dans le fichier pyGapM27.py, peux-tu modifier la ligne 25: sys.stdout = open( os.path.join( myhome , Soft+'_stdout.txt'), 'w') en sys.stdout = open( os.path.join( myhome , Soft+'_stdout.txt'), 'w+') Puis lancer GIMP , et puis regarder le contenu du fichier $HOME/pyGapM27_stdout.txt
  21. @keymlinux si tu fais dans une console : /usr/bin/env python --version tu obtiens quoi ?
  22. En bon informaticien, je suis fainéant: donc si je dois répéter des opérations, je fais des scripts pour ne pas me fatiguer et je fais profiter la communauté Astro. Les plugins solaires me sont bien utiles : coloriser le soleil , mettre une Terre à la bonne dimension, graduer le soleil , accentuer les protubérances. @n.granier Si tu vois les créations des scripts alors est-ce que le dossier scriptfu a-t-il été créé ?
  23. j'ai trouvé le problème: peux-tu recharger la dernière version du plugin sur gitlab. ou faire > cd <path>/pygap-m27 > chmod a+x */*.py @rmor51 c'est le même problème pour toi. Les droits en exécution de certains fichiers n'étaient pas bon car j'ai développé sous windows .
  24. As-tu Python d'installer ? ( sur windows, il est distribuer avec GIMP )
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.