Webastro
La communauté de l'astronomie


M
E
N
U


Précédent   Forums d'astronomie Webastro > Les sciences > Logiciels
Mot de passe oublié? S'inscrire

Logiciels Toutes discussions sur les logiciels d'astronomie: planétariums, traitement d'image, météo pilotage de matériel, jeux...

Astro
Quizz
Jouer
Réponse
 
Outils de la discussion Modes d'affichage
Vieux 28/10/2015, 19h07   #1
lock042
Membre
Quasar
 
Avatar de lock042
 
Date d'inscription: mai 2013
Localisation: Dijon
Messages: 2 217
Par défaut Siril 0.9.3 stable

Bonjour, nous sommes heureux et fier de vous annoncer la sortie officielle de la version stable 0.9 du logiciel Siril.

1 - Présentation :
Siril était supposé être Iris pour Linux (sirI-L). C'est un outil de (pré)traitement d'images pour l'astronomie LIBRE ET GRATUIT, capable de travailler sur des séquences d'images, de les aligner manuellement ou automatiquement, de les empiler et d'améliorer le rendu final.

2 - Installation de la nouvelle version :
Chaque nouvelle version s'accompagne de son lot de paquet "prêt-à-installer". Nous essayons d'en faire le maximum et vous encourageons à vérifier à cette page si un paquet existe pour votre système d'exploitation : http://free-astro.org/index.php/Siril:0.9.0

3 - Nouveautés :
Cette version est le fruit de la reprise du logiciel original par une nouvelle équipe. Il s'agit de la première version dite stable. Elle permet le (pré-) traitement des images (et/ou vidéos) astronomiques, que cela soit en ciel profond ou en planétaire.
Contrairement à ce que pourrait indiquer le nom de la précédente version, 0.9RC1, cette version inclue une grande quantité de nouveauté. Commençant avec cette version stable, un cycle de version plus conventionnel sera adopté par la suite avec des mises à jour de stabilité dans des versions mineures (0.9.1, 0.9.2, ...) alors que la prochaine version stable sera la version 1.0.0.
Une liste détaillée des nouveautés est disponible à cette adresse : http://free-astro.org/bugs/changelog_page.php. Cependant, voici une liste partielle présentant les plus importantes améliorations :

- Undo/redo : La possibilité d'annuler et de rétablir les traitements effectués sur les images a été intégrée dans le but de rendre Siril plus convivial et surtout plus conforme au standard des logiciels modernes. Il est également possible de choisir le dossier dans lequel les fichiers temporaires sont stockés grâce à la fenêtre des paramètres. Par défaut, ces derniers sont stockés dans le dossier /tmp (pour les systèmes GNU/Linux). Il est à noter que ces opérations ne sont possibles que sur les traitements effectués par l'interface graphique et non la ligne de commande.

- Alignement automatique d'images du ciel profond avec prise en charge de la rotation de champ : Indispensable pour effectuer un traitement correct lorsque la mise en station n'est pas parfaite, l'algorithme d'alignement automatique se base sur la méthode des triangles. Tout d'abord Siril cherche des étoiles dans l'image de référence, ensuite l'algorithme principal va construire des triangles à partir des étoiles les plus brillantes. Le but est d'essayer de faire correspondre les triangles, qui sont invariant à plusieurs transformations affines telles que la translation, rotation et le changement d’échelle, les uns avec les autres entre les différentes images. En faisant ceci, Siril détermine l'angle de rotation entre les images ainsi que la translation et le facteur d’échelle (généralement proche de 1.00 lorsqu'il s'agit d'une session prise à partir d'un seul instrument). Un énorme merci à Michael William Richmond pour avoir partagé les sources de son programme et également répondu à mes nombreuses sollicitations.

- Algorithme de tri des images planétaires : Pendant longtemps, Siril a souffert d'un algorithme classant les images planétaires peu fiable. Pour y remédier, il a été décidé d'intégrer une technique qui a fait ses preuves dans nombreux logiciels tels que PIPP, Registax, ou autres : la méthode dite de "gradient". Sans rentrer dans les détails, cet algorithme permet de classer de façon très pertinente les images de planètes possédant quelques détails à la surface. Elle est idéale pour des planètes comme Jupiter ou bien Saturne. Je remercie tout particulièrement Chris Garry (auteur de PIPP) dans l'aide qu'il nous a fourni.

- Amélioration de la parallélisation : Depuis la version bêta, il a été mis un point d'honneur à essayer d'accélérer les étapes les plus longues du processus de traitement des images astronomique. Pour ce faire, nous avons intégrer les calculs à une interface de programmation pour le calcul parallèle : OPENMP. Tout est transparent pour l'utilisateur, même si ce dernier peut décider de réduire à tout moment le nombre de cœur du processeur utilisé. Il est cependant conseiller de garder le maximum de cœurs afin de ne pas amoindrir les performances de Siril.

- Meilleur portage : Il a été accordé une importance toute particulière à la prise en charge du plus grand nombre de distributions de type UNIX. En effet, Siril fonctionne sous les distributions Linux, mais également sous Mac-OS (après quelques manipulations) et FreeBSD. Des utilisateurs nous ont même reporté faire fonctionner Siril sous des architectures ARM de tablette.
EDIT: Depuis 2017, Siril est aussi disponible sous Windows.

- Corrections de bugs : Cette version s'accompagne d'une correction de nombreux bugs reportés par nous et nos précieux bêta-testeurs ainsi que d'autres qui n'était pas répertoriés. La liste des bugs se trouve ici, ainsi que divers commentaires associés, se trouve ici : http://free-astro.org/bugs/view_all_bug_page.php. Si vous rencontrez un bug non répertorié, n'hésitez pas à vous inscrire sur ce site et de détailler le bug. Nous nous ferons un plaisir d'y répondre et de le corriger.

Nous espérons sincèrement que vous prendrez plaisir à utiliser Siril et produirez de beaux clichés.

L'équipe de développement de Siril
__________________
Cordialement, Cyril
Siril, logiciel de traitement d'images astro open-source.

Dernière modification par lock042 ; 11/02/2018 à 09h42
lock042 est déconnecté   Réponse avec citation
Vieux 28/10/2015, 19h28   #2
gastropode
Membre
Supernova
 
Avatar de gastropode
 
Date d'inscription: avril 2014
Localisation: Centre
Messages: 301
Par défaut

Citation:
Envoyé par lock042 Voir le message
Bonjour, nous sommes heureux et fier de vous annoncer la sortie officielle de la version stable 0.9 du logiciel Siril....
Nous espérons sincèrement que vous prendrez plaisir à utiliser Siril et produirez de beaux clichés.
L'équipe de développement de Siril
Merci à toute l'équipe ainsi qu'à ceux qui ont accepté d'aider à cet aboutissement.
Une bonne plate forme : Linux;
Un bon logiciel : Siril.
Reste juste à faire plein de bons clichés...
gastropode est déconnecté   Réponse avec citation
Vieux 28/10/2015, 20h05   #3
Cyp
Membre
Trou noir
 
Avatar de Cyp
 
Date d'inscription: décembre 2003
Localisation: Juliénas (Rhône, 69)
Messages: 1 409
Par défaut

Alors ça, c'est cool ! Je m'empresse de tester cette nouvelle version dès que j'ai quelque-chose à me mettre sur le capteur.

Bravo pour le boulot, et merci pour ce super logiciel
__________________
Site perso : www.cypouz.com
Observatoire Sirene : www.obs-sirene.com
Cyp est déconnecté   Réponse avec citation
Vieux 29/10/2015, 01h22   #4
lock042
Membre
Quasar
 
Avatar de lock042
 
Date d'inscription: mai 2013
Localisation: Dijon
Messages: 2 217
Par défaut

Merci à vous. Pour ceux qui voudraient l'utiliser avec windows, voici une marche à suivre (les performances seront diminuées) disponibles dans ce lien : http://free-astro.vinvin.tf/index.php/Siril:0.9.0/fr
lock042 est déconnecté   Réponse avec citation
Vieux 29/10/2015, 09h49   #5
Eric S
Membre
Quasar
 
Date d'inscription: novembre 2008
Localisation: Grenoble
Messages: 2 222
Par défaut

Citation:
Envoyé par lock042 Voir le message
Pour ceux qui voudraient l'utiliser avec windows, voici une marche à suivre [...]
Merci. Il va falloir que je teste ça, surtout que j'ai déjà VirtualBox avec un Ubuntu dedans installé sur mon PC Windows.
Eric S est déconnecté   Réponse avec citation
Vieux 29/10/2015, 21h32   #6
Greg34
AstroGeek
Supernova
 
Avatar de Greg34
 
Date d'inscription: janvier 2015
Localisation: à 10km au sud d'Annonay
Messages: 608
Par défaut

Merci à toi et à Vinvin (l'anti Delphi ) et aux autres s'il y en a !

J'ai une partition win32...pfff me tâte toujours à la formater pour y installer un linux
Greg34 est déconnecté   Réponse avec citation
Vieux 29/10/2015, 23h50   #7
Traou Mad
Manchot empereur
Supergéante rouge
 
Avatar de Traou Mad
 
Date d'inscription: mai 2012
Localisation: Saturnien d'origine
Messages: 180
Par défaut

Problème de dépendances non satisfaites pour moi (kubuntu 15.10 64 bits) avec le paquet ubuntu, linux mint 64 bits. Du coup, je vais voir la page d'installation pour obtenir de l'aide sur les dépendances et la compilation.
Je fais le
Code:
sudo apt-get -y install autoconf build-essential libgtk-3-dev fftw3-dev libgsl0-dev libcfitsio3-dev libconfig++-dev libtiff-dev libjpeg-dev libraw-dev libffms2-dev libopencv-dev
comme c'est indiqué pour construire les dépendances.
Et paf ! J'ai un message d'erreur :
Code:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Note*: sélection de «*libfftw3-dev*» au lieu de «*fftw3-dev*»
Note*: sélection de «*libtiff5-dev*» au lieu de «*libtiff-dev*»
autoconf est déjà la plus récente version disponible.
build-essential est déjà la plus récente version disponible.
libconfig++-dev est déjà la plus récente version disponible.
libfftw3-dev est déjà la plus récente version disponible.
libgsl0-dev est déjà la plus récente version disponible.
libgtk-3-dev est déjà la plus récente version disponible.
libjpeg-dev est déjà la plus récente version disponible.
libraw-dev est déjà la plus récente version disponible.
libtiff5-dev est déjà la plus récente version disponible.
libcfitsio3-dev est déjà la plus récente version disponible.
libffms2-dev est déjà la plus récente version disponible.
libopencv-dev est déjà la plus récente version disponible.
Vous pouvez lancer «*apt-get -f install*» pour corriger ces problèmes*:
Les paquets suivants contiennent des dépendances non satisfaites*:
 siril : Dépend: libconfig++9 mais il n'est pas installable
         Dépend: libopencv-core2.4 mais il n'est pas installable
         Dépend: libopencv-imgproc2.4 mais il n'est pas installable
         Dépend: libraw9 (>= 0.15.1) mais il n'est pas installable
E: Dépendances non satisfaites. Essayez «*apt-get -f install*» sans paquet
(ou indiquez une solution).
Du coup, j'essaie apt-get -f install ?
__________________
Le kouign amann, c'est trop bon mais ça colle aux oculaires
Sterenn, l'astronomie amateur au pays de Lorient
Traou Mad est déconnecté   Réponse avec citation
Vieux 30/10/2015, 00h49   #8
lock042
Membre
Quasar
 
Avatar de lock042
 
Date d'inscription: mai 2013
Localisation: Dijon
Messages: 2 217
Par défaut

Peut-être que les paquets proposés ici marcheront mieux

https://launchpad.net/ubuntu/xenial/amd64/siril/0.9.0-1
__________________
Cordialement, Cyril
Siril, logiciel de traitement d'images astro open-source.

Dernière modification par lock042 ; 30/10/2015 à 00h51
lock042 est déconnecté   Réponse avec citation
Vieux 30/10/2015, 11h30   #9
vinvin
Membre
Trou noir
 
Date d'inscription: août 2009
Localisation: Alpes-maritimes (06)
Messages: 800
Par défaut

Salut Traou Mad, le message d'erreur n'est pas clair, on ne sait pas pourquoi apt-get ne veut pas installer ces packages. Probablement que le nom du package a changé dans ta distribution, ou leur version. Tu peux les chercher avec
Code:
$ apt-cache search libraw
par exemple, pour installer les bons. Une fois que tu les auras, il faudra peut-être que tu forces l'installation du package ubuntu pour qu'il ne vérifie pas les dépendances, ou que tu attendes que kubuntu en génère un.
vinvin est déconnecté   Réponse avec citation
Vieux 30/10/2015, 23h57   #10
Traou Mad
Manchot empereur
Supergéante rouge
 
Avatar de Traou Mad
 
Date d'inscription: mai 2012
Localisation: Saturnien d'origine
Messages: 180
Par défaut

C'est pas grave, je viens d'installer via les sources... comme je faisais avec les versions précédentes. Je voulais juste tester les binaires, y a un truc qui coince quelque part (ou un truc qui traîne), et pourtant j'ai bien l'impression que mes dépendances sont satisfaites (le plus souvent avec des versions supérieures à celles requises). Mais du moment que ça marche maintenant...
__________________
Le kouign amann, c'est trop bon mais ça colle aux oculaires
Sterenn, l'astronomie amateur au pays de Lorient
Traou Mad est déconnecté   Réponse avec citation
Vieux 30/10/2015, 23h59   #11
lock042
Membre
Quasar
 
Avatar de lock042
 
Date d'inscription: mai 2013
Localisation: Dijon
Messages: 2 217
Par défaut

As tu essayé avec le lien que j'ai donné ?
C'est le lien officiel d'Ubuntu.
lock042 est déconnecté   Réponse avec citation
Vieux 31/10/2015, 00h33   #12
Traou Mad
Manchot empereur
Supergéante rouge
 
Avatar de Traou Mad
 
Date d'inscription: mai 2012
Localisation: Saturnien d'origine
Messages: 180
Par défaut

J'ai été voir, mais vu que c'est la version suivante (16.04) version en développement d'Ubuntu, alors que je ne suis "que" à la version 15.10 de (k)ubuntu qui vient tout juste de sortir, j'ai pas insisté. j'y retournerai à tête reposée.
__________________
Le kouign amann, c'est trop bon mais ça colle aux oculaires
Sterenn, l'astronomie amateur au pays de Lorient
Traou Mad est déconnecté   Réponse avec citation
Vieux 31/10/2015, 00h45   #13
Traou Mad
Manchot empereur
Supergéante rouge
 
Avatar de Traou Mad
 
Date d'inscription: mai 2012
Localisation: Saturnien d'origine
Messages: 180
Par défaut

Et puis c'est quand même bizarre... Je regarde les paquets qui semblent coincer dans le terminal (cf + haut) : libopencv-core2.4v5 est installé, version 2.4.9+dfsg-1ubuntu6, alors que tout à l'heure, ça m'indiquait qu'il n'était pas installable. Pareil pour libconfig++9, j'ai la version 1.5-0.2 d'installée. Quant à libraw, libraw9 n'est pas disponible, mais libraw10 (v 0.16.2-1) est installé...
__________________
Le kouign amann, c'est trop bon mais ça colle aux oculaires
Sterenn, l'astronomie amateur au pays de Lorient
Traou Mad est déconnecté   Réponse avec citation
Vieux 31/10/2015, 13h33   #14
lock042
Membre
Quasar
 
Avatar de lock042
 
Date d'inscription: mai 2013
Localisation: Dijon
Messages: 2 217
Par défaut

Bon, si j'ai le temps je verrai si je peux faire un ou deux paquets (k)ubuntu mais pas avant 2 semaines
lock042 est déconnecté   Réponse avec citation
Vieux 01/11/2015, 23h31   #15
Traou Mad
Manchot empereur
Supergéante rouge
 
Avatar de Traou Mad
 
Date d'inscription: mai 2012
Localisation: Saturnien d'origine
Messages: 180
Par défaut

J'étais de sortie cette nuit, malgré la lune. Pas un nuage. L'occasion de tester encore et toujours mon matériel sous linux. Prises de vue et gestion matérielle avec Kstars, traitement sous Siril, petite retouche avec GIMP 2.9. Ma caméra est une DMK41 plutôt destinée au planétaire...
__________________
Le kouign amann, c'est trop bon mais ça colle aux oculaires
Sterenn, l'astronomie amateur au pays de Lorient
Traou Mad est déconnecté   Réponse avec citation
Vieux 01/11/2015, 23h45   #16
gastropode
Membre
Supernova
 
Avatar de gastropode
 
Date d'inscription: avril 2014
Localisation: Centre
Messages: 301
Par défaut

Citation:
Envoyé par Traou Mad Voir le message
C'est pas grave, je viens d'installer via les sources... comme je faisais avec les versions précédentes. Je voulais juste tester les binaires, y a un truc qui coince quelque part (ou un truc qui traîne), et pourtant j'ai bien l'impression que mes dépendances sont satisfaites (le plus souvent avec des versions supérieures à celles requises). Mais du moment que ça marche maintenant...
Je continue aussi à installer avec les sources.
Les paquets je vous laisse le temps d'avancer tranquillement.
gastropode est déconnecté   Réponse avec citation
Vieux 02/11/2015, 10h53   #17
Traou Mad
Manchot empereur
Supergéante rouge
 
Avatar de Traou Mad
 
Date d'inscription: mai 2012
Localisation: Saturnien d'origine
Messages: 180
Par défaut

Je voudrais rapporter un petit bug mineur chez moi que je contourne en redémarrant SIRIL :
Hier, je devais traiter plusieurs séries de darks. Pour chaque série de dark, je dois éliminer la première image. Donc, pour ma première série, je sélectionne manuellement mes images, SIRIL empile correctement les images sélectionnées. J'ouvre ma deuxième série, je fais ma sélection, et là, c'est le drame : SIRIL refuse obstinément de lire ma sélection personnalisée et empile toutes les images. J'ai beau recommencer, c'est pareil. Le seul moyen que j'ai trouvé est de redémarrer.
Visiblement, il doit y avoir un schmurtz dans la gestion des opérations mémorisées ou de la purge mémoire, j'ai aussi un petit bins un peu similaire pour le compositage rgb. Je traite mes séquences rgb séparément, et j'ai tout intérêt à redémarrer SIRIL avant de passer au compositage, sinon, les canaux s'affichent incorrectement dans la fenêtre grey chanels images. De mémoire, au lieu d'avoir les canaux R, V et B qui s'affichent, j'ai NB et deux couleurs. Je peux reproduire le bug si besoin est.
__________________
Le kouign amann, c'est trop bon mais ça colle aux oculaires
Sterenn, l'astronomie amateur au pays de Lorient
Traou Mad est déconnecté   Réponse avec citation
Vieux 02/11/2015, 11h58   #18
lock042
Membre
Quasar
 
Avatar de lock042
 
Date d'inscription: mai 2013
Localisation: Dijon
Messages: 2 217
Par défaut

Pour ton premier problème, il ne faut pas oublier dans l'onglet stacking, de changer la combobox pour dire d'empiler uniquement les images sélectionnées.
lock042 est déconnecté   Réponse avec citation
Vieux 02/11/2015, 13h01   #19
Traou Mad
Manchot empereur
Supergéante rouge
 
Avatar de Traou Mad
 
Date d'inscription: mai 2012
Localisation: Saturnien d'origine
Messages: 180
Par défaut

Oui, c'est ce que j'avais fait! Par contre, j'ai essayé de reproduire le bug ce matin, rien n'y fait, ça marche nickel...
__________________
Le kouign amann, c'est trop bon mais ça colle aux oculaires
Sterenn, l'astronomie amateur au pays de Lorient
Traou Mad est déconnecté   Réponse avec citation
Vieux 02/11/2015, 22h44   #20
lock042
Membre
Quasar
 
Avatar de lock042
 
Date d'inscription: mai 2013
Localisation: Dijon
Messages: 2 217
Par défaut

Bon voila, j'ai créé un paquet Ubuntu 15.10. En fait le problème venait du fait que Linux Mint (17.x) est synchronisée sur Ubuntu 14.04 LTS. Donc j'ai refais un paquet pour Ubuntu 15.10, disponible ici : http://free-astro.vinvin.tf/index.php/Siril:0.9.0
__________________
Cordialement, Cyril
Siril, logiciel de traitement d'images astro open-source.

Dernière modification par lock042 ; 02/11/2015 à 22h51
lock042 est déconnecté   Réponse avec citation
Vieux 09/11/2015, 00h18   #21
vinvin
Membre
Trou noir
 
Date d'inscription: août 2009
Localisation: Alpes-maritimes (06)
Messages: 800
Par défaut

Après les 10 jours habituels de latence après l'entrée dans unstable, Siril a été migré dans testing ! A vos debians !
vinvin est déconnecté   Réponse avec citation
Vieux 09/11/2015, 12h52   #22
Cyp
Membre
Trou noir
 
Avatar de Cyp
 
Date d'inscription: décembre 2003
Localisation: Juliénas (Rhône, 69)
Messages: 1 409
Par défaut

Super !
__________________
Site perso : www.cypouz.com
Observatoire Sirene : www.obs-sirene.com
Cyp est déconnecté   Réponse avec citation
Vieux 09/11/2015, 18h01   #23
lock042
Membre
Quasar
 
Avatar de lock042
 
Date d'inscription: mai 2013
Localisation: Dijon
Messages: 2 217
Par défaut

Par contre, aux utilisateurs de debian (et autres aussi). Il faut bien installer libgsl 1.16 et non la version 2.0.
Nous nous sommes rendu compte que le code de siril n'est pas compatible avec les changements opérés dans la dernière. Du coup, je travaille là-dessus
__________________
Cordialement, Cyril
Siril, logiciel de traitement d'images astro open-source.
lock042 est déconnecté   Réponse avec citation
Vieux 03/12/2015, 14h01   #24
lock042
Membre
Quasar
 
Avatar de lock042
 
Date d'inscription: mai 2013
Localisation: Dijon
Messages: 2 217
Par défaut

Bonjour tout le monde.

Petit message pour vous annoncer la sortie de la version 0.9.1.
Peu de changement, surtout 2 bugs corrigés, dont un qui peut toucher les utilisateurs de mac (car ils ont des librairies mises à jour très régulièrement dans macport).

EDIT : comme à chaque sortie, des paquets sont proposés sur le site.

Bonne journée
__________________
Cordialement, Cyril
Siril, logiciel de traitement d'images astro open-source.
lock042 est déconnecté   Réponse avec citation
Vieux 12/12/2015, 12h51   #25
lock042
Membre
Quasar
 
Avatar de lock042
 
Date d'inscription: mai 2013
Localisation: Dijon
Messages: 2 217
Par défaut

Bonjour tout le monde.

Siril continue son petit bonhomme de chemin et est en train de se voir doter de la fonction STF Autostretch que l'on retrouve chez PixInsight et qui est tant apprécié des utilsateurs.

Voici une vidéo résumant les différents types de mode de visualisation proposés par Siril.
J'ai utilisé pour cela l'image L de M33 proposée par Nicolas Outters sur WA (j'espère que cela ne pose pas de soucis).

http://free-astro.vinvin.tf/videos/STF2.webm

Bonne journée
__________________
Cordialement, Cyril
Siril, logiciel de traitement d'images astro open-source.
lock042 est déconnecté   Réponse avec citation
Réponse

Outils de la discussion
Modes d'affichage

Règles de messages
Vous ne pouvez pas créer de nouvelles discussions
Vous ne pouvez pas envoyer des réponses
Vous ne pouvez pas envoyer des pièces jointes
Vous ne pouvez pas modifier vos messages

Les balises BB sont activées : oui
Les smileys sont activés : oui
La balise [IMG] est activée : oui
Le code HTML peut être employé : non

Navigation rapide


Fuseau horaire GMT +2. Il est actuellement 00h26.