lock042

Siril 0.9.9

Recommended Posts

il y a 20 minutes, vinvin a dit :

Mais pour ça il faut un PC sous windows vista

Sachant que c'est Vista qui m'a définitivement fait passer sous Linux ... ca viendra pas de moi ;)

Share this post


Link to post
Share on other sites

Ok les gars, pas de soucis, vous avez déjà pas mal de boulot entre les windaubes et les différentes distris linux, je comprends. De toute façon, je shoot pas en ce moment, j'aurais peut-être changé d'OS à ma prochaine session 😉.

 

Cordialement

Edited by leduc09

Share this post


Link to post
Share on other sites

Bonjour

Peut-être cela a été déjà évoqué, dans ce cas toutes mes excuses.

Ma question est la suivante: avec SIRIL, pour empiler un grand nombre d'images d'un même objet céleste , peut-on "mélanger" des brutes issues de sessions réalisées avec plusieurs imageurs (APN en ce qui me concerne), avec des ISO différents, éventuellement optiques variées ?

Si oui, quid des darks, flats et offsets ? Lesquels choisir ou écarter ?

Je dois préciser que j'ai essayé, et soit ça plante (tailles d'images différentes), soit ça marche mais le résultat ne semble pas génial (problème de flat ?)

Merci par avance.

Patrick

Edited by patrick cartou
un oubli important

Share this post


Link to post
Share on other sites

Concernant mes problèmes de points noirs. J'ai testé les 3 premiers scripts de Colmic. Ma conclusion: celui avec correction cosmétique pose problème sur les couches vertes et bleues (la rouge n'est pas impactée).

ça donne ça avec le script2 (prétraitement avec correction cosmétique) Ce sont les centres d'étoiles qui sont impactés (donc pas un problème de dark)

 

100D astrodon, filtre CLS, zoom x4 sur une zone de la couche verte

 

1809220502073028315906178.jpg

 

En RVB, ça donne des points rouges bien moches au coeur des étoiles ( comme V et B = zéro) Pareil avec un A7S. Donc, à mon avis, ça ne vient pas de la qualité du signal enregistré sur le capteur.

 

Donc, de mon coté je n'utilisai pas la correction cosmétique. Je ne sais pas s'il y a un bug dans le script ou s'il faut utiliser avec précaution la correction cosmétique qui dans mon cas rajoute des parasites ingérables!

 

Bon maintenant, je vais pouvoir traiter toutes mes images de ces dernières semaines avec ce logiciel si pratique avec les scripts. :) Encore bravo à toute l'équipe pour ce logiciel qui a je n'en doute pas encore de grandes marges de progression!:):) Et puis merci à Colmic pour ses scripts et son tuto, complet, qui simplifie la vie des photographes qui ne savent pas (ou plus) traiter au mieux ses images!

 

JP

Share this post


Link to post
Share on other sites
Il y a 23 heures, patrick cartou a dit :

, peut-on "mélanger" des brutes issues de sessions réalisées avec plusieurs imageurs

Oui, c'est théoriquement possible, mais alors je ne conseille pas de le faire en script :).

Chaque session doit être traitée séparément.

il y a 46 minutes, mejean a dit :

Ma conclusion: celui avec correction cosmétique pose problème sur les couches vertes et bleues (la rouge n'est pas impactée).

ça donne ça avec le script2

Peux tu me donner une image prétraitée sans correction cosmétique, histoire que je l'applique pour voir ?

C'est pas normal ces points noirs.

Share this post


Link to post
Share on other sites
il y a 8 minutes, lock042 a dit :

Oui, c'est théoriquement possible, mais alors je ne conseille pas de le faire en script :).

Chaque session doit être traitée séparément.

Peux tu me donner une image prétraitée sans correction cosmétique, histoire que je l'applique pour voir ?

C'est pas normal ces points noirs.

Tu veux le résultat d'un empilement sans correction cosmétique ou 1 image individuelle? C'est peut être parce que ce sont des images en champ large (focales entre 85 et 135 mm), avec pleins d'étoiles, que ça fait des drôles de trucs?

 

JP

Share this post


Link to post
Share on other sites
Il y a 17 heures, lock042 a dit :

Une image seule pretraitée et non dematricé.

OK, pas le temps ce soir, je t'envoie ça demain

 

Edit: lien envoyé sur ton mail.

  • J'aime 1

Share this post


Link to post
Share on other sites
il y a une heure, lock042 a dit :

Je viens de tester, je n'ai pas de soucis.

 

OK! :)

 ça peut venir du script de Colmic? Mais dans ce cas, il s'en serait aperçu,non?  Il y a pas mal de choix dans le menu de la correction cosmétique, est ce qu'il y a un truc qui pourrait créer des artéfacts? Le fait que je ne les vois que sur 2 des 3 couches, tu n'aurais pas une idée? Qu'est ce que ça ferait si "CFA" n'est pas coché alors que ce n'est pas un capteur monochrome?

 

JP

 

 

Share this post


Link to post
Share on other sites
il y a une heure, mejean a dit :

 ça peut venir du script de Colmic? Mais dans ce cas, il s'en serait aperçu,non?

 

Bon je veux bien m'être gaufré pour la traduction -bias en -offset, mais faudrait pas quand même m'accuser de tous les maux hein :D

Surtout que chez moi tout fonctionne parfaitement. Jamais vu une seule fois ces points noirs dans mes étoiles.

 

La dernière fois que j'ai vu ça chez quelqu'un, il a refait ses flats (avec les bons scripts) et comme par miracle les points noirs ont disparu...

 

Es-tu bien certain d'avoir récupéré les derniers scripts corrigés ? Va vérifier la date des fichiers dans C:\Programmes\SiriL\scripts :

 

image.png.0b653fb884b9086becb975e79a318dc9.png

 

Share this post


Link to post
Share on other sites

Des points noirs au milieu des étoiles ? J'ai déjà connu ça, et ça datait de bien avant les scripts... Ça fait loin, mais il me semble que c'était un curseur un peu trop poussé ou une option cochée qui n'aurait pas dû l'être, mais oui, il me semble bien que c'était au niveau du pré-traitement. (les flats, c'est une bonne piste)

Share this post


Link to post
Share on other sites

Pour les points noirs c'est Biactol

(Oui je l'ai déjà faite)

Share this post


Link to post
Share on other sites
il y a 35 minutes, gehelem a dit :

Pour les points noirs c'est Biactol

(Oui je l'ai déjà faite)

et ça marche en ligne de commande ?

 

Share this post


Link to post
Share on other sites
il y a 4 minutes, Traou Mad a dit :

et ça marche en ligne de commande ?

 

Si le miroir de ta salle de bain est équipé d'un terminal, oui.

  • Haha 1

Share this post


Link to post
Share on other sites
Il y a 22 heures, Colmic a dit :

 

Bon je veux bien m'être gaufré pour la traduction -bias en -offset, mais faudrait pas quand même m'accuser de tous les maux hein :D

Surtout que chez moi tout fonctionne parfaitement. Jamais vu une seule fois ces points noirs dans mes étoiles.

 

La dernière fois que j'ai vu ça chez quelqu'un, il a refait ses flats (avec les bons scripts) et comme par miracle les points noirs ont disparu...

 

Es-tu bien certain d'avoir récupéré les derniers scripts corrigés ? Va vérifier la date des fichiers dans C:\Programmes\SiriL\scripts :

 

 

 

 

Non, je me doute bien que ça marche bien de ton coté, tu aurais vu le loup! Ce que je ne comprend pas: si c'est un problème de dark ou flat, en prenant les  mêmes images (bruts, darks,offset, flat), en lançant tes 3 premiers scripts, l'un après l'autre, pourquoi seul le script 2 donne ce résultat dégueu? Je me demande s'il n'y a pas un truc qui n'est pas pris en compte par ton script sur ma machine? (genre un onglet qui n'est pas modifié comme il faut) Je ne suis pas du tout informaticien, donc c'est peut être de grosses conneries que je dis!

J'irais voir le fil cité, et sinon oui j'ai mis à jour les scripts dès que j'ai vu l'info sur la MAJ!

Concernant les flats, j'ai parfois une des couches qui est limite surex en partie mais la luminance est comme il faut. Je crois me souvenir que la couleur n'a pas d'importance pour les flats?

 

 

Share this post


Link to post
Share on other sites
il y a 52 minutes, mejean a dit :

J'irais voir le fil cité, et sinon oui j'ai mis à jour les scripts dès que j'ai vu l'info sur la MAJ!

 

Il y a eu une incompréhension les premiers jours avec la MAJ, j'ai donné le mauvais lien dans mes posts, car Cyril avait changé le nom du fichier d'install.

Donc il est important de vérifier les dates de tes scripts comme mentionné au-dessus.

Share this post


Link to post
Share on other sites
Le 25/9/2018 à 00:03, Colmic a dit :

 

Il y a eu une incompréhension les premiers jours avec la MAJ, j'ai donné le mauvais lien dans mes posts, car Cyril avait changé le nom du fichier d'install.

Donc il est important de vérifier les dates de tes scripts comme mentionné au-dessus.

J'ai vérifié: la date de création des scripts installés correspond à celle que tu mentionnes.

 

J'ai refait de nouveau un test avec de nouvelles images (sur 30 images). Résultat du script 2 toujours plus mauvais que celui du script 1, toujours ces points noirs présents avec la correction cosmétique (très présents en visu 2:1). En fait les points noirs correspondent à des étoiles "supprimées" par la correction cosmétique. Finalement, j'arrive à avoir du stareater!😄

 

Voici 2 ex:

script 1, couche verte visu 2:1

1809260915573028315912742.jpg

 

script 2, couche verte visu 2:1

 

1809260915573028315912741.jpg

 

 

D'où peut venir ces problèmes de mon coté? A la base, les brutes ne sont pas hyper belles, les nuits étaient chaudes. Et j'image en ville, donc PL présente malgré la présence de filtre.

Ou il y a des critères sur la cosmétique, qui ne sont pas universels?

Share this post


Link to post
Share on other sites

Une petite requête : je préfère passer pour un imbécile que de ne pas demander.

 

Pour mon truc de script de livestacking qui commence à marcher un peu, je convertis des RAW (par exemple), ne serait-ce que pour les débayérisationner.

En gros je fais les prétraitements image par image, avec ce genre de script :

setext fits
convertraw current 
preprocess current -cfa -debayer

mais mais mais, ces commandes marchent avec des séquences.

Donc, la combine c'est que je duplique mon image pour avoir une séquence de deux images que je peux prétraiter.

Et je n'en récupère qu'une seule... l'autre c'est poubelle.

 

= >  Je cherche une idée plus efficace, parce que bien entendu ça double le temps de prétraitement...

je rêve de pouvoir avoir des séquences d'une seule image, ou de pouvoir utiliser les commandes convertraw et preprocess sur une image au lieu d'une séquence...

je rêve ?

Share this post


Link to post
Share on other sites

Je peux essayer de rendre possible le pretraitement sur une seule image en ligne de commande pour la prochaine version.

Share this post


Link to post
Share on other sites
il y a 46 minutes, lock042 a dit :

Je peux essayer de rendre possible le pretraitement sur une seule image en ligne de commande pour la prochaine version.

Alors ça ce serait le bonheur...

Mais faut pas non plus que ça te prenne trop de temps, on est sur un marché de niche.

Avec le convertraw ??

Share this post


Link to post
Share on other sites
Il y a 10 heures, gehelem a dit :

Avec le convertraw ??

Ben ca c'est censé marchee avec une image

Share this post


Link to post
Share on other sites
il y a 57 minutes, lock042 a dit :

Ben ca c'est censé marchee avec une image

ah merci !!!

je n'avais pas essayé en spécifiant le nom du fichier, trop classe

Share this post


Link to post
Share on other sites

Y a pas a specifier de nom d'entré. La commande prend tout ce qu'il y a dans le dossier.

Share this post


Link to post
Share on other sites
Le ‎22‎/‎09‎/‎2018 à 18:17, lock042 a dit :

Oui, c'est théoriquement possible, mais alors je ne conseille pas de le faire en script :).

Chaque session doit être traitée séparément.

Peux tu me donner une image prétraitée sans correction cosmétique, histoire que je l'applique pour voir ?

C'est pas normal ces points noirs.

 

Merci bien pour la réponse !

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai un pb avec la commande SEQCROP sur une séquence d'images de la Lune : la fonction me génère bien des fichiers nommés cropped_*.fit, mais qui pèsent chacun 3ko et sont affichés comme le "printscreen" en attache, que ce soit sur des images FIT dématricées ou non.

Par contre aucun pb avec la fonction CROP sur chaque image individuelle.

!No comprendo! :bang:

Où est mon erreur ?

Merci d'avance !

Stéphiou.

 

 

Capture2.JPG

Capture1.JPG

cropped_pp_Cosme48_DarkWSC43Mat_LIGHTS_00002.fit

Share this post


Link to post
Share on other sites

Je crois qu'il y a bien une erreur avec cette commande, chez moi elle ne fait rien du tout.

Par contre tu peux utiliser la façon graphique de faire la même chose, qui devrait mieux marcher : sélection dans l'image puis clic droit dans l'image et crop séquence.

Merci de nous avoir prévenu.

Share this post


Link to post
Share on other sites

pour ma part, sur mon imac, je n'ai pas accès aux scripts alors que ca fonctionne sur mon pc portable

 

Share this post


Link to post
Share on other sites
il y a 35 minutes, mbnb24 a dit :

pour ma part, sur mon imac, je n'ai pas accès aux scripts alors que ca fonctionne sur mon pc portable

 

As tu bien récupérer le dernier dmg dispo sur notre site  ? 

Share this post


Link to post
Share on other sites

@vinvin pour une fois que je voulais utiliser la ligne de commande et ne pas faire "l'assisté"... :p

@mbnb24 pour l'instant la fonction SEQCROP n'est pas scriptable en dern version de SIRIL sous Win10, en attendant il y a quand même une solution en script qui marche --> "cropper" les images une par une en enchaînant le bloc de 3 fonctions (LOAD/CROP/SAVE) suivant, par ex :

LOAD *_0001.fit

CROP x y dx dy

SAVE cropped_*_0001.fit

LOAD *_0002.fit

CROP x y dx dy

SAVE cropped_*_0002.fit

...

Cela demande une certaine dextérité ds le "copier-coller", sinon un ami kiné :be:

Avec Notepad++, recommandé par Lock042 je crois, c'est quand mm bien pratique !

Edited by Stéphiou

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.