Jump to content
Colmic

TUTORIAL pour le traitement complet d'une image APN avec les scripts SIRIL et PHOTOSHOP

Recommended Posts

Il y a 11 heures, vinvin a dit :

La mémoire est estimée à 7G pour 16 d'installés, t'as laissé le facteur 0.5 dans les paramètres non ? Si tu ne fais pas trop de trucs en même temps tu peux réessayer avec 0.9 environ pour voir si ça va plus vite et à quel point il en bouffe :)

D'un autre coté, en donner moins à siril permet d'en donner plus à la mémoire cache du système, donc ça pourrait aussi améliorer la charge I/O et faire que ça va plus vite dans la globalité... Ca dépend de la machine je suppose.

Le traitement a été fait avec 0,9 comme limite. En dehors du fait que ça a pris 3h30 pour aboutir, ça s'est très bien passé.

Il faut à présent que j'apprenne les bases du traitement, parce que, là, j'y vais un peu à tâtons. Et c'est un peu gâcher, avec un tel logiciel.

Share this post


Link to post
Share on other sites
Posted (edited)

Bon j'abandonne avec SiRiL, je n'ai pas résultat exploitable avec ou sans DOF ça ne change rien même au delà de 100, les images sont tellement bruitées que les résultats sont décevants, l'A7S est censé être un super appareil même avec un empilement de 400 photos de 30sec à 2500 iso le résultat est vraiment décevant, je vais passer sur Pixinsight pour voir parce que là SiRiL après des jours et des jours de tests absolument aucun résultat que j'obtiens n'est exploitable (j'utilise un pc dédié avec un disque dur M2 de 250Go et 8Go de DDR4 pour le traitement SiRiL donc j'en ai lancé des tas de traitements...)

Quand je vois des photos passer avec des A7S je me dis que soit mon capteur déconne (j'en doute) soit mon matos est nul (EQ6-R Pro et une TS Optics 80/560 doublet de PA) Soit moi ciel est possédé par les enfers mais là encore je vis en campagne et le ciel est plutôt correct ou alors je n'ai rien compris à SiRiL.

Ce logiciel m'a juste frustré.

Edited by QualQuek

Share this post


Link to post
Share on other sites
Posted (edited)

Des tas de gens font de chouettes images avec un A7S et Siril 😃.

Donc oui, c'est tout à fait possible.

Edited by lock042

Share this post


Link to post
Share on other sites

Une chose m'échappe, je trouve de tout sur internet mais sur le cas de l'A7S ils conseillent de shooter avec des iso relativement élevé mais avec des temps court, il y a un exemple d'un empilement de photos faites à l'A7S à 51000 iso de 5 sec et le résultats est juste dingue, pourtant j'ai cru comprendre qu'il fallait faire des temps de pose de 30sec pour éviter le star eater et au dessus de 2000iso, alors quoi je j'ai rien compris non plus? Si cela ne vient pas de SiRiL c'est clairement que je ne l'utilise pas correctement ou que je prends pas les photos correctement mais ça me rend dingue de n'arriver à rien avec ce que je shoot.

Par exemple ce site explique plutot bien comment réduire le bruits des images avec des iso élevé : https://www.diyphotography.net/find-best-iso-astrophotography-dynamic-range-noise/

Du coup je ne sais plus quoi penser, la seule photos que j'ai réussi à faire et qui était jolie c'était M42 et je shootais à 800 iso...

Donc voilà au secours!

Share this post


Link to post
Share on other sites

Je n'ai pas l'A7S donc je ne peux trop dire. Cependant, à trop booster les ISO on perd en dynamique. Ca, c'est sûr. Du coup tu peux te retrouver a un stade ou tu perds en couleurs (surtout au niveau des étoiles).

@Colmic a cet APN si je ne m'abuse. Il pourra t'éclairer.

Share this post


Link to post
Share on other sites

Sur le A7S, Le star eater s’active pour les poses de plus de 30s. Donc à 30s et en dessous en mode manuel, pas de star eater.

 

@Thierry Legault peut en dire plus sur les ISO avec ce boîtier. Mais on trouve les renseignements aussi sur son site me semble-t-il.

 

Share this post


Link to post
Share on other sites
Posted (edited)

@ QualQuek : De ce que je crois avoir compris, ce sont les dark les plus importants - qu'on me corrige si je suis dans l'erreur -.

Et ça semble être confirmé par une série à 800 iso pour laquelle j'ai fait 40, 20 et 10 brutes à 30, 60 et 120 s, mais seulement 10, 10 et 10 dark de chaque. Parce que je voulais gagner du temps.

Alors, oui, Siril a fait des miracles, mais il ne faut pas lui en demander plus que ce qui est possible.

Sur la photo en question, on voit très nettement le bruit, alors que sur une précédente, toujours 800 iso pour 40, 20 et 10, de brutes et dark aussi, toujours à 30, 60 et 120 s, le bruit est beaucoup plus discret, sauf à pousser ensuite en post-traitement.

Mon équipement, c'est celui-ci :SA-APN.thumb.jpg.0dc329d7a026b088005e22ba9d636ba7.jpg

 

Ainsi que tu peux le constater, très en-dessous de ce que tu utilises.

J'ai un fils de 9 ans, en pleine découverte, et à qui je répète souvent : «Mons fils, lorsque tu ne parviens pas à faire quelque chose, soit tu t'y prends mal, soit c'est impossible ; et, si on te demande de le faire, c'est que c'est possible.»

Edited by FalCT60

Share this post


Link to post
Share on other sites

Salut @QualQuek

Un petit topo rapide sur le A7S :

- il faut impérativement shooter en mode normal (surtout pas en mode BULB) à cause de ce fameux star-eater qui transforme le fond de ciel en une mélasse infâme dès qu'on active le BULB

- par conséquent les temps de pose sont limités à 30s maxi (en mode normal donc) mais qu'on se rassure, 30s ça suffit amplement pour sortir les faibles nébulosités

- on shoote également au-delà de 2000 ISO car c'est à 2000 ISO que se déclenche le premier ampli du capteur qui réduit fortement le bruit de lecture

- on n'a pas forcément d'intérêt à monter à plus de 2500 ou 3200 ISO car plus tu vas monter en ISO plus tu vas perdre en dynamique, et le A7S est dit ISOless (on ne gagne rien du tout à monter à part réduire la dynamique)

- ceci dit le seul cas où il est intéressant de monter en ISO, c'est pour des temps de pose très courts, pour ceux qui ont des dobson non motorisés ou des APN sur pied photo

- on peut shooter en mode shutter mécanique ou électronique (le mode dit silencieux), on perd juste 1 bit de dynamique en mode silencieux mais perso j'ai jamais vu la différence sur mes images, et ça permet de préserver un peu le déclencheur mécanique

- il est important de désactiver tous les modes de réduction de bruit (RB longue pose, etc..) du A7S

- évidemment on fait des darks, flats et offsets dans les règles

- il est TRES important de faire du dithering avec le A7S, sinon tu feras apparaître les fameuses trames à cause du bruit télégraphique

- pour cela il faut autoguider avec option dithering ou alors faire quelques appuis sur la raquette aléatoirement toutes les 3 ou 4 poses

 

En respectant ces quelques règles tu peux espérer sortir des trucs du genre. 

Toutes ces images ont été traitées avec SiriL et le process décrit dans ce tuto.

Tu as le descriptif des temps de pose et ISO dans le nom des images (clic sur l'image pour avoir la full) :

 

M31FSQ106-304x30s-3200iso-14082018b.jpg

 

M42_siril0_9_11.jpg

 

M45-FSQ106-121x30s-3200ISO-15082018.jpg

 

America_FSQ106_180x30s_11082018.jpg

 

doubleamas_FSQ106_62x30s_3200iso.jpg

 

B33-FSQ106-109x30s-3200iso.jpg

Share this post


Link to post
Share on other sites

@Colmic

J'ai shooté M66 à 30 sec à 2500 iso (360x30sec) sur une eq6-r pro avec une lunette apo doublet ts optics 80/560 fpl53 lanthane.

J'ai fais 65 dark et 100 flat & offset

J'ai bien du dithering qui décale de temps en temps la prise.

Le résultat est celui que tu as vu en haut sous SiRiL sur la page précédente, je ne comprends pas pourquoi c'est aussi moche, tu sais quoi si tu veux je te met à disposition toutes mes brutes, dark flat et offset et tu me dis si tu as un meilleur résultat sous SiRiL.

Share this post


Link to post
Share on other sites

Tu parles de M66 ou de M106 ?

Parce que celle que je vois page précédente, c'est ça :

m106_brute.PNG

 

Si ta brute montre ça, alors ne t'entête pas à faire des galaxies, c'est très difficile de sortir des choses correctes avec un APN à F/7.

 

Moi à F/5 j'ai jamais eu de résultats mirobolants sur galaxies, alors à F/7 c'est encore plus difficile. 

Ici ta brute montre que tu n'atteins pas forcément les 3 sigmas sur une pose unitaire, dès lors tu pourras faire autant de poses que tu voudras, ton bruit sera toujours là au final.

Le A7S est très sensible, mais ya des limites quand même ! Surtout que F/7 ça commence à devenir compliqué en 30s de pose seulement.

 

M101 couleurs pas top, et je suis à F/5 :

M101_fsq106_60x30s_60x60s_3200iso.jpg

 

M51 couleurs pas top :

M51-FSQ106-F8-149x30s-3200iso.jpg

 

M63 c'est le mieux que j'ai réussi à sortir :

M63-FSQ106-78x30s-3200iso.jpg

 

Pour comparaison avec la même lunette et l'ASI183, avec même un peu moins de temps de pose total (mais des poses de 120s unitaires)

M63_FSQ106_F5_Altair183ProTec-15_37x120s

 

Share this post


Link to post
Share on other sites

Ha d'accord je comprends mieux, je n'aurais jamais de résultats satisfaisants à F7, du coup ça serait plus judicieux pour moi de passer ma lunette en lunette de guidage et de prendre newton 200/800 je ne pense pas pouvoir monter un 250/1000 sur la eq6-r pro le poids sera trop élevé je pense.

Du coup pour l'a7s je devrais plutôt me concentrer sur les nébuleuses et les amas ou les grands objets, tes images sont quand même moins bruité que les miennes mais bon t'as aussi une lunette de dingue...

Share this post


Link to post
Share on other sites

Oui c'est surtout l'A7S je pense, comme il ne faut pas dépasser les 30sec de pose. Parce que même à F/7,5 (80ED sans réducteur), on obtient de très bonnes choses sur les galaxies. 

 

Après, si je peux me permettre un conseil, ça ne fait pas si longtemps que tu as ton nouveau matos de mémoire (j'avais vu passer tes messages quand tu l'avais acheté), et à la lecture de tes posts sur ce topic, peut être serait-il judicieux d'apprendre à bien le maitriser avant de repartir de suite sur encore plus gros parce que tu n'es pas satisfait des premières images... Quand on voit ce que font certains avec des setup bien moins bons, on peut se dire que notre marge de progression est énorme :) (je m'intègre également dedans) le problème ne vient pas toujours uniquement du matos... 

Share this post


Link to post
Share on other sites

C'est plutôt la faible ouverture de la lunette (FD/7) qui ne me permet pas d'exploiter pleinement l'A7S et de récupérer du signal comme l'a souligné Colmic car avec l'A7S 30sec maxi.

Bon au moins je sais d'où ça vient car je ne comprenais pas je pensais pouvoir avoir plus de signal.

@Colmic petite question d'ailleurs car j'ai remarqué que j'avais tendance à sous-exposer les objets car sinon l'image apparaissait cramée une fois l'empilement fait sous SiRiL j'imagine que c'est aussi une erreur?

Share this post


Link to post
Share on other sites
Posted (edited)

@ Colmic : Tu ne devrais pas publier de telles photos (celles de ta première réponse) : j'en ai pour des jours à éponger la bave sur mon bureau ! 🤣

À un niveau moindre, voici ce que j'ai pu réaliser avec mon matériel et Siril :

NGC2024_01.jpg

 

Toujours 40, 20 et 10 poses à 30, 60 et 120 s à 800 iso.

Je me suis contenté de recadrer et de décaler un peu l'histogramme sous darktable, après avoir effectué le traitement selon le tuto.

Edited by FalCT60

Share this post


Link to post
Share on other sites
Posted (edited)
il y a 20 minutes, QualQuek a dit :

qui ne me permet pas d'exploiter pleinement l'A7S

Ah oui, je ne dis pas que l'A7S est mauvais, vu ce que font les astrams avec... C'est juste la combinaison des deux qui rend difficile les galaxies. Parce qu'à F/7,5 on a de très bon résultats sur les galaxies :) 

 

Un livre qui m'a beaucoup, beaucoup aidé 

 

image.png.4351019339f27856d861275914d5046f.png

 

J'ai vu que tu t'étais procuré Les secrets de l'astrophoto du même auteur, qui est très bien aussi, mais dans Astrophotographie il va davantage en profondeur pour l'astrophoto avec instruments Astro. 

 

En tous cas te souhaite bonne persévérance ;) 

 

Colmic ta prise avec M42 + la tête à cheval est fabuleuse  ! 

Edited by Drase

Share this post


Link to post
Share on other sites
il y a 53 minutes, QualQuek a dit :

C'est plutôt la faible ouverture de la lunette (FD/7)

Siril est donc innocent :D.

  • Haha 1

Share this post


Link to post
Share on other sites
Posted (edited)

@lock042 Je reviens sur mes dires, j'ai trouvé exactement d'où vient le bruit sur mes images et c'est bien SiRiL qui en responsable, plus précisément l'extraction du gradient.

Voilà 2 photos de M66 avec le même traitement SiRiL sauf que la première n'a pas d'extraction du gradient la seconde oui, si tu es capable de me dire pourquoi ça me fait ça sur mes images...

 

Sans extraction du gradient

sans_gradient.PNG

 

Avec extraction du gradient

avec_gradient.PNG

Edited by QualQuek

Share this post


Link to post
Share on other sites

Ce sont des vues en étirement automatique ou en linéaire ? Tu as bien mis des points partout pour enlever le fond de ciel ? C'est avec quelle version ? Est-ce qu'il y a des étapes de traitements après avoir enlevé le gradient de fond de ciel ?

Share this post


Link to post
Share on other sites

Ce sont des capture d'écran de l'image TIFF affiché en plein écran, j'utilise SiRiL dernière version, l'extraction du gradient est fait comme indiqué dans le tuto, j'enlève consciencieusement les points vert des galaxies et aux alentours proches.

Oui il a des étapes après mais cela ne dégrade rien de plus c'est immédiatement après l'extraction du gradient que l'image est dégradée puisque les images ont exactement le même traitement exception faite de l'extraction du gradient...

Share this post


Link to post
Share on other sites
Posted (edited)

Oui ben c'est normal.

Ce genre d'opération apporte du bruit déja.

Ensuite il faut aussi pas s'en tenir aux paramètres par défaut. La on voit que tu as des rebonds sur les bords de l'image.

Il faut jouer avec les paramètres. Tout ne s'obtient pas en un click.


Et puis tu es en vu autoajustement. Donc une fois que tu as applatit l'image avec l'extraction de gradient ca fait ressortir plus de détail. C'et normal aussi.

Quand on étire l'histogramme la encore il faut le faire manuellement, et pas en auto.

 

Bref, rien de choquant la

Edited by lock042

Share this post


Link to post
Share on other sites
Posted (edited)

En fait, ton flat a été très mal fait (reste de poussières et vignettage visible).

Or, une extraction de gradient n'arrivera jamais a récupérer un flat mal fait.

 

Citation

Je reviens sur mes dires, j'ai trouvé exactement d'où vient le bruit sur mes images et c'est bien SiRiL qui en responsable

Donc non, je ne suis pas d'accord.

Edited by lock042
  • J'aime 1

Share this post


Link to post
Share on other sites
Posted (edited)

En fait durant mes test cette image a été faite sans DOF (j'essayais avec DOF, sans , avec 10 DOF, 100 DOF etc...) ce qui explique les défauts.

Je ne suis pas en vue ajustement, c'est une capture d'écran de l'image TIFF finale enregistrée après traitement complet SiRiL.

Mais je comprends bien qu'il faut pas non plus suivre tout bêtement sur le tuto il faut ajuster en fonction de ce que l'on a, je suis satisfait de SiRiL je remarque juste que l'extraction du gradient me dégrade considérablement l'image en mettant beaucoup de bruit, mais pas grave je peux faire l'extraction plus finement sur Photoshop..

Edited by QualQuek

Share this post


Link to post
Share on other sites
Posted (edited)
il y a 7 minutes, QualQuek a dit :

En fait durant mes test cette image a été faite sans DOF (j'essayais avec DOF, sans , avec 10 DOF, 100 DOF etc...) ce qui explique les défauts.

Ben oui, donc c'est normal. Et il me semble hasardeux de tirer des conclusions quand on utilise pas toutes les images :)

 

Tu remarqueras que tu crois que le bruit augmente, mais c'est faux. Le signal est également plus présent. C'est juste que l'image a été applatit. Et qu'il ne faut absolument pas se fier au mode de visualisation auto ajustement.

 

EDIT : par contre les rebonds disgracieux sont dû aux problème des flats. L'extraction de gradient essaye d'enlever le vignettage avec un polynome qui n'est pas adapté à la situation.

Edited by lock042

Share this post


Link to post
Share on other sites

Alors pas d'accord j'ai une image de M101 avec 100 DOF et l'extraction du gradient me fait exactement la même chose...

Share this post


Link to post
Share on other sites
il y a 1 minute, QualQuek a dit :

Alors pas d'accord j'ai une image de M101 avec 100 DOF et l'extraction du gradient me fait exactement la même chose...

As tu essayé de :

- mieux positionner les échantillons

- changer l'ordre du polynome

 

Ici clairement le manque de flat est le problème. Mais il peut y avoir addition de plusieurs problème.

  • J'aime 1

Share this post


Link to post
Share on other sites

Je vais essayer, en tout cas merci de prendre du temps pour m'aider, je me doute bien qu'un truc ne doit pas être bons sur mes photos pour que SiRiL me fasse ça mais j'essaye de comprendre quoi.

Share this post


Link to post
Share on other sites
Il y a 1 heure, lock042 a dit :

As tu essayé de :

- mieux positionner les échantillons

- changer l'ordre du polynome

 

Ici clairement le manque de flat est le problème. Mais il peut y avoir addition de plusieurs problème.


As tu des préconisations pour le placement des échantillons et le choix de l’ordre du polynôme ? Je suis dans une zone avec beaucoup de PL et c’est pareil pour moi, le retrait de gradient avec Siril me donne toujours des images très curieuses avec des zones bizarres. Pourtant les flats sont corrects.

Share this post


Link to post
Share on other sites
Posted (edited)
il y a 32 minutes, Fred_76 a dit :


As tu des préconisations pour le placement des échantillons et le choix de l’ordre du polynôme ? Je suis dans une zone avec beaucoup de PL et c’est pareil pour moi, le retrait de gradient avec Siril me donne toujours des images très curieuses avec des zones bizarres. Pourtant les flats sont corrects.

 

Je n'ai pas réussi avec SiRiL ou je ne m'y prends pas correctement, en revanche sous photoshop ça me prend 2 minutes @Fred_76 

  1. Importe ton image dans photoshop, sélectionne toute ton image (édition => copier), copie là et fait nouveau => image et colle ton image du presse-papier.
  2. Ensuite utilise l'outil correcteur (dureté à 0 et épaisseur adaptée) en sélectionnant une zone neutre de ton image en appuyant sur ALT et applique le en effaçant tes galaxies par exemple
  3. Une fois les éléments que tu souhaites conserver ont été enlevés applique le filtre bruit => antipoussière met la valeur du rayon à 70 environ et le seuil à 0, te voilà avec un pseudo-flat
  4. retourne sur ton image de base importée et va dans image=>appliquer une image => sélectionne ton image sans titre sur laquelle tu as appliqué le filtre antipoussière et choisi la méthode opération "soustraction" et règle le décalage, perso j'utilise 35

Et TADA! Voilà ton gradient extrait de ton image, franchement le résultat est pas dégueue et tu peux traiter ton image comme tu l'entends ou finir sous Lightroom.

Edited by QualQuek
  • Merci / Quelle qualité! 1

Share this post


Link to post
Share on other sites
il y a une heure, QualQuek a dit :

 

Je n'ai pas réussi avec SiRiL ou je ne m'y prends pas correctement, en revanche sous photoshop ça me prend 2 minutes @Fred_76 

  1. Importe ton image dans photoshop, sélectionne toute ton image (édition => copier), copie là et fait nouveau => image et colle ton image du presse-papier.
  2. Ensuite utilise l'outil correcteur (dureté à 0 et épaisseur adaptée) en sélectionnant une zone neutre de ton image en appuyant sur ALT et applique le en effaçant tes galaxies par exemple
  3. Une fois les éléments que tu souhaites conserver ont été enlevés applique le filtre bruit => antipoussière met la valeur du rayon à 70 environ et le seuil à 0, te voilà avec un pseudo-flat
  4. retourne sur ton image de base importée et va dans image=>appliquer une image => sélectionne ton image sans titre sur laquelle tu as appliqué le filtre antipoussière et choisi la méthode opération "soustraction" et règle le décalage, perso j'utilise 35

Et TADA! Voilà ton gradient extrait de ton image, franchement le résultat est pas dégueue et tu peux traiter ton image comme tu l'entends ou finir sous Lightroom.

 

Très bonne méthode, plus efficace que celle que j'utilisais (étapes 1 et 2 identiques) mais à l'étape 3, application d'un flou gaussien pour avoir un dégradé régulier, puis soustraction de cette couche à l'image d'origine et réglage du décalage/exposition.

 

Mais j'essaye quand même avec Siril car dès fois (rarement) ça marche très bien.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.